Installation problem 0.19_pre: CFD dependency check fails

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

User avatar
oliveroxtoby
Posts: 500
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Installation problem 0.19_pre: CFD dependency check fails

Postby oliveroxtoby » Thu Mar 25, 2021 5:36 am

Roland wrote: Wed Mar 24, 2021 11:14 pm
oliveroxtoby wrote: Mon Mar 22, 2021 7:14 pm
Roland wrote: Sun Mar 21, 2021 4:12 pm I am still getting an issue. Upon running the solver, OpenFOAM gives this message:
16:41:08 --> FOAM Warning :
From void* Foam::dlLibraryTable::openLibrary(const Foam::fileName&, bool)
in file db/dynamicLibrary/dlLibraryTable/dlLibraryTable.C at line 188
Could not load "libmomentumTransportModels.so"
Error 948576: `y
This can be ignored for now. It was a quick fix for compatibility with OpenFOAM v8. I'll sort it out properly when I get some time.
Hi Oliver,

Perhaps I found the cause of this error. Upon inspection of controlDict, I saw this code at file end:
libs
(
// Needed for availability of porous baffle boundary in potentialFoam
"libturbulenceModels.so"
"libmomentumTransportModels.so"
);
I'm not sure what this means. Perhaps a reminder for you as a coder of a task to do? Or a typo?

Anyway, I just reported it here for in case that it could be of help.

Best regards,

Roland
Hi Roland

I fixed the issue a couple of days ago - please update your workbench.
User avatar
Roland
Posts: 303
Joined: Fri Aug 21, 2015 2:20 pm

Re: Installation problem 0.19_pre: CFD dependency check fails

Postby Roland » Thu Mar 25, 2021 9:02 pm

Code: Select all

I fixed the issue a couple of days ago - please update your workbench.
Shall do. Thx!
oat
Posts: 1
Joined: Thu Apr 29, 2021 4:18 am

Re: Installation problem 0.19_pre: CFD dependency check fails

Postby oat » Thu Apr 29, 2021 4:26 am

The problem also recently happened to me. However, I can solve it. Let's try this. Instead of installing the openfoam in the FD preference, download and run the OpenFOAM® MinGW and install Microsoft MPI. You will be asked to install Microsoft MPI, when installing the openfoam.