[Strange BUG] Array of Structure Do No Export - If There is a Clone !?

This forum section is only for IFC-related issues
paullee
Posts: 1688
Joined: Wed May 04, 2016 3:58 pm

[Strange BUG] Array of Structure Do No Export - If There is a Clone !?

Postby paullee » Wed May 01, 2019 1:54 pm

Hi, this seem weird :D

This make array to be used in multi-storey building problematic...

How to reproduce?
  1. Created a Structure say a column base on a sketch
  2. Create an Array say in X direction
  3. Create another Array say in Z direction
  4. Not sure if this concern or not - put these Arrays into BuildingPart
  5. Select BuildingPart and Export to IFC
  6. Both Array exist - just use FC to open - no problem/bug so far ...
Now below create the bug ...
  1. Select either Array (say that in X direction) and make a Clone by clicking the Clone button
  2. Select BuildingPart and Export to IFC again
  3. The Array with A Clone created is not in the IFC Export :!: :!: :!: :?: :?: :?:
  4. Special Remarks - I have not selected the Clone for the Export...
.

FreeCAD_0.18-16110-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage
on
Fedora 29


IFC exported with All Arrays
Screenshot from 2019-05-01 21-38-00.png
Screenshot from 2019-05-01 21-38-00.png (209.98 KiB) Viewed 236 times
.
FCStd - Array in X direction with a Clone Created
Screenshot from 2019-05-01 21-38-20.png
Screenshot from 2019-05-01 21-38-20.png (184.02 KiB) Viewed 239 times
.
IFC - Array in X direction Disappeared
Screenshot from 2019-05-01 21-40-12.png
Screenshot from 2019-05-01 21-40-12.png (201.39 KiB) Viewed 239 times
Last edited by paullee on Wed May 01, 2019 2:27 pm, edited 4 times in total.
paullee
Posts: 1688
Joined: Wed May 04, 2016 3:58 pm

Re: [Strange BUG] Array of Structure Do No Export - If There is a Clone !?

Postby paullee » Wed May 01, 2019 2:04 pm

FCStd - 2 Arrays of Structure .

FCStd - Array in X-Direction Cloned .

IFC - 2 Arrays of Structure - Exported OK .

IFC - Array of Structure in X-Direction - DISAPPEARED
paullee
Posts: 1688
Joined: Wed May 04, 2016 3:58 pm

Re: [Strange BUG] Array of Structure Do No Export - If There is a Clone !?

Postby paullee » Wed May 01, 2019 2:15 pm

Further Test -
  1. Now if I select the BuildingPart / 2 Original Arrays of Structures
  2. + Select the Clone
  3. Export to IFC + Open the IFC in FC
Result -
  1. The Array in Z-direction - which is not Cloned - export OK as in last test
  2. The Array in X-direction - which is Clone - Not Appear as in last test
  3. The Array Clone (Array in X-Direction) - Just has 1 object rather than array of them
FCStd file
Screenshot from 2019-05-01 22-09-10.png
Screenshot from 2019-05-01 22-09-10.png (173.47 KiB) Viewed 226 times
.
Exported IFC
Screenshot from 2019-05-01 22-10-10.png
Screenshot from 2019-05-01 22-10-10.png (200.87 KiB) Viewed 226 times
Screenshot from 2019-05-01 22-10-14.png
Screenshot from 2019-05-01 22-10-14.png (200.07 KiB) Viewed 226 times
Attachments
Study_ Point Office Block_ 01_branch_15___ Array_ 4 with Clone_ Select Arrays & Clone.ifc
(8.41 KiB) Downloaded 4 times
User avatar
yorik
Site Admin
Posts: 11496
Joined: Tue Feb 17, 2009 9:16 pm
Location: São Paulo, Brazil
Contact:

Re: [Strange BUG] Array of Structure Do No Export - If There is a Clone !?

Postby yorik » Thu May 02, 2019 7:22 pm

There was a problem with the ArchCommands.pruneIncluded() function, whose job is to remove from a list of objects all the objects that are actually parts of another object, so they are not exported twice. This function indeed removed objects that were part of an object that is outside the export set, which obviously is wrong. I fixed that a couple of weeks ago, what version are you using?

I actually also just fixed another bug in that function, it considered a cloned object as a component of the clone, which is obviously wrong too. Fixed in git commit 5c700f76e
paullee
Posts: 1688
Joined: Wed May 04, 2016 3:58 pm

Re: [Strange BUG] Array of Structure Do No Export - If There is a Clone !?

Postby paullee » Thu May 02, 2019 11:04 pm

FreeCAD used

FreeCAD_0.18-16110-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage
on
Fedora 29

Testing Lastest 0.19_pre

Testing if latest AppImage has it fixed... but found...

AppImage after 0.19_pre 16291 - - No longer run in Fedora 29
https://forum.freecadweb.org/viewtopic.php?f=3&t=36100

With 0.19_pre 16291, the bug was not fixed yet :) Fix be backported to 0.18 ? :?:
paullee
Posts: 1688
Joined: Wed May 04, 2016 3:58 pm

Re: [Strange BUG] Array of Structure Do No Export - If There is a Clone !?

Postby paullee » Sun May 05, 2019 1:52 pm

yorik wrote:
Thu May 02, 2019 7:22 pm
There was a problem with the ArchCommands.pruneIncluded() function, whose job is to remove from a list of objects all the objects that are actually parts of another object, so they are not exported twice. This function indeed removed objects that were part of an object that is outside the export set, which obviously is wrong. I fixed that a couple of weeks ago, what version are you using?

I actually also just fixed another bug in that function, it considered a cloned object as a component of the clone, which is obviously wrong too. Fixed in git commit 5c700f76e
With @Triplus @looo etc's help, below AppImage run :)
FreeCAD_0.19-16540-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage on Fedora 29

Find problem partially fixed:-


Select BuildingPart Containing the 2 Arrays - with a clone of the Array in X-Direction in the same file
  1. Select the BuildingPart containing the 2 Arrays only
  2. With above combination, IfcExport fails as reported previously
  3. Now it is ok as shown in screenCapture below - both array are shown correctly
  4. OK
Select BuildingPart Containing the 2 Arrays + the Clone of Array in X-Direction - with a clone of the Array in X-Direction in the same file
  1. Select the BuildingPart containing the 2 Arrays + the clone of the Array in X-Direction
  2. Now, the Array in X-Direction seem not exported (tell from the name of exported element)
  3. And, the Clone of Array show only have 1 element
  4. SOME PROBLEM
Screenshot from 2019-05-05 21-18-07.png
Screenshot from 2019-05-05 21-18-07.png (161.69 KiB) Viewed 134 times
Screenshot from 2019-05-05 21-20-02.png
Screenshot from 2019-05-05 21-20-02.png (201.78 KiB) Viewed 134 times
Attachments
Study_ Point Office Block_ 01_branch_15___Array_Test_ add Clone.FCStd
(28.38 KiB) Downloaded 4 times