update IfcOpenShell on windows 0.19 lp builds to 0.6

This forum section is only for IFC-related issues
User avatar
bernd
Posts: 8351
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

update IfcOpenShell on windows 0.19 lp builds to 0.6

Postby bernd » Fri May 31, 2019 10:07 pm

AFAIK windwos builds still uses IfcOpenShell 0.5. For FreeCAD 0.18.2 we should stay with these version. May be update to the latest 0.5 https://github.com/IfcOpenBot/IfcOpenSh ... its/master

Some time ago I started to use 0.6. We would have some big advantages by the use of 0.6. I would suggest to use 0.6 for FreeCAD 0.19 dev versions. See https://github.com/IfcOpenBot/IfcOpenSh ... its/v0.6.0 We will get nurbs, YEAH

Just click on the latest commit and scroll down. Ahh I had a conversation with the author about the versions of IfcOpenShell. Others might be interested as well. https://github.com/IfcOpenShell/IfcOpenShell/issues/583

looo is trying to compile 0.6 for conda builds already. See https://github.com/IfcOpenShell/IfcOpenShell/issues/582

sgrogan wrote: ping
User avatar
sgrogan
Posts: 5339
Joined: Wed Oct 22, 2014 5:02 pm

Re: update IfcOpenShell on windows 0.19 lp builds to 0.6

Postby sgrogan » Sat Jun 01, 2019 6:02 pm

bernd wrote:
Fri May 31, 2019 10:07 pm
sgrogan wrote:
ping
Thanks for the ping, but I didn't get it.
Anyway, Win is using the bot builds from, I guess the 0.5 branch
The statically compiled packages are a little bit of a double edged sword.
The plus is that once we match the python version they can be used on multiple builds.
The minus is that the files are bigger than they need to be. However to dynamically link we need to have IFC and FreeCAD share some common dependencies. I haven't succeeded in linking IfcOpenShell with FreeCAD's libpacks, for me at least this would be ideal.

I wonder if Stinkfist0 could use a sub-set of the FreeCAd libpack?
User avatar
bernd
Posts: 8351
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: update IfcOpenShell on windows 0.19 lp builds to 0.6

Postby bernd » Sun Jun 02, 2019 4:53 am

I just propose fo use IfcOpenShell 0.6 builds from IfcOpenBot for FreeCAD win libpack builds of 0.19.
User avatar
yorik
Site Admin
Posts: 11521
Joined: Tue Feb 17, 2009 9:16 pm
Location: São Paulo, Brazil
Contact:

Re: update IfcOpenShell on windows 0.19 lp builds to 0.6

Postby yorik » Mon Jun 03, 2019 4:42 pm

Note that 0.6 is still not the official one I think (their master still points to 0.5). Maybe better wait until they consider it stable..
However 0.6 works great for me, and it has both IFC2x3 and IFC4 support...