[solved]Cannot open add-on manager

Having trouble installing or compiling FreeCAD? Get help here.
User avatar
Vicolaships
Posts: 5
Joined: Sat Dec 10, 2016 3:31 pm

[solved]Cannot open add-on manager

Postby Vicolaships » Sun Jan 13, 2019 5:05 pm

Hi,

I cannot open the add-on manager in FreeCAD:

Code: Select all

$ freecad
FreeCAD 0.17, Libs: 0.17R13541 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2018
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/victor/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/lib/freecad/Mod/Ship/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/victor/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/lib/freecad/Mod/Plot/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/victor/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/lib/freecad/Mod/Draft/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/victor/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/lib/freecad/Mod/Tux/InitGui.py
Please look into the log file for further information
During initialization the error /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/victor/.local/lib/python2.7/site-packages/PySide2/QtCore.so) occurred in /usr/lib/freecad/Mod/Arch/InitGui.py
Please look into the log file for further information
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/victor/.local/lib/python2.7/site-packages/PySide2/QtGui.so)






Running the Python command 'Std_AddonMgr' failed:
Traceback (most recent call last):
  File "/usr/lib/freecad/Mod/AddonManager/AddonManagerGui.py", line 10, in Activated
    import AddonManager
  File "/usr/lib/freecad/Mod/AddonManager/AddonManager.py", line 40, in <module>
    from PySide import QtCore, QtGui
  File "/usr/lib/freecad/Ext/PySide/QtCore.py", line 1, in <module>
    from PySide2.QtCore import *

/usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.11' not found (required by /home/victor/.local/lib/python2.7/site-packages/PySide2/QtCore.so)
I'm using Kubuntu 18.04 and the FreeCAD stable PPA.

Code: Select all

OS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)

Code: Select all

$ dpkg -l | grep -i freecad
ii  freecad                                              1:0.17.13541-1ppa10~ubuntu18.04.1                  amd64        Extensible Open Source CAx program (beta)
How can I make it work again ? (it worked before!)

I have deleted all my preferences and re-installed FreeCAD again but it still does not work:

Code: Select all

sudo apt remove --purge freecad
rm ~/.FreeCAD/ ~/.config/FreeCAD/ -rf
sudo apt install -y freecad
I experience the same problem with the freecad-daily version.
Feel free to ask for information if you miss some!

Thanks
Last edited by Vicolaships on Mon Jan 14, 2019 6:05 pm, edited 1 time in total.
User avatar
yorik
Site Admin
Posts: 10696
Joined: Tue Feb 17, 2009 9:16 pm
Location: São Paulo, Brazil
Contact:

Re: Cannot open add-on manager

Postby yorik » Mon Jan 14, 2019 4:28 pm

It looks like there is some Qt version mismatch there: your FreeCAD is using 5.9, but your pyside2 package wants 5.11...
Where does /home/victor/.local/lib/python2.7/site-packages/PySide2/QtCore.so come from?
User avatar
Vicolaships
Posts: 5
Joined: Sat Dec 10, 2016 3:31 pm

Re: Cannot open add-on manager

Postby Vicolaships » Mon Jan 14, 2019 6:05 pm

yorik wrote:
Mon Jan 14, 2019 4:28 pm
It looks like there is some Qt version mismatch there: your FreeCAD is using 5.9, but your pyside2 package wants 5.11...
Where does /home/victor/.local/lib/python2.7/site-packages/PySide2/QtCore.so come from?
I don't know but I have deleted these local packages and it now works! Thanks for the hint
User avatar
Kunda1
Posts: 3809
Joined: Thu Jan 05, 2017 9:03 pm

Re: [solved]Cannot open add-on manager

Postby Kunda1 » Mon Mar 04, 2019 11:46 am

Vicolaships wrote:
Mon Jan 14, 2019 6:05 pm
I don't know but I have deleted these local packages and it now works! Thanks for the hint
Please mark this thread as [Solved] by adding it to the title of the first post in this thread. Thanks.
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features