Mac dev Py3 / QT5 version - does not start

Having trouble installing or compiling FreeCAD? Get help here.
Brutha
Posts: 159
Joined: Mon May 04, 2015 1:50 pm

Mac dev Py3 / QT5 version - does not start

Postby Brutha » Wed Mar 13, 2019 12:35 pm

Hi All,

Was trying the FreeCAD_0.18-16079-OSX-x86_64-conda-Qt5-Py3.dmg version from the download page, but can't seem to get it to start. Nothing happens when I try to click the icon, if I try to run from spotlight, it says "Finder cannot open this application".

Using open from the command line I get:

Code: Select all

LSOpenURLsWithRole() failed for the application /Applications/FreeCAD.app with error -10810.
If I try to run the executable from within the package, I get the message below. Any ideas?

Cheers

Brutha

Code: Select all

FreeCAD 0.18, Libs: 0.18R16079 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

/Applications/FreeCAD.app/Contents/MacOS/FreeCAD: line 3:   770 Abort trap: 6           $script_dir/Resources/bin/FreeCAD $@
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

[Process completed]
Brutha
Posts: 159
Joined: Mon May 04, 2015 1:50 pm

Re: Mac dev Py3 / QT5 version - does not start

Postby Brutha » Wed Mar 13, 2019 12:36 pm

And should have mentioned I'm on Mojave 10.14.3!
User avatar
jmborer
Posts: 42
Joined: Thu Feb 28, 2019 5:39 pm
Location: Switzerland

Re: Mac dev Py3 / QT5 version - does not start

Postby jmborer » Wed Mar 13, 2019 12:45 pm

Same for me.
User avatar
looo
Posts: 3482
Joined: Mon Nov 11, 2013 5:29 pm

Re: Mac dev Py3 / QT5 version - does not start

Postby looo » Wed Mar 13, 2019 2:12 pm

I guess this is still the first version I made. Please join this topic [1] and test this build [2]:

[1] https://forum.freecadweb.org/viewtopic. ... 50#p293468
[2] https://www.dropbox.com/sh/tcpg7xrvjdun ... Oteia?dl=0
Brutha
Posts: 159
Joined: Mon May 04, 2015 1:50 pm

Re: Mac dev Py3 / QT5 version - does not start

Postby Brutha » Wed Mar 13, 2019 4:06 pm

OK, downloading now!
leonardshelby
Posts: 72
Joined: Sat Feb 24, 2018 6:09 pm

Re: Mac dev Py3 / QT5 version - does not start

Postby leonardshelby » Wed Mar 13, 2019 5:00 pm

@looo Thanks for your work on mac OS releases! Your version from the dropbox link starts, but it still has the same freezing issues as the older .dmg builds on macOS 10.14.x.
User avatar
looo
Posts: 3482
Joined: Mon Nov 11, 2013 5:29 pm

Re: Mac dev Py3 / QT5 version - does not start

Postby looo » Wed Mar 13, 2019 5:56 pm

leonardshelby wrote:
Wed Mar 13, 2019 5:00 pm
freezing issues as the older .dmg builds on macOS 10.14.x.
maybe security settings of mac. I found this for qgis:
https://issues.qgis.org/issues/20381
Brutha
Posts: 159
Joined: Mon May 04, 2015 1:50 pm

Re: Mac dev Py3 / QT5 version - does not start

Postby Brutha » Thu Mar 14, 2019 9:52 am

looo wrote:
Wed Mar 13, 2019 5:56 pm
maybe security settings of mac. I found this for qgis:
https://issues.qgis.org/issues/20381
I think so, for some reason I cannot add the app to my accessibility list.

Will post in dev thread from now on!
lizabrown
Posts: 1
Joined: Mon Mar 18, 2019 6:47 am

Re: Mac dev Py3 / QT5 version - does not start

Postby lizabrown » Mon Mar 18, 2019 7:00 am

I have recently bought a MacBook Pro and the same problem is also found in my new MacBook. The Mac dev Py3 / QT5 version is not supported on my system. I have updated the system and expected to be solved, but after it, my macbook pro won't turn on. It turns into a black screen.
Brutha
Posts: 159
Joined: Mon May 04, 2015 1:50 pm

Re: Mac dev Py3 / QT5 version - does not start

Postby Brutha » Mon Mar 18, 2019 11:41 am

Hmm, the following version is working fine on mine (well apart from SpaceNavigator support, but I guess thats just a compile flag or something) - I'm on Mojave 10.14.3:

Code: Select all

OS: macOS 10.14
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16087 (Git)
Build type: Release
Branch: master
Hash: ec86db4bfbb1f7e165d0620cb4d85c2b9beb36bc
Python version: 3.7.1
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedKingdom (en_GB)