PPA problem updating to Release of 0.18

Having trouble installing or compiling FreeCAD? Get help here.
User avatar
iogui
Posts: 95
Joined: Tue Mar 19, 2019 3:44 pm
Location: São Paulo
Contact:

Re: PPA problem updating to Release of 0.18

Postby iogui » Sun Apr 07, 2019 4:43 am

NormandC wrote:
Sun Apr 07, 2019 3:32 am
Is freecad-python3 installed? As far as I know, the freecad metapackage depends on either freecad-python2 or freecad-python3, maybe if freecad-python2 is found, the freecad-python3 package isn't installed?
kkremitzki wrote:
Sun Apr 07, 2019 3:50 am
Setting the default to Python 3 just means new users running sudo apt install freecad will hit the dependency freecad-python3 | freecad-python2 so if they don't have either installed they'll get freecad-python3. If you already have freecad-python2 installed the dependency will be satisfied.
The package freecad-python3 doesn't exist for Ubuntu 16.04 (xenial). See:

Code: Select all

$ apt-cache search freecad
freecad-dev - FreeCAD development files
freecad - Extensible Open Source CAx program
freecad-doc - FreeCAD documentation
freecad-python2 - Extensible Open Source CAx program - Python 2 binaries
freecad-common - Extensible Open Source CAx program - common files
freecad-runtime - Extensible Open Source CAx program - runtime files
libfreecad-python2-0.18 - Extensible Open Source CAx program - Python 2 library files
Be the change you want to see in the world. - Mahatma Gandhi
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: PPA problem updating to Release of 0.18

Postby NormandC » Sun Apr 07, 2019 5:18 am

Sorry, I forgot you were on Ubuntu 16.04. It's too old to support Python 3, specifically Py3 in conjunction with Qt5.
jmaustpc
Posts: 10389
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: PPA problem updating to Release of 0.18

Postby jmaustpc » Sun Apr 07, 2019 7:22 am

NormandC wrote:
Sun Apr 07, 2019 5:18 am
Sorry, I forgot you were on Ubuntu 16.04. It's too old to support Python 3, specifically Py3 in conjunction with Qt5.
that could be unfortunate. I have been expecting to see lost of issues with the add-ons where some are Py2 only and some could be Py3 only. One of the reasons I was personally wanting to see PY3 default in 0.18 was to encourage 3rd party add-ons devs to make sure they are py3 compatible and allow them to move on from py2 that is, not bother supporting py2 if it is too difficult for some reason.

I can see we are likely to have some difficulties for sometime if getting over to py3 completely is not easy or possible. :(

by the way this is a link to the Ubuntu life cycle page
https://www.ubuntu.com/about/release-cycle

they have two different levels of support on their LTS versions, the first being "hardware and maintenance updates" the second being only "maintenance updates". Ubuntu 16.04 is already in the later "maintenance updates" only phase. All support does not end until early 2021, i.e. in two more years.
User avatar
looo
Posts: 3482
Joined: Mon Nov 11, 2013 5:29 pm

Re: PPA problem updating to Release of 0.18

Postby looo » Sun Apr 07, 2019 8:46 am

Py3 is the future. It will bring a few difficulties/frustration. Maybe 0.18 is not as stabile as a py2 release of 0.18. But thinking about a 1.19 (if this will happen) it's definitely an essential move.

So citing the creator of freecad: don't wine, fix the py3 errors!
User avatar
iogui
Posts: 95
Joined: Tue Mar 19, 2019 3:44 pm
Location: São Paulo
Contact:

Re: PPA problem updating to Release of 0.18

Postby iogui » Sun Apr 07, 2019 1:34 pm

NormandC wrote:
Sun Apr 07, 2019 5:18 am
Sorry, I forgot you were on Ubuntu 16.04. It's too old to support Python 3, specifically Py3 in conjunction with Qt5.
Too old? Are you sure about it? Ubuntu 16.04 has python 3 with qt5 in it's official repository:

https://packages.ubuntu.com/xenial/python3-pyqt5

Is that anything else it needs to? I'm trying to understand this because I already use python 3 in Ubuntu 16.04 and I'm avoiding to make the change to 18.04 for now since it will cost time to have anything working right.
Be the change you want to see in the world. - Mahatma Gandhi
jmaustpc
Posts: 10389
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: PPA problem updating to Release of 0.18

Postby jmaustpc » Sun Apr 07, 2019 1:49 pm

It says here that 16.04 has this version of Python3

libpython3-stdlib (3.5.1-3)
interactive high-level object-oriented language (default python3 version)

https://packages.ubuntu.com/xenial/python/


my 18.04 has 3.6.7-1 from Ubuntu main
and
3.7.1-1 is available from Universe (but not installed on my system)



does anyone know what FreeCAD's minimum Py3 version is?
jmaustpc
Posts: 10389
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: PPA problem updating to Release of 0.18

Postby jmaustpc » Sun Apr 07, 2019 1:52 pm

NormandC wrote:
Sun Apr 07, 2019 5:18 am
Sorry, I forgot you were on Ubuntu 16.04. It's too old to support Python 3, specifically Py3 in conjunction with Qt5.
Just wondered, what about from Universe for 16.04? Since my 18.04 has 3.6 in main and 3.7 in Universe, could 16.04 use a more advanced Python from its Universe repo?
User avatar
iogui
Posts: 95
Joined: Tue Mar 19, 2019 3:44 pm
Location: São Paulo
Contact:

Re: PPA problem updating to Release of 0.18

Postby iogui » Sun Apr 07, 2019 1:55 pm

And also don't you forget Ubuntu 16.04 is the last LTS before the 18.04 version so I would not say it is too old although it is for sure not the last LTS version.
Be the change you want to see in the world. - Mahatma Gandhi
jmaustpc
Posts: 10389
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: PPA problem updating to Release of 0.18

Postby jmaustpc » Sun Apr 07, 2019 2:12 pm

iogui wrote:
Sun Apr 07, 2019 1:55 pm
And also don't you forget Ubuntu 16.04 is the last LTS before the 18.04 version so I would not say it is too old although it is for sure not the last LTS version.
Yes, we know that. In the past we have found that trying to support the oldest then current LTS can become close to impossible, it can get to the point where you have to update so much that it is better to just update the O/S. The effort involved in supporting the third LTS at the time can become more than its worth considering it will by then only have a few months to go. But at this time I am referring to 14.04 being like that, not 16.04. A lot of us update to only every second LTS version. We had a lot of problems with C++11 on the then oldest LTS, I did manage to get it to compile eventually just because I enjoyed the challenge, but doing so was excessive, replaced so much of the core system, I had to update GCC, I think I even had to compile some newer libs and I certainly had to add heaps of PPAs. It was the FreeCAD dev version, i.e. master, that I was compiling. The point is that it gets to a point where you just have to drop support for the oldest LTS etc. because otherwise you are restricting FreeCAD to only work with in some cases 5 years old versions of other libs etc.
User avatar
kkremitzki
Posts: 2170
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: PPA problem updating to Release of 0.18

Postby kkremitzki » Sun Apr 07, 2019 2:22 pm

The problem is actually the version of Qt being too old to run PySide 2. It may be possible to build against Python 3 on 16.04 but it would need the be a Qt 4 build. I judged working on it to be not a good use of time for a marginal gain, figuring people still using the old LTS are less interested in the newest features.

Edit: To add more detail, in order to get a Qt 4/Python 3 build working, we would need a python3-pivy package for 16.04, which in turn would need a modified coin and soqt package--if anyone wants to work on it.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.