Daily PPA for 0.19

Having trouble installing or compiling FreeCAD? Get help here.
MasterCATZ
Posts: 18
Joined: Mon Jul 20, 2020 3:59 am

Re: Daily PPA for 0.19

Postby MasterCATZ » Thu Jan 21, 2021 11:39 pm

Ubuntu 20.04

Code: Select all

aio@aio:~$ sudo apt install freecad-daily
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  afflib-tools libafflib-dev libbfio-dev libbfio1 libc3p0-java libewf-dev
  libvhdi-dev libvhdi1 libvmdk-dev libvmdk1
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  freecad-daily-common freecad-daily-python3 libfreecad-daily-python3-0.19
Suggested packages:
  povray
The following NEW packages will be installed:
  freecad-daily freecad-daily-common freecad-daily-python3
The following packages will be upgraded:
  libfreecad-daily-python3-0.19
1 upgraded, 3 newly installed, 0 to remove and 11 not upgraded.
Need to get 48.6 MB of archives.
After this operation, 96.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu focal/main amd64 freecad-daily-common all 0.19~pre2~202101210709~ubuntu20.04.1 [18.5 MB]
Get:2 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu focal/main amd64 libfreecad-daily-python3-0.19 amd64 0.19~pre2~202101210709~ubuntu20.04.1 [30.0 MB]
Get:3 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu focal/main amd64 freecad-daily-python3 amd64 0.19~pre2~202101210709~ubuntu20.04.1 [46.8 kB]
Get:4 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu focal/main amd64 freecad-daily all 0.19~pre2~202101210709~ubuntu20.04.1 [33.3 kB]
Fetched 48.6 MB in 24s (2003 kB/s)                                             
Selecting previously unselected package freecad-daily-common.
(Reading database ... 528964 files and directories currently installed.)
Preparing to unpack .../freecad-daily-common_0.19~pre2~202101210709~ubuntu20.04.
1_all.deb ...
Unpacking freecad-daily-common (0.19~pre2~202101210709~ubuntu20.04.1) ...
Preparing to unpack .../libfreecad-daily-python3-0.19_0.19~pre2~202101210709~ubu
ntu20.04.1_amd64.deb ...
Unpacking libfreecad-daily-python3-0.19 (0.19~pre2~202101210709~ubuntu20.04.1) o
ver (0.19~pre2~202101190706~ubuntu20.04.1) ...
Selecting previously unselected package freecad-daily-python3.
Preparing to unpack .../freecad-daily-python3_0.19~pre2~202101210709~ubuntu20.04
.1_amd64.deb ...
Unpacking freecad-daily-python3 (0.19~pre2~202101210709~ubuntu20.04.1) ...
Selecting previously unselected package freecad-daily.
Preparing to unpack .../freecad-daily_0.19~pre2~202101210709~ubuntu20.04.1_all.d
eb ...
Unpacking freecad-daily (0.19~pre2~202101210709~ubuntu20.04.1) ...
Setting up libfreecad-daily-python3-0.19 (0.19~pre2~202101210709~ubuntu20.04.1) 
...
Setting up freecad-daily-common (0.19~pre2~202101210709~ubuntu20.04.1) ...
Setting up freecad-daily-python3 (0.19~pre2~202101210709~ubuntu20.04.1) ...
update-alternatives: using /usr/lib/freecad-daily/bin/freecad-python3 to provide
 /usr/bin/freecad-daily (freecad-daily) in auto mode
Setting up freecad-daily (0.19~pre2~202101210709~ubuntu20.04.1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for shared-mime-info (1.15-1) ...
aio@aio:~$ freecad-daily
FreeCAD 0.19, Libs: 0.19R
© Juergen Riegel, Werner Mayer, Yorik van Havre and others 2001-2020
FreeCAD is free and open-source software licensed under the terms of LGPL2+ license.
FreeCAD wouldn't be possible without FreeCAD community.
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

During initialization the error "name '_init_pyside_extension' is not defined" occurred in /usr/share/freecad-daily/Mod/AddonManager/InitGui.py
Please look into the log file for further information
During initialization the error "name '_init_pyside_extension' is not defined" occurred in /usr/share/freecad-daily/Mod/Arch/InitGui.py
Please look into the log file for further information
During initialization the error "name '_init_pyside_extension' is not defined" occurred in /usr/share/freecad-daily/Mod/Draft/InitGui.py
Please look into the log file for further information
During initialization the error "name '_init_pyside_extension' is not defined" occurred in /usr/share/freecad-daily/Mod/Tux/InitGui.py
Please look into the log file for further information
Unknown command 'Std_AddonMgr'
Fatal Python error: could not initialize part 2
Python runtime state: initialized

Current thread 0x00007f9055675100 (most recent call first):
  File "/usr/lib/python3/dist-packages/six.py", line 128 in __init__
  File "/usr/lib/python3/dist-packages/six.py", line 320 in <module>
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 783 in exec_module
  File "<frozen importlib._bootstrap>", line 671 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 975 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 991 in _find_and_load
  File "/usr/share/freecad-daily/Mod/Start/StartPage/StartPage.py", line 27 in <module>
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 783 in exec_module
  File "<frozen importlib._bootstrap>", line 671 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 975 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 991 in _find_and_load
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap>", line 1042 in _handle_fromlist
  File "<string>", line 2 in <module>
Aborted (core dumped)
aio@aio:~$ 
Last edited by MasterCATZ on Fri Jan 22, 2021 3:30 am, edited 1 time in total.
chrisb
Posts: 34448
Joined: Tue Mar 17, 2015 9:14 am

Re: Daily PPA for 0.19

Postby chrisb » Thu Jan 21, 2021 11:44 pm

MasterCATZ wrote: Thu Jan 21, 2021 11:39 pm ...
If this is some log output, put it in code tags for improved readability.
A Sketcher Lecture with in-depth information is available in English, auf Deutsch, en français, en español.
User avatar
kkremitzki
Posts: 2279
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: Daily PPA for 0.19

Postby kkremitzki » Fri Jan 22, 2021 12:23 am

I can't replicate this in a fresh install. Based on the error message referring to pyside I would guess you have a pip-installed version somewhere.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
MasterCATZ
Posts: 18
Joined: Mon Jul 20, 2020 3:59 am

Re: Daily PPA for 0.19

Postby MasterCATZ » Fri Jan 22, 2021 3:36 am

I even did a Ubuntu 20.04 reinstall a few weeks ago as this person had it solved then

https://forum.freecadweb.org/viewtopic.php?t=51472

but still has this issue how would I get this working with pip installed python ?

fresh install on virtual machine worked how ever

Code: Select all

python -m pip uninstall pyside
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
WARNING: Skipping pyside as it is not installed.

Code: Select all

sudo python -m pip uninstall pyside2
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
WARNING: Skipping pyside2 as it is not installed.

Code: Select all

   
   
 sudo apt remove --purge freecad-daily
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  afflib-tools freecad-daily-common freecad-daily-python3 libafflib-dev libbfio-dev libbfio1 libc3p0-java libewf-dev libvhdi-dev libvhdi1 libvmdk-dev libvmdk1
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  freecad-daily*
0 upgraded, 0 newly installed, 1 to remove and 18 not upgraded.
After this operation, 52.2 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 530788 files and directories currently installed.)
Removing freecad-daily (0.19~pre2~202101210709~ubuntu20.04.1) ...
Processing triggers for shared-mime-info (1.15-1) ...
aio@aio:~$ sudo apt remove --purge freecad
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  afflib-tools freecad-common freecad-daily-common freecad-daily-python3 freecad-python3 freecad-runtime libafflib-dev libbfio-dev libbfio1 libc3p0-java libewf-dev libfreecad-python3-0.18
  libjs-jquery-ui libsoqt520 libvhdi-dev libvhdi1 libvmdk-dev libvmdk1 python-matplotlib-data python3-cycler python3-kiwisolver python3-matplotlib python3-pivy python3-pyside2.qtgui
  python3-pyside2.qtopengl python3-pyside2.qtsvg python3-pyside2.qtuitools python3-pyside2.qtwidgets python3-pyside2.qtxml
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  freecad*
0 upgraded, 0 newly installed, 1 to remove and 18 not upgraded.
After this operation, 53.2 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 530782 files and directories currently installed.)
Removing freecad (0.18.4+dfsg2-1ubuntu4) ...
Processing triggers for shared-mime-info (1.15-1) ...
  
   
aio@aio:~$ sudo rm -R /etc/alternatives/freecad
aio@aio:~$ sudo rm -R /etc/alternatives/freecad-daily 
aio@aio:~$ sudo rm -R /etc/alternatives/freecadlib
aio@aio:~$ sudo rm -R /usr/share/freecad
aio@aio:~$ sudo rm -R /usr/share/freecad-daily/
aio@aio:~$ sudo rm -R /usr/lib/freecad
aio@aio:~$ sudo rm -R /usr/lib/freecad-daily
aio@aio:~$ sudo rm -R /usr/lib/freecad-
freecad-daily-python3/ freecad-python3/       
aio@aio:~$ sudo rm -R /usr/lib/freecad-daily-python3
aio@aio:~$ sudo rm -R /usr/lib/freecad-python3
what else could I possibly need to hunt down ?

this is the only working file

FreeCAD_0.18-16146-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage

all the other appimages fail , along with ppa stable / daily

Code: Select all

freecad
FreeCAD 0.18.4, Libs: 0.18.4R
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

During initialization the error /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /home/aio/.local/lib/python3.8/site-packages/PySide2/QtCore.abi3.so) occurred in /usr/share/freecad/Mod/Plot/InitGui.py
Please look into the log file for further information
During initialization the error /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /home/aio/.local/lib/python3.8/site-packages/PySide2/QtCore.abi3.so) occurred in /usr/share/freecad/Mod/Ship/InitGui.py
Please look into the log file for further information
During initialization the error /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /home/aio/.local/lib/python3.8/site-packages/PySide2/QtGui.abi3.so) occurred in /usr/share/freecad/Mod/Tux/InitGui.py
Please look into the log file for further information
/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /home/aio/.local/lib/python3.8/site-packages/PySide2/QtGui.abi3.so)

and if i try a reinstall .. not all files are installed ?

Code: Select all

sudo apt install --reinstall freecad-daily
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  afflib-tools freecad-common freecad-python3 freecad-runtime libafflib-dev libbfio-dev libbfio1 libc3p0-java libewf-dev libfreecad-python3-0.18 libvhdi-dev libvhdi1 libvmdk-dev libvmdk1
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  povray
The following NEW packages will be installed:
  freecad-daily
0 upgraded, 1 newly installed, 0 to remove and 18 not upgraded.
Need to get 33.3 kB of archives.
After this operation, 52.2 kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu focal/main amd64 freecad-daily all 0.19~pre2~202101210709~ubuntu20.04.1 [33.3 kB]
Fetched 33.3 kB in 1s (36.0 kB/s)     
Selecting previously unselected package freecad-daily.
(Reading database ... 530777 files and directories currently installed.)
Preparing to unpack .../freecad-daily_0.19~pre2~202101210709~ubuntu20.04.1_all.deb ...
Unpacking freecad-daily (0.19~pre2~202101210709~ubuntu20.04.1) ...
Setting up freecad-daily (0.19~pre2~202101210709~ubuntu20.04.1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Config is in use.
aio@aio:~$ freecad-daily
bash: /usr/bin/freecad-daily: No such file or directory

Code: Select all

sudo apt install --reinstall freecad-daily-python3 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 18 not upgraded.
Need to get 46.8 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu focal/main amd64 freecad-daily-python3 amd64 0.19~pre2~202101210709~ubuntu20.04.1 [46.8 kB]
Fetched 46.8 kB in 1s (40.1 kB/s)                
(Reading database ... 529353 files and directories currently installed.)
Preparing to unpack .../freecad-daily-python3_0.19~pre2~202101210709~ubuntu20.04.1_amd64.deb ...
Unpacking freecad-daily-python3 (0.19~pre2~202101210709~ubuntu20.04.1) over (0.19~pre2~202101210709~ubuntu20.04.1) ...
Setting up freecad-daily-python3 (0.19~pre2~202101210709~ubuntu20.04.1) ...
update-alternatives: using /usr/lib/freecad-daily/bin/freecad-python3 to provide /usr/bin/freecad-daily (freecad-daily) in auto mode
Config is in use.
aio@aio:/var/cache/apt/archives$

Code: Select all

 sudo apt install --reinstall freecad-daily-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 freecad-daily-python3 : Depends: libfreecad-daily-python3-0.19 (>= 0.19~pre2~202101210709~ubuntu20.04.1) but 0.19~pre2~202101100705~ubuntu20.04.1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
aio@aio:/var/cache/apt/archives$ sudo apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libfreecad-daily-python3-0.19
The following packages will be upgraded:
  libfreecad-daily-python3-0.19
1 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
Need to get 30.0 MB of archives.
After this operation, 57.3 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/freecad-maintainers/freecad-daily/ubuntu focal/main amd64 libfreecad-daily-python3-0.19 amd64 0.19~pre2~202101210709~ubuntu20.04.1 [30.0 MB]
Fetched 30.0 MB in 13s (2357 kB/s)                                                                                                                                                                         
(Reading database ... 529353 files and directories currently installed.)
Preparing to unpack .../libfreecad-daily-python3-0.19_0.19~pre2~202101210709~ubuntu20.04.1_amd64.deb ...
Unpacking libfreecad-daily-python3-0.19 (0.19~pre2~202101210709~ubuntu20.04.1) over (0.19~pre2~202101100705~ubuntu20.04.1) ...
Setting up libfreecad-daily-python3-0.19 (0.19~pre2~202101210709~ubuntu20.04.1) ...
aio@aio:/var/cache/apt/archives$ s
jmaustpc
Posts: 11006
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: Daily PPA for 0.19

Postby jmaustpc » Fri Jan 22, 2021 11:47 am

Some comments that may help

1)
I installed something from a PPA can't remember what but might have been when I installed QGIS, it said to run "apt full-upgrade"

This page will explain what it does

http://manpages.ubuntu.com/manpages/xen ... apt.8.html

For me it fixed the packages not installed.

2)
you seem to be using the command "pip" that gives you pip for Python2, you want to use "pip3" which deals with Python3

Code: Select all

pip3 -V
will give you the pip version on your system for Python3 if installed, the same with just "pip" will do the same for Python2 pip. Note that the above code includes a capital "V" not lower case, it matters as they do different things.

For example, on my Kubuntu 18.04 system "pip3" exists and works but pip does not, it says it is not installed
User avatar
kkremitzki
Posts: 2279
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: Daily PPA for 0.19

Postby kkremitzki » Fri Jan 22, 2021 9:29 pm

I should first mention that pip should not need to be involved in this installation, and that especially sudo pip can have undesirable consequences for your system--unless you're certain that you need it, you probably shouldn't be doing it, and if you see directions instructing it, they're probably wrong.

That being said, the problem with the steps you posted are that you only removed the metapackages freecad-daily and freecad. Those are basically only for pulling in the dependencies that contain the actual files. Note the output of the apt command, it is telling you that after removing them you have packages that are no longer needed, freecad-daily-common, etc., so you need to issue a sudo apt autoremove to complete the process. Then when you did sudo rm afterward you are removing the files that are managed by packages you still have installed, so as far as your system is concerned it doesn't know that those packages are actually now broken and need to be reinstalled.

Since you have used sudo pip in the past, you may have leftover files associated with that to clean up, as well, however, which could interfere with your installation once you fix it. Check /usr/lib/python* and /usr/local/lib/python*, you should not see a directory called 'site-packages' anywhere, and if you do find any, you may want to remove what's there.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
nelsonjm
Posts: 9
Joined: Sat Jan 23, 2021 9:07 pm

Re: Daily PPA for 0.19

Postby nelsonjm » Sat Jan 23, 2021 10:45 pm

I ran into a similar issue but with the AppImages. In addition to the locations kkremitzki highlighted also check:
~/.local/lib/python*
MasterCATZ
Posts: 18
Joined: Mon Jul 20, 2020 3:59 am

Re: Daily PPA for 0.19

Postby MasterCATZ » Fri Jan 29, 2021 10:16 pm

pip3 -V
pip 20.0.2 from /usr/lib/python3/dist-packages/pip (python 3.8)

sudo pip3 uninstall pyside2
WARNING: Skipping pyside2 as it is not installed.


pip is used for about 80% of my other software packages


/usr/lib/python2.7 , 3 , 3.6 , 3.8 , 3.9 contain no site-packages just dist-packages


sudo apt autoremove has been done multiple times

~/.local/lib/python*
does how ever contains site-packages what do you want me to do their ?

their is also a folder /usr/include/PySide2 but nothing is saying Pyside2 is installed
Attachments
Screenshot from 2021-01-30 08-44-53.png
Screenshot from 2021-01-30 08-44-53.png (61.38 KiB) Viewed 553 times
Screenshot from 2021-01-30 08-19-33.png
Screenshot from 2021-01-30 08-19-33.png (95.65 KiB) Viewed 564 times
MasterCATZ
Posts: 18
Joined: Mon Jul 20, 2020 3:59 am

Re: Daily PPA for 0.19

Postby MasterCATZ » Sat Jan 30, 2021 2:18 am

and if I remove /usr/local/lib/python*
freecad will load with many errors if I reinstall pyside2 / PyQt5 it goes back to dumping the core


if i remove /usr/lib/python* entire OS is broken


looks like I just had to remove shiboken2 for
FreeCAD_0.19-22665-Linux-Conda_glibc2.12-x86_64.AppImage
to work again
galou_breizh
Posts: 354
Joined: Wed Sep 15, 2010 9:38 am

Re: Daily PPA for 0.19

Postby galou_breizh » Tue Apr 06, 2021 7:14 pm

It looks that the PPA recipe for FreeCAD daily on Ubuntu 20.04 amd64 fails:

Code: Select all

/usr/bin/ld: cannot find -lpthreads
Other recipes fail as well.

Can an expert have a look?
Thanks,
Gaël