[Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Having trouble installing or compiling FreeCAD? Get help here.
paullee
Posts: 3809
Joined: Wed May 04, 2016 3:58 pm

Re: AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by paullee »

NormandC wrote: Sat May 04, 2019 4:26 pm
FreeCAD 0.18.1 is provided as a flatpak. It runs well on Ubuntu, as I assume it would on fedora. I don't use IfcOpenShell though.

https://forum.freecadweb.org/viewtopic.php?f=10&t=30368
https://flathub.org/apps/details/org.freecadweb.FreeCAD
Thanks, I have no idea about Flatpak... and with some study, FC runs... :)

... some older version though :( ... it does not find / use the user's config files as original Fedora29/FC and/or AppImage do... :(


And I am not sure if it pack IfcOpenShell, or use that one in ... site-packages, IfcOpenShell seems runs :)
paullee
Posts: 3809
Joined: Wed May 04, 2016 3:58 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by paullee »

looo wrote: Sat May 04, 2019 5:18 pm There are also other interested in an compatible ifc library for conda-forge. Maybe you can try to create a staged-recipe for this library:
https://conda-forge.org/docs/maintainer ... or-recipes
https://github.com/IfcOpenShell/IfcOpen ... .6.0/conda

If more people would work on conda-packages for freecad this would be a nice cross platform solution...
I had compiled IfcOpenShell for python and put in ... site-package... then FC AppImage find it :)

Up to ...
FreeCAD_0.19.16291_Conda_Py3Qt5_glibc2.12-x86_64.AppImage

FC runs on my Fedora and it find the IFC I compiled.

Then, FC no longer run. With the nls package installed 'separately', FC (FreeCAD_0.19-16540-Linux-Conda_Py3Qt5_glibc2.12-x86_64) runs but it no longer find the IFC I compile...
User avatar
looo
Posts: 3698
Joined: Mon Nov 11, 2013 5:29 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by looo »

Local site packages are seperated by python version. The new appimage uses python 3.7.
paullee
Posts: 3809
Joined: Wed May 04, 2016 3:58 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by paullee »

looo wrote: Sun May 05, 2019 5:35 am Local site packages are seperated by python version. The new appimage uses python 3.7.
Thanks again.

I just compile on March latest version was 3.6.2...

Seem needs to try compiling again :)

Or can I tell FC to use 3.6.2? .... or just put / rename that directory to 3.7.x to try circumventing FC? :lol:
paullee
Posts: 3809
Joined: Wed May 04, 2016 3:58 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by paullee »

Finally, I just create a 'python3.7' link to 'python3.6', then it works.... atm at least :lol:

But i can help to repeat, why these 'latest' AppImage version interface look out-dated / old-fashioned?

Because the nsl library?
Screenshot from 2019-05-05 21-18-07.png
Screenshot from 2019-05-05 21-18-07.png (161.69 KiB) Viewed 850 times
User avatar
looo
Posts: 3698
Joined: Mon Nov 11, 2013 5:29 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by looo »

No, it's a more general problem. I hope update to qt5.9 will solve this. There are also other problems with the freecad conda-package which needs to be resolved. The nsl lib was a good hint. I guess we need to find a way to link against condas sysroot libs instead of system libs.
triplus
Posts: 9475
Joined: Mon Dec 12, 2011 4:45 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by triplus »

looo wrote: Sat May 04, 2019 7:19 am Actually it's bundled in the 0.19 appimages, but not used...
I guess we need to find a way to link against condas sysroot libs instead of system libs.
Nop. I took a look and libnsl is missing. People using Conda directly on Fedora 28+ will likely need to install the mentioned package too. I decided to add the libnsl library to AppImage, using Ubuntu package as a basis.

@paullee

It would be great if you could remove the system provided libnsl package, the one you have installed earlier, and to test after if both stable and daily AppImages still run on your system.
User avatar
looo
Posts: 3698
Joined: Mon Nov 11, 2013 5:29 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by looo »

triplus wrote: Fri May 10, 2019 8:59 pm Nop. I took a look and libnsl is missing. People using Conda directly on Fedora 28+ will likely need to install the mentioned package too. I decided to add the libnsl library to AppImage, using Ubuntu package as a basis.
I guess this packaging efforts already damaged my brain... really need to make a brake from this.

Sysroot libs are only available for build-envs and regarding the name should be provided by the system... So you are right, this libraries must be installed in the system.
paullee
Posts: 3809
Joined: Wed May 04, 2016 3:58 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by paullee »

triplus wrote: Fri May 10, 2019 8:59 pm @paullee

It would be great if you could remove the system provided libnsl package, the one you have installed earlier, and to test after if both stable and daily AppImages still run on your system.
OK remove the libnsl package ... Test again my previous finding still valid - - - [ AppImage after 0.19_pre 16291 - - No longer run in Fedora 29 ]

OK - - - FreeCAD_0.18-16110-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage
OK - - - FreeCAD_0.19.16207_Conda_Py3Qt5_glibc2.12-x86_64.AppImage
OK - - - FreeCAD_0.19.16291_Conda_Py3Qt5_glibc2.12-x86_64.AppImage
Not OK - FreeCAD_0.19-16540-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage

Code: Select all

[paullee@localhost squashfs-root]$ /home/paullee/Downloads/FreeCAD_0.19-16540-Linux-Conda_Py3Qt5_glibc2.12-x86_64/squashfs-root
/home/paullee/Downloads/FreeCAD_0.19-16540-Linux-Conda_Py3Qt5_glibc2.12-x86_64/squashfs-root/usr/bin/FreeCAD: error while loading shared libraries: libnsl.so.1: cannot open shared object file: No such file or directory
Surprise - - - OK - - - FreeCAD_0.19-16694-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage runs ! ! !
- still can't help saying the interface look old-school :D
Screenshot from 2019-05-11 08-20-14.png
Screenshot from 2019-05-11 08-20-14.png (170.99 KiB) Viewed 751 times
Screenshot from 2019-05-11 08-20-06.png
Screenshot from 2019-05-11 08-20-06.png (143.06 KiB) Viewed 751 times
User avatar
looo
Posts: 3698
Joined: Mon Nov 11, 2013 5:29 pm

Re: [Solved] AppImage after 0.19_pre 16291 - - No longer run in Fedora 29

Post by looo »

But i can help to repeat, why these 'latest' AppImage version interface look out-dated / old-fashioned?
paullee wrote: Sat May 11, 2019 12:24 am - still can't help saying the interface look old-school :D
0.19 appimage now uses qt5.6.3 and it seems to look more modern. Hopefully it works for everyone :D
Post Reply