[Solved]Issues with new libpacks for Windows

Having trouble installing or compiling FreeCAD? Get help here.
User avatar
makkemal
Posts: 395
Joined: Wed Apr 29, 2015 12:41 pm
Location: South Africa
Contact:

[Solved]Issues with new libpacks for Windows

Postby makkemal » Wed Jul 03, 2019 3:47 am

I get the following error using the official libpack pre19
Is this a setting

Code: Select all

Shiboken2Config: Using default python: .cp36-win_amd64
CMake Error at C:/Freecad/FreeCADLibs_12.1.2_x64_VC15/lib/cmake/Shiboken2-5.12.2/shiboken_helpers.cmake:193 (message):
  The detected Python minor version is not compatible with the Python minor
  version which was used when Shiboken was built.  Consider building shiboken
  with FORCE_LIMITED_API set to '1', so that only the Python major version
  matters.

  Built with: '3.6' Detected: '3.7'
Call Stack (most recent call first):
  C:/Freecad/FreeCADLibs_12.1.2_x64_VC15/lib/cmake/Shiboken2-5.12.2/Shiboken2Config.cp36-win_amd64.cmake:47 (shiboken_check_if_built_and_target_python_are_compatible)
  C:/Freecad/FreeCADLibs_12.1.2_x64_VC15/lib/cmake/Shiboken2-5.12.2/Shiboken2Config.cmake:10 (include)
  CMakeLists.txt:1046 (find_package)
User avatar
apeltauer
Posts: 212
Joined: Fri Aug 11, 2017 2:19 pm

Re: New libpacks for Windows with Qt5.12, OCC7.3 and Python 3.6 by apeltauer

Postby apeltauer » Wed Jul 03, 2019 5:32 am

are you using python 3.7?
Somehow cmake detects python 3.7, but shiboken was build with python 3.6.
User avatar
makkemal
Posts: 395
Joined: Wed Apr 29, 2015 12:41 pm
Location: South Africa
Contact:

Re: New libpacks for Windows with Qt5.12, OCC7.3 and Python 3.6 by apeltauer

Postby makkemal » Wed Jul 03, 2019 11:27 am

Somehow cmake detects python 3.7, but shiboken was build with python 3.6.
Thanks I had anaconda python installed with ver 3.7 once uninstalled it everything worked