Freecad 0.18 bringt beim Starten Fehler und Icons fehlen

Having trouble installing or compiling FreeCAD? Get help here.
anroubo
Posts: 3
Joined: Fri Nov 08, 2019 1:38 pm

Freecad 0.18 bringt beim Starten Fehler und Icons fehlen

Postby anroubo » Fri Nov 08, 2019 2:54 pm

Servus zusammen.

ich versuche seit ein paar Tagen Freecad einzurichten, komme aber jetzt nicht mehr weiter.

Wenn ich Freecad über das Terminal installiere startet es nicht. Da bekomme ich beider Installation folgende Warnmeldung:
Einstellung von /usr/lib/freecad/lib wird übersprungen...

Code: Select all

python3-pyside.qtopengl (1.2.2-2build2) wird eingerichtet ...
shiboken (1.2.2-2build2) wird eingerichtet ...
python3-pivy (0.6.4-2~ubuntu16.04.3) wird eingerichtet ...
python3-pyside.qtsvg (1.2.2-2build2) wird eingerichtet ...
python3-pyside.qtxml (1.2.2-2build2) wird eingerichtet ...
python3-pyside.qtuitools (1.2.2-2build2) wird eingerichtet ...
python3-yaml (3.11-3build1) wird eingerichtet ...
libfreecad-python3-0.18 (2:0.18.4+dfsg1~201911060029~ubuntu16.04.1) wird eingerichtet ...
freecad-python3 (2:0.18.4+dfsg1~201911060029~ubuntu16.04.1) wird eingerichtet ...
update-alternatives: /usr/lib/freecad/bin/freecad-python3 wird verwendet, um /usr/bin/freecad (freecad) im automatischen Modus bereitzustellen
update-alternatives: Warnung: Erstellung von /usr/lib/freecad/lib wird übersprungen, weil die zugehörige Datei /usr/lib/freecad-python3/lib (der Link-Gruppe freecad) nicht existiert
freecad (2:0.18.4+dfsg1~201911060029~ubuntu16.04.1) wird eingerichtet ...
openmpi-common (1.10.2-8ubuntu1) wird eingerichtet ...
openmpi-bin (1.10.2-8ubuntu1) wird eingerichtet ...
update-alternatives: /usr/bin/mpirun.openmpi wird verwendet, um /usr/bin/mpirun (mpirun) im automatischen Modus bereitzustellen
libhwloc-plugins (1.11.2-3) wird eingerichtet ...
Trigger für libc-bin (2.23-0ubuntu11) werden verarbeitet ...
andreas@andreas-HP-350-G2:~$
und freecad startet wegen der fehlenden Bibliothek nicht

Code: Select all

andreas@andreas-HP-350-G2:~$ freecad
freecad: error while loading shared libraries: libFreeCADGui.so: cannot open shared object file: No such file or directory

Bei der Installation aus dem Ubuntu-Software-Center, startet Freecad, es fehlen aber bei der Symbolleiste "Entwurfs-Einrastung" die Icon. Diese werden nur mit leeren Buttons angezeigt.

Beim starten wird mir folgendes angezeigt:

Code: Select all

@andreas-HP-350-G2:~$ freecad
mkdir: cannot create directory '/home/andreas/snap/freecad/8/.config': File exists
FreeCAD 0.18, Libs: 0.18R16093 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##


(process:15130): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
und in Freecad sieht das ganze dann so aus:
Image

die installierte Freecad-Version:

OS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 (Git)
Build type: Unknown
Branch: master
Hash: 690774c0effe4fd7b8d2b5e2fb2b8c8d145e21ce
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.0.0
Locale: English/UnitedStates (en_US)

ich hoffe es kann mir hierzu jemand weiterhelfen

Gruß
chrisb
Posts: 19703
Joined: Tue Mar 17, 2015 9:14 am

Re: Freecad 0.18 bringt beim Starten Fehler und Icons fehlen

Postby chrisb » Fri Nov 08, 2019 4:10 pm

Falls Du vorher eine FreeCAD-Installation hattest, solltest Du Deinen ~/.FreeCAD-Ordner löschen oder erst mal umbenennen.
Die Version, die Du installieren möchtest ist außerdem nicht aktuell, versuch mal die letzte 0.18 oder eine aktuelle 0.19 zu installieren. Da gibt es ein Appimage, das alle Bibliotheken an Bord hat.
anroubo
Posts: 3
Joined: Fri Nov 08, 2019 1:38 pm

Re: Freecad 0.18 bringt beim Starten Fehler und Icons fehlen

Postby anroubo » Fri Nov 08, 2019 4:42 pm

Hallo chrisb,

die neuste Version 18er habe ich nach den Schritten https://www.freecadweb.org/wiki/Install_on_Unix/de versucht,

Code: Select all

sudo add-apt-repository ppa:freecad-maintainers/freecad-stable
sudo apt-get update
sudo apt-get install freecad freecad-doc && sudo apt-get upgrade
aber hier macht das installieren der freecad-doc folgende Probleme:

Code: Select all

sudo apt-get install freecad freecad-doc && sudo apt-get upgrade
[sudo] Passwort für andreas: 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 freecad-common : Beschädigt: freecad-doc (< 1:0.18~) aber 0.15.4671+dfsg1-4 soll installiert werden
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
von chrisb » Fr Nov 08, 2019 5:10 pm
Falls Du vorher eine FreeCAD-Installation hattest, solltest Du Deinen ~/.FreeCAD-Ordner löschen oder erst mal umbenennen.
ich werde den Ordner löschen und es mal mit der neuen Version versuchen und melde mich ob es geht
vocx
Posts: 1912
Joined: Thu Oct 18, 2018 9:18 pm

Re: Freecad 0.18 bringt beim Starten Fehler und Icons fehlen

Postby vocx » Fri Nov 08, 2019 4:53 pm

anroubo wrote:
Fri Nov 08, 2019 2:54 pm
freecad (2:0.18.4+dfsg1~201911060029~ubuntu16.04.1) wird eingerichtet ...
It seems you are using Ubuntu 16.04. This version of Ubuntu is quite old. I strongly suggest you update to Ubuntu 18.04 at least.

FreeCAD funktioniert besser in 18.04.

Code: Select all

@andreas-HP-350-G2:~$ freecad
mkdir: cannot create directory '/home/andreas/snap/freecad/8/.config': File exists
Benutz mal die Snap-Version nicht.
anroubo
Posts: 3
Joined: Fri Nov 08, 2019 1:38 pm

Re: Freecad 0.18 bringt beim Starten Fehler und Icons fehlen

Postby anroubo » Sat Nov 09, 2019 10:22 pm

chrisb wrote:
Fri Nov 08, 2019 4:10 pm
Falls Du vorher eine FreeCAD-Installation hattest, solltest Du Deinen ~/.FreeCAD-Ordner löschen oder erst mal umbenennen.
Hab ich versucht, hat auch nicht funktioniert!

ich hab Ubuntu 16.04 auf Ubuntu 18.04 upgedatet und freecad wieder installiert.
Jetzt hat es funktioniert und die Version ist jetzt:

OS: Ubuntu 18.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.4.
Build type: Release
Python version: 3.6.8
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)