pivy 0.6.2

Have some feature requests, feedback, cool stuff to share, or want to know where FreeCAD is going? This is the place.
Forum rules
Be nice to others! Read the FreeCAD code of conduct!
User avatar
sgrogan
Posts: 5636
Joined: Wed Oct 22, 2014 5:02 pm

Re: pivy 0.6.2

Postby sgrogan » Wed Jun 21, 2017 11:12 pm

How much have you guys been able to test looo's pivy package with python 2.7? Especially on Ubuntu 14.04. how did you handle swig?
triplus
Posts: 9278
Joined: Mon Dec 12, 2011 4:45 pm

Re: pivy 0.6.2

Postby triplus » Wed Jun 21, 2017 11:21 pm

When i added the Pivy PPA (Ubuntu 16.04) it upgraded the python-pivy package (Python 2). I didn't remove it since and didn't notice any issues for now. As for Ubuntu 14.04 i haven't done any tests yet.
User avatar
sgrogan
Posts: 5636
Joined: Wed Oct 22, 2014 5:02 pm

Re: pivy 0.6.2

Postby sgrogan » Wed Jun 21, 2017 11:39 pm

triplus wrote:
Wed Jun 21, 2017 11:21 pm
When i added the Pivy PPA (Ubuntu 16.04) it upgraded the python-pivy package (Python 2). I didn't remove it since and didn't notice any issues for now.
Thanks triplus. Specifically I'm wondering about QT4 + Py2.7 + looo's pivy package on 16.04. I can test on 14.04. If all is good, I think I can move looo's pivy work to the daily PPA.
wmayer
Site Admin
Posts: 15487
Joined: Thu Feb 19, 2009 10:32 am

Re: pivy 0.6.2

Postby wmayer » Thu Jun 22, 2017 6:16 am

sgrogan wrote:
Wed Jun 21, 2017 11:12 pm
How much have you guys been able to test looo's pivy package with python 2.7? Especially on Ubuntu 14.04. how did you handle swig?
I made the same experience as triplus (under Ubuntu 14.04), i.e. that it upgraded the python-pivy package but everything still works fine. Since the wrapping/unwrapping of the Inventor classes still works as expected swig doesn't cause any problems. Note that also python3-pivy with the py3 build works flawlessly.
User avatar
looo
Posts: 3181
Joined: Mon Nov 11, 2013 5:29 pm

Re: pivy 0.6.2

Postby looo » Thu Jun 22, 2017 6:28 am

wmayer wrote:I made the same experience as triplus (under Ubuntu 14.04), i.e. that it upgraded the python-pivy package but everything still works fine.
good to hear different swig versions doesn't have any influence.
please help with my conda-packaging efforts: https://liberapay.com/looooo/
minimalistic blog: https://looooo.github.io/mini-blog/