Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Have some feature requests, feedback, cool stuff to share, or want to know where FreeCAD is going? This is the place.
Forum rules
Be nice to others! Read the FreeCAD code of conduct!
vocx
Posts: 4049
Joined: Thu Oct 18, 2018 9:18 pm

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby vocx » Mon Apr 29, 2019 2:26 am

kkremitzki wrote:
Wed Jan 16, 2019 3:33 pm
I've just uploaded OpenFOAM 1812 - please give it a try!
By the way, I have seen no mention of this, but I think the Gmsh 4.0.2 package is broken. It is not compiled against OpenCascade so it basically doesn't work.

Code: Select all

aptitude show libgmsh4.0

Depends: libann0, libblas3 | libblas.so.3, libc6 (>= 2.15), libcgns3.3 (>= 3.1.4.2),
libfltk-gl1.3 (>= 1.3.0), libfltk-images1.3, libfltk1.3 (>= 1.3.4), libgcc1 (>= 1:4.0), libgl1, libgl2ps1.4,
libglu1-mesa | libglu1, libgmp10, libhdf5-openmpi-100 (>= 1.8.13), libjpeg8 (>= 8c), liblapack3 | liblapack.so.3,
libopenmpi2, libpng16-16 (>= 1.6.2-1), libstdc++6 (>= 5.2), libx11-6
On the other hand, the Gmsh 3.0.6 that is in Ubuntu 18.04 works.

Code: Select all

aptitude show libgmsh3

Depends: libann0, libblas3 | libblas.so.3, libc6 (>= 2.15), libcgns3.3 (>= 3.1.4.2),
libfltk-gl1.3 (>= 1.3.0), libfltk-images1.3, libfltk1.3 (>= 1.3.4), libgcc1 (>= 1:4.0), libgl1-mesa-glx | libgl1, libgl2ps1.4,
libglu1-mesa | libglu1, libjpeg8 (>= 8c), liblapack3 | liblapack.so.3,
libmed1v5, liboce-foundation11, liboce-modeling11, libopenmpi2, libpng16-16 (>= 1.6.2-1), libstdc++6 (>= 5.2), libtet1.5, libx11-6
The dependency says liboce but the software recognizes it correctly like OpenCascade.

You should probably remove Gmsh 4.0.2 or not? Otherwise apt will install the 4.x version over the 3.x version, and it won't work. This is confusing for users.
Always add the important information to your posts if you need help.
To support the documentation effort, and code development, your donation is appreciated: paypal.
User avatar
kkremitzki
Posts: 1986
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby kkremitzki » Mon Apr 29, 2019 2:56 am

I just need to upload an updated gmsh package, the one in Debian Unstable is currently 4.1.5.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
User avatar
nemesis
Posts: 351
Joined: Tue Mar 25, 2014 11:24 pm
Location: France, Lyon

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby nemesis » Wed Oct 09, 2019 5:39 am

kkremitzki wrote:
Mon Apr 29, 2019 2:56 am
hi Kurt,
quick question, is Freecad 0.18.3 avaimable in debian buster repo? cause it looks like it is not, so if I m not wrong, do tou plan to update it?
User avatar
kkremitzki
Posts: 1986
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby kkremitzki » Wed Oct 09, 2019 7:29 am

nemesis wrote:
Wed Oct 09, 2019 5:39 am
kkremitzki wrote:
Mon Apr 29, 2019 2:56 am
hi Kurt,
quick question, is Freecad 0.18.3 avaimable in debian buster repo? cause it looks like it is not, so if I m not wrong, do tou plan to update it?
Eventually it will be available in buster-backports, see backports.debian.org.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
m0n5t3r
Posts: 104
Joined: Fri Feb 03, 2017 2:55 pm

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby m0n5t3r » Sun Feb 16, 2020 6:34 am

Hey, I got opencamlib-2019.07 packages to build with python3; built / tested on 18.04:
  • I dropped the python 2.7 version
  • the python3 lib seems to work (where by "work" I mean "import ocl" doesn't crash, I have no idea how to test more and I can do 3d surfaces now)
  • I made the C++ library provide a virtual package so it can replace other versions automatically (assuming the -year.month is needed at all in the name, I just went with the current scheme)
it's at https://launchpad.net/~iacobs/+archive/ubuntu/cnc, I guess it would be a good idea to get it into freecad-community PPA?
kkremitzki wrote: ping
User avatar
Kunda1
Posts: 7345
Joined: Thu Jan 05, 2017 9:03 pm

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby Kunda1 » Sun Feb 16, 2020 1:08 pm

m0n5t3r wrote:
Sun Feb 16, 2020 6:34 am
Hey, I got opencamlib-2019.07 packages to build with python3; built / tested on 18.04:
Awesome. I posted this to https://aur.archlinux.org/packages/open ... ent-729478 but what would be nice is if there are diffs i can attach for other packagers to learn how you added py3 support.

Also when the dust settles, do you mind updating the OpenCamLib page with this update and new instructions ?
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features
m0n5t3r
Posts: 104
Joined: Fri Feb 03, 2017 2:55 pm

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby m0n5t3r » Sun Feb 16, 2020 7:31 pm

there wasn't much to patch; the contents of the debian directory are at https://launchpad.net/~iacobs/+archive/ ... ian.tar.xz

debian/rules is basically a makefile, the relevant parts are the last 4 defines added to extra_flags:

Code: Select all

-DUSE_PY_3="ON" \
-DBUILD_PY_LIB="ON" \
-DPYTHON_EXECUTABLE="$(shell which python3)" \
-DPYTHON_VERSION_SUFFIX=3
the patch I added for the source is debian/patches/fix-python-paths.patch, which makes the path detection in https://github.com/aewallin/opencamlib/ ... .cmake#L51 and https://github.com/aewallin/opencamlib/ ... .cmake#L57 work with python 3 (and not return something bogus like /usr/local/lib/python3)

things seem to depend on the cmake version, though, have a look at the whole pythonlib file (it's not that large, and the logic is easy to follow even if you, like me, are totally clueless on cmake syntax / functions); if you have cmake >=3.12 you may have to provide all paths explicitly. like this: https://github.com/aewallin/opencamlib/ ... ml#L92-L95

edit: I don't have a wiki account, not sure how I could g about getting one
User avatar
Kunda1
Posts: 7345
Joined: Thu Jan 05, 2017 9:03 pm

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby Kunda1 » Sun Feb 16, 2020 8:21 pm

m0n5t3r wrote:
Sun Feb 16, 2020 7:31 pm
edit: I don't have a wiki account, not sure how I could g about getting one
PM me your preferred username and email, and I can set you up.
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features
m0n5t3r
Posts: 104
Joined: Fri Feb 03, 2017 2:55 pm

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby m0n5t3r » Tue Feb 18, 2020 3:43 pm

wiki updated; I also tested building in ubuntu 19.10 (cmake 3.13), it works without specifying the various paths explicitly; I ended up pushing an ubuntu 19.10 package to my PPA, for good measure.
User avatar
kkremitzki
Posts: 1986
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby kkremitzki » Fri Feb 21, 2020 2:25 am

m0n5t3r wrote:
Tue Feb 18, 2020 3:43 pm
wiki updated; I also tested building in ubuntu 19.10 (cmake 3.13), it works without specifying the various paths explicitly; I ended up pushing an ubuntu 19.10 package to my PPA, for good measure.
The packaging is based on repos at salsa.debian.org, the GitLab instance for the Debian Project. Do you mind preparing a PR so we can keep everything in one place? https://salsa.debian.org/science-team/opencamlib
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.