Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Have some feature requests, feedback, cool stuff to share, or want to know where FreeCAD is going? This is the place.
Forum rules
Be nice to others! Read the FreeCAD code of conduct!
vocx
Posts: 661
Joined: Thu Oct 18, 2018 9:18 pm

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby vocx » Mon Apr 29, 2019 2:26 am

kkremitzki wrote:
Wed Jan 16, 2019 3:33 pm
I've just uploaded OpenFOAM 1812 - please give it a try!
By the way, I have seen no mention of this, but I think the Gmsh 4.0.2 package is broken. It is not compiled against OpenCascade so it basically doesn't work.

Code: Select all

aptitude show libgmsh4.0

Depends: libann0, libblas3 | libblas.so.3, libc6 (>= 2.15), libcgns3.3 (>= 3.1.4.2),
libfltk-gl1.3 (>= 1.3.0), libfltk-images1.3, libfltk1.3 (>= 1.3.4), libgcc1 (>= 1:4.0), libgl1, libgl2ps1.4,
libglu1-mesa | libglu1, libgmp10, libhdf5-openmpi-100 (>= 1.8.13), libjpeg8 (>= 8c), liblapack3 | liblapack.so.3,
libopenmpi2, libpng16-16 (>= 1.6.2-1), libstdc++6 (>= 5.2), libx11-6
On the other hand, the Gmsh 3.0.6 that is in Ubuntu 18.04 works.

Code: Select all

aptitude show libgmsh3

Depends: libann0, libblas3 | libblas.so.3, libc6 (>= 2.15), libcgns3.3 (>= 3.1.4.2),
libfltk-gl1.3 (>= 1.3.0), libfltk-images1.3, libfltk1.3 (>= 1.3.4), libgcc1 (>= 1:4.0), libgl1-mesa-glx | libgl1, libgl2ps1.4,
libglu1-mesa | libglu1, libjpeg8 (>= 8c), liblapack3 | liblapack.so.3,
libmed1v5, liboce-foundation11, liboce-modeling11, libopenmpi2, libpng16-16 (>= 1.6.2-1), libstdc++6 (>= 5.2), libtet1.5, libx11-6
The dependency says liboce but the software recognizes it correctly like OpenCascade.

You should probably remove Gmsh 4.0.2 or not? Otherwise apt will install the 4.x version over the 3.x version, and it won't work. This is confusing for users.
User avatar
kkremitzki
Posts: 1583
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: Community Extras PPA Announcement & Support Thread: IfcOpenShell, Gmsh 4, freecad-doc translations & more!

Postby kkremitzki » Mon Apr 29, 2019 2:56 am

I just need to upload an updated gmsh package, the one in Debian Unstable is currently 4.1.5.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.