Marking PartDesign not properly attached datums

Have some feature requests, feedback, cool stuff to share, or want to know where FreeCAD is going? This is the place.
Forum rules
Be nice to others! Read the FreeCAD code of conduct!
User avatar
saso
Posts: 1279
Joined: Fri May 16, 2014 1:14 pm
Contact:

Re: Marking PartDesign not properly attached datums

Postby saso » Thu Jul 18, 2019 4:01 pm

DeepSOIC wrote:
Thu Jul 18, 2019 3:50 pm
I would prefer these extra icon columns to be on the right-hand side, not like in DAG View. To keep the tree cleaner.
I see your point... NX has this as menu options to show or hide many different additional columns of information
User avatar
DeepSOIC
Posts: 6694
Joined: Fri Aug 29, 2014 12:45 am
Location: Saint-Petersburg, Russia

Re: Marking PartDesign not properly attached datums

Postby DeepSOIC » Thu Jul 18, 2019 7:46 pm

openBrain wrote:
Wed Jul 17, 2019 5:02 pm
the icon is ... awful. :lol:
Looks like front view of a car, so can't give an obvious meaning to that. :)
saso wrote:
Thu Jul 18, 2019 3:09 pm
Existing icon seems quite clear to be an electrical plug
:lol: so many interpretations

Image
My intent was to depict a bug clinging onto a stem. Or a part tied with red rubber bands to another one.

I don't think that chain or lock are good icons, because they are too general. Neither has any association with "placement". But since no one seems to understand the meaning of current icon, I guess it is no better.
User avatar
DeepSOIC
Posts: 6694
Joined: Fri Aug 29, 2014 12:45 am
Location: Saint-Petersburg, Russia

Re: Marking PartDesign not properly attached datums

Postby DeepSOIC » Thu Jul 18, 2019 7:48 pm

openBrain wrote:
Wed Jul 17, 2019 5:02 pm
What about something like that :
not_attached_icon.svg.png
If you remove one of the pieces of the ring, that icon looks like a bar stuck to a magnet. That may actually be a good new icon, as it has that "placement" association to it.
chrisb
Posts: 16937
Joined: Tue Mar 17, 2015 9:14 am

Re: Marking PartDesign not properly attached datums

Postby chrisb » Thu Jul 18, 2019 10:44 pm

Perhaps we don't need an overlay icon at all, a color dor may be sufficient.
User avatar
saso
Posts: 1279
Joined: Fri May 16, 2014 1:14 pm
Contact:

Re: Marking PartDesign not properly attached datums

Postby saso » Thu Jul 18, 2019 10:48 pm

DeepSOIC wrote:
Thu Jul 18, 2019 7:46 pm
But since no one seems to understand the meaning of current icon, I guess it is no better.
I think the comment was about the pink overlay icons :)
Attachments
Screenshot_20190618_194726.png
Screenshot_20190618_194726.png (15.18 KiB) Viewed 163 times
openBrain
Posts: 1595
Joined: Fri Nov 09, 2018 5:38 pm

Re: Marking PartDesign not properly attached datums

Postby openBrain » Fri Jul 19, 2019 1:36 pm

DeepSOIC wrote:
Thu Jul 18, 2019 7:48 pm
If you remove one of the pieces of the ring, that icon looks like a bar stuck to a magnet. That may actually be a good new icon, as it has that "placement" association to it.
Simple striked magnet ?
not_attached_icon.svg.png
not_attached_icon.svg.png (1.48 KiB) Viewed 142 times
abdullah
Posts: 3174
Joined: Sun May 04, 2014 3:16 pm

Re: Marking PartDesign not properly attached datums

Postby abdullah » Sun Jul 21, 2019 7:36 am

openBrain wrote:
Wed Jul 17, 2019 5:02 pm
abdullah wrote:
Wed Jun 19, 2019 4:13 pm
If the code is acceptable, the icon may be changed:
I realized today that this feature is available. And indeed the icon is ... awful. :lol:
I could claim I did it awful on purpose, but it is a combination of lack of artistic skills and lack of interest.

Whatever icon that the long discussion ends-up having, if any, should come in XPM format:

Code: Select all

                static const char * const feature_detached_xpm[]={
                    "9 9 3 1",
                    ". c None",
                    "# c #cc00cc",
                    "a c #ffffff",
                    "...###...",
                    ".##aaa##.",
                    "##aaaaa##",
                    "##aaaaa##",
                    "#########",
                    "#########",
                    "#########",
                    ".##aaa##.",
                    ".##aaa##.",
"...###..."};
openBrain
Posts: 1595
Joined: Fri Nov 09, 2018 5:38 pm

Re: Marking PartDesign not properly attached datums

Postby openBrain » Mon Jul 22, 2019 12:17 pm

abdullah wrote:
Sun Jul 21, 2019 7:36 am
Whatever icon that the long discussion ends-up having, if any, should come in XPM format:
At least this explains a bit. ;)
If I'm correct, the first XPM line should be "9 10 3 1" (instead of "9 9 3 1").
ATM the last line is ignored which doesn't help the icon to be understandable. :lol: