Installation problems

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

User avatar
oliveroxtoby
Posts: 324
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: CfdOF Workbench Training Material

Postby oliveroxtoby » Wed Mar 28, 2018 11:38 am

thschrader wrote:
Tue Mar 20, 2018 10:33 am
@Oliver:
There is a guy in the german forum who has problems with installing cfmesh.
https://forum.freecadweb.org/viewtopic.php?f=13&t=27574
He has installed openfoam 5.0. So far I know openfoam 5.0 does not support cfmesh. Is that right?
When installing bluecfd via preferences/cfd, which version will be installed (2016-1/2016-2)?
Maybe you can have a look in the thread above and give an advice. No problem to
use english, we can translate it.
Thomas
We've upgraded it to support OpenFOAM 5 / BlueCFD 2017 now.
Please provide all the information requested in this post before reporting problems with CfdOF.
thschrader
Posts: 1432
Joined: Sat May 20, 2017 12:06 pm
Location: Germany

Re: CfdOF Workbench Training Material

Postby thschrader » Wed Mar 28, 2018 9:01 pm

oliveroxtoby wrote:
Wed Mar 28, 2018 11:38 am
We've upgraded it to support OpenFOAM 5 / BlueCFD 2017 now.
:)
I updated the cfd-of wb and installed bluecfd 2017. (I have installed the 2017-1 version,
which I downloaded before the 2017-2 was released. At the moment my internet-connection
is pretty slow...)
Installing cfmesh via preferences didnt work. I downloaded cfmesh from sourceforge and then
used the "Choose existing file..." option. That works. System:
OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13452 (Git)
Build type: Release
Branch: master
Hash: 34633c144de9133c1f9aeb7da783f369cae9bfaf
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: German/Germany (de_DE)

completed.JPG
completed.JPG (33.34 KiB) Viewed 778 times
User avatar
oliveroxtoby
Posts: 324
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: CfdOF Workbench Training Material

Postby oliveroxtoby » Thu Mar 29, 2018 7:17 am

thschrader wrote:
Wed Mar 28, 2018 9:01 pm
oliveroxtoby wrote:
Wed Mar 28, 2018 11:38 am
We've upgraded it to support OpenFOAM 5 / BlueCFD 2017 now.
:)
I updated the cfd-of wb and installed bluecfd 2017. (I have installed the 2017-1 version,
which I downloaded before the 2017-2 was released. At the moment my internet-connection
is pretty slow...)
Installing cfmesh via preferences didnt work.
This error (SSL: CERTIFICATE_VERIFY_FAILED) has been reported by several people. Current python best-practice seems to be to use the requests library instead of urllib for downloading files. Possibly that would fix the issue. However, python bundled in FreeCAD does not include requests, so for now it will have to stay as it is with the workaround of manually downloading and selecting the file.
Please provide all the information requested in this post before reporting problems with CfdOF.
MrRossi
Posts: 37
Joined: Thu Dec 01, 2016 7:30 am

Re: Installation problems

Postby MrRossi » Sat Mar 31, 2018 8:09 am

Hello Oliver

Doesn`t work. Same error as before.
Any further ideas?

Thanks and
Greetings
Christian
Attachments
Bild6.jpg
Bild6.jpg (140.86 KiB) Viewed 742 times
Bild7.jpg
Bild7.jpg (115.66 KiB) Viewed 742 times
jeno
Posts: 609
Joined: Sun Jun 29, 2014 10:41 am

Re: Installation problems

Postby jeno » Sat Mar 31, 2018 9:12 am

MrRossi wrote:
Sat Mar 31, 2018 8:09 am
Hello Oliver

Doesn`t work. Same error as before.
Any further ideas?

Thanks and
Greetings
Christian
Already mentioned in the thread at the german sub: screenshot bild6.jpg, local installation. There are a lot of slashes in the path, at least from my pov. After file: there are three and after the drive letter there are two. Assuming these are errors and the paths are used in variables then things might go wrong.
User avatar
oliveroxtoby
Posts: 324
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Installation problems

Postby oliveroxtoby » Tue Apr 03, 2018 6:48 am

MrRossi wrote:
Sat Mar 31, 2018 8:09 am
Hello Oliver

Doesn`t work. Same error as before.
Any further ideas?

Thanks and
Greetings
Christian
Please could I draw your attention to my previous post:
Also, please could you follow the instructions in my post about bug reporting, https://forum.freecadweb.org/viewtopic.php?f=37&t=27055 and copy all the output that appears on the report window when you try to build cfMesh? It is very hard to conclude anything from the screenshot.
Since you say that the log file is not created, then the full output on the report window is the only clue I can think of that may tell us what's going on. Thank you for persisting - hopefully we can eventually get to the bottom of this.
Please provide all the information requested in this post before reporting problems with CfdOF.
MrRossi
Posts: 37
Joined: Thu Dec 01, 2016 7:30 am

Re: Installation problems

Postby MrRossi » Tue Apr 03, 2018 5:07 pm

Hallo Oliver

I have attached a txt-file with all output lines which appeared during cfMesh instalklation in the report view.
Does this help?

Regards
Christian
Attachments
Error_Log.txt
(70.29 KiB) Downloaded 30 times
User avatar
oliveroxtoby
Posts: 324
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Installation problems

Postby oliveroxtoby » Wed Apr 04, 2018 7:44 am

MrRossi wrote:
Tue Apr 03, 2018 5:07 pm
Hallo Oliver

I have attached a txt-file with all output lines which appeared during cfMesh instalklation in the report view.
Does this help?

Regards
Christian
Hi Christian

That helps a lot, thanks. Unfortunately I am still stumped. The file indicates that there is an issue starting the blueCFD environment the second and third time it is tried. The lines
Setting environment for , using MSMPI71 - please wait...
indicate a problem - they should read:
Setting environment for OpenFOAM 5.x mingw-w64 Double Precision (of5-64), using MSMPI71 - please wait...
as it does the first time (line 4 of the file).

Unfortunately I can't figure out why this might be happening on your system. I can give you a few things to try if you have the patience? First thing would be to run the blueCFD core terminal (Start | All Programs | blueCFD 2017 | blueCFD core terminal) and check that it initialises correctly, i.e. you get
Setting environment for OpenFOAM 5.x mingw-w64 Double Precision (of5-64), using MSMPI71 - please wait...
as the first line, then exit and retry from FreeCAD.
Please provide all the information requested in this post before reporting problems with CfdOF.
MrRossi
Posts: 37
Joined: Thu Dec 01, 2016 7:30 am

Re: Installation problems

Postby MrRossi » Wed Apr 04, 2018 6:42 pm

Hallo Oliver

Thank you so much.
I have further information, installation worked as I booted the computer
In Safe Mode. Installation finished without an error, although I have seen red lines
In the report window during installation.
I haven't yet tried if it's really working.

I also will try your hints. Keep you posted.

Regards
Christian
emills2
Posts: 577
Joined: Tue Apr 28, 2015 11:23 pm

Re: Installation problems

Postby emills2 » Tue Apr 24, 2018 6:23 am

Hi, i am also having issues installing cfmesh. All attempts are from the last few days.

OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13515 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: e17b340949b75a226cc7d89989b0aa238ccfc75f
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)



blueCFD doesn't seem to have issues, but i have no idea how to run a test in the console. when i install cfmesh, i see a lot of error messages that look like

Code: Select all

Making dependency list for source file writeMeshFPMA.C
could not open file foamTime.H for source file utilities/dataConversion/foamToFPMA/fpmaMesh.C
The installation finishes after about 30 minutes (not sure). when i run dependency check, it hangs forever. the console makes it this far:

Code: Select all

Checking CFD workbench dependencies...
Checking FreeCAD version
Checking for OpenFOAM:
Running  echo $WM_PROJECT_VERSION
Raw command:  [u'C:/Program Files/FreeCAD 0.17/bin\\python.exe', '-u', 'C:\\Users\\Edward Mills\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\WindowsRunWrapper.py', 'C:\\PROGRA~1\\BLUECF~1\\OPENFO~1.X\\..\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', 'echo $WM_PROJECT_VERSION']
Setting environment for OpenFOAM 5.x mingw-w64 Double Precision (of5-64), using MSMPI71 - please wait...
Environment is now ready. Notes:
   - You can change between installed versions by running: ofmenu
   - You can change to other predefined versions by running: ofmenuNew
5.x
Traceback (most recent call last):
  File "C:\Users\Edward Mills\AppData\Roaming\FreeCAD\Mod\CfdOF\CfdPreferencePage.py", line 126, in runDependencyChecker
    msg = CfdTools.checkCfdDependencies()
  File "C:\Users\Edward Mills\AppData\Roaming\FreeCAD\Mod\CfdOF\CfdTools.py", line 802, in checkCfdDependencies
    if foam_ver != 'dev' and foam_ver != 'plus' and int(foam_ver.split('.')[0]) < 4:
ValueError: invalid literal for int() with base 10: '- You can change to other predefined versions by running: ofmenuNew'
the above was copied out of the console after closing the preferences screen in the middle of a hung dependency check.

i have attached the build log, and a dump of the freecad console. the freecad console shows errors that i didn't see in the build log.

any ideas?
Attachments
cfmesh freecad install console dump.txt
(477.43 KiB) Downloaded 28 times
log.buildCfMeshOnBlueCFD .txt
(406.18 KiB) Downloaded 24 times