Body invisible after deleting Part container

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
chrisb
Posts: 18177
Joined: Tue Mar 17, 2015 9:14 am

Body invisible after deleting Part container

Postby chrisb » Sun Jul 15, 2018 3:26 pm

In the attached file there is a Part container with a body inside. The cube inside the body is visible. When I delete the outer Part container I say "no" to the question if I want to delete the contents too. That operation leaves Body with its contents.

However, the Body is invisible, whether I toggle it or not. The same holds for all features if the body is more complicated. The only solution is to save and reload the file.

Did I miss something?
Attachments
HiddenBody.FCStd
(6.2 KiB) Downloaded 18 times
wandererfan
Posts: 2985
Joined: Tue Nov 06, 2012 5:42 pm

Re: Body invisible after deleting Part container

Postby wandererfan » Sun Jul 15, 2018 3:39 pm

chrisb wrote:
Sun Jul 15, 2018 3:26 pm
However, the Body is invisible, whether I toggle it or not. The same holds for all features if the body is more complicated. The only solution is to save and reload the file.
FWIW, I've had seemingly random problems with toggling visibility with the spacebar. Sometimes going in to the View tab in PropertyEditor works better.
User avatar
DeepSOIC
Posts: 6969
Joined: Fri Aug 29, 2014 12:45 am
Location: Saint-Petersburg, Russia

Re: Body invisible after deleting Part container

Postby DeepSOIC » Sun Jul 15, 2018 3:58 pm

chrisb wrote:
Sun Jul 15, 2018 3:26 pm
...
Clearly a bug. I can reproduce.


Another "fix" is to create a new 3d view, and close the old one.
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Body invisible after deleting Part container

Postby NormandC » Sun Jul 15, 2018 4:29 pm

DeepSOIC wrote:
Sun Jul 15, 2018 3:58 pm
Clearly a bug. I can reproduce.


Another "fix" is to create a new 3d view, and close the old one.
It's the same issue as when creating a PartDesign Boolean, then deleting it. The Body that was used in the Boolean is no longer visible; the only workaround is to create a new 3D view.

wandererfan wrote:
Sun Jul 15, 2018 3:39 pm
FWIW, I've had seemingly random problems with toggling visibility with the spacebar.
Pre-selection/selection highlighting is also out of whack where Bodies and Part containers are concerned. It works, it doesn't, it works, it doesn't, with no logical reason why... Very confusing.
chrisb
Posts: 18177
Joined: Tue Mar 17, 2015 9:14 am

Re: Body invisible after deleting Part container

Postby chrisb » Sun Jul 15, 2018 5:04 pm

Should I create a ticket for this (reproducible) one?
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Body invisible after deleting Part container

Postby NormandC » Mon Jul 16, 2018 6:36 pm

IMO yes.
chrisb
Posts: 18177
Joined: Tue Mar 17, 2015 9:14 am

Re: Body invisible after deleting Part container

Postby chrisb » Mon Jul 16, 2018 11:42 pm

wmayer
Site Admin
Posts: 14795
Joined: Thu Feb 19, 2009 10:32 am

Re: Body invisible after deleting Part container

Postby wmayer » Fri Sep 21, 2018 1:13 pm

chrisb
Posts: 18177
Joined: Tue Mar 17, 2015 9:14 am

Re: Body invisible after deleting Part container

Postby chrisb » Fri Sep 21, 2018 2:06 pm

Works flawless, thank you.
freedman
Posts: 887
Joined: Thu Mar 22, 2018 3:02 am
Location: Washington State, USA

Re: Body invisible after deleting Part container

Postby freedman » Fri Sep 21, 2018 2:29 pm

After deleting the Part container I created a new one and the cube shows up.