SIGSEGV signal raised: 11

Having trouble installing or compiling FreeCAD? Get help here.
brothermechanic
Posts: 8
Joined: Tue Mar 20, 2018 11:20 am

SIGSEGV signal raised: 11

Postby brothermechanic » Tue Aug 07, 2018 2:00 am

Hello
I compiule freecad, but it don't works stable.
Help me right compile freecad on my system.
My system - gentoo kde Asus GL703VM.
This is screencast from my desctop
https://youtu.be/KFsru7grL_0
As you can see, my build with opencascade-6*
I recompile freecad with opencascade-7* (7.3.0) and get this error
libTKFillet.so.7: cannot open shared object file: No such file or directory
Image
My overlay https://github.com/brothermechanic/cg/t ... fx/freecad
I need to know where is the bug? May be i have wrong version of some libs?
Please help to solve this!
Last edited by brothermechanic on Tue Aug 07, 2018 10:34 am, edited 1 time in total.
wmayer
Site Admin
Posts: 14882
Joined: Thu Feb 19, 2009 10:32 am

Re: SIGSEGV signal raised: 11

Postby wmayer » Tue Aug 07, 2018 7:44 am

When building FreeCAD to link against another OCCT version you should do a "make clean" before. Sometimes you even have to completely erase the build directory because cmake still keeps some old values in its cache.
Then you must make sure that 3rd party libs like netgen use the same OCCT version.
brothermechanic
Posts: 8
Joined: Tue Mar 20, 2018 11:20 am

Re: SIGSEGV signal raised: 11

Postby brothermechanic » Tue Aug 07, 2018 10:38 am

wmayer
Thank you for answer
This is my overlay
https://github.com/brothermechanic/cg/t ... fx/freecad
I often building software, for example blender (see my overlay)
Make, make clean in my gentoo system is did automatically.
Netgen i dont install separately, because it is in 3rd-party folder
May be this is bug in freecad deps like boost or other?
Or this is freecad's bug?
wmayer
Site Admin
Posts: 14882
Joined: Thu Feb 19, 2009 10:32 am

Re: SIGSEGV signal raised: 11

Postby wmayer » Tue Aug 07, 2018 10:57 am

Are you sure that in cmake the two variables concerning OCCT are set correctly? And does it help to set LD_LIBRARY_PATH to point to the lib directory of OCCT?