compile with py3 and Qt5 on Debian Stretch

Having trouble installing or compiling FreeCAD? Get help here.
User avatar
kkremitzki
Posts: 1759
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: compile with py3 and Qt5 on Debian Stretch

Postby kkremitzki » Tue Nov 20, 2018 10:46 pm

bernd wrote:
Tue Nov 20, 2018 10:42 pm
I havae problems with Qt5 on Debian Buster ...
Can you try adding -DPYTHON_CONFIG_SUFFIX="-python2.7.x86_64-linux-gnu" to your cmake flags?
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
user1234
Posts: 187
Joined: Mon Jul 11, 2016 5:08 pm

Re: compile with py3 and Qt5 on Debian Stretch

Postby user1234 » Tue Nov 20, 2018 10:49 pm

Hello!
Try

Code: Select all

-DPYTHON_CONFIG_SUFFIX="-python2.7.x86_64-linux-gnu" 
I do not know anymore who tells me that trick. But the VTK is mad on Debian testing. The new CMake do not like that.

Greetings
user

edit, as always to late ....
User avatar
bernd
Posts: 8439
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: compile with py3 and Qt5 on Debian Stretch

Postby bernd » Tue Nov 20, 2018 11:20 pm

the shiboken and pyside errors are gone ... :)

still the qt5x11extras are somehow missing ...

Code: Select all

CMake Error at src/Gui/CMakeLists.txt:110 (find_package):
  By not providing "FindQt5X11Extras.cmake" in CMAKE_MODULE_PATH this project
  has asked CMake to find a package configuration file provided by
  "Qt5X11Extras", but CMake did not find one.

  Could not find a package configuration file provided by "Qt5X11Extras" with
  any of the following names:

    Qt5X11ExtrasConfig.cmake
    qt5x11extras-config.cmake

  Add the installation prefix of "Qt5X11Extras" to CMAKE_PREFIX_PATH or set
  "Qt5X11Extras_DIR" to a directory containing one of the above files.  If
  "Qt5X11Extras" provides a separate development package or SDK, be sure it
  has been installed.


-- Configuring incomplete, errors occurred!

but

Code: Select all

$ dpkg -l | grep  qt5x11extras
ii  libqt5x11extras5:amd64                 5.11.2-2                     amd64        Qt 5 X11 extras
$ 
User avatar
kkremitzki
Posts: 1759
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: compile with py3 and Qt5 on Debian Stretch

Postby kkremitzki » Wed Nov 21, 2018 12:27 am

Try grabbing the libqt5x11extras5-dev package.

Edit: The apt-file tool is good for this:

Code: Select all

$ apt-file search Qt5X11ExtrasConfig.cmake
libqt5x11extras5-dev: /usr/lib/x86_64-linux-gnu/cmake/Qt5X11Extras/Qt5X11ExtrasConfig.cmake
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
User avatar
bernd
Posts: 8439
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: compile with py3 and Qt5 on Debian Stretch

Postby bernd » Wed Nov 21, 2018 5:49 am

:D 8-)
User avatar
bernd
Posts: 8439
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: compile with py3 and Qt5 on Debian Stretch

Postby bernd » Wed Nov 21, 2018 9:48 pm

first step is done. It compiles on Debian Buster with Qt5 ...

https://github.com/berndhahnebach/FreeC ... Qt5_Py2.sh

next step will be Py3 afterwards I decide it I give Stretch a try in compiling FreeCAD Qt5Py3 or if I give Buster a try on my Computer ... :geek:
User avatar
kkremitzki
Posts: 1759
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: compile with py3 and Qt5 on Debian Stretch

Postby kkremitzki » Wed Nov 21, 2018 10:02 pm

bernd wrote:
Wed Nov 21, 2018 9:48 pm
next step will be Py3 afterwards I decide it I give Stretch a try in compiling FreeCAD Qt5Py3 or if I give Buster a try on my Computer ... :geek:
The release of Buster is coming up so switching to it in advance is not such a bad idea.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
User avatar
bernd
Posts: 8439
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: compile with py3 and Qt5 on Debian Stretch

Postby bernd » Thu Nov 22, 2018 9:36 am

FreeCAD Qt5 runs on Buster. Next step is Python 3.

kkremitzki wrote:
Mon Nov 19, 2018 8:02 pm
Right now all you need to build Qt5 + Py3 on Debian Buster is a python3-pivy package. You can refer to my package for that here: https://salsa.debian.org/kkremitzki-guest/pivy
The pivy from your repo are just Python files. What do I need to do with them?

How do I tell cmake that it trys to compile against Python3 and it finds my brand new pivy?

Bernd
User avatar
kkremitzki
Posts: 1759
Joined: Thu Mar 03, 2016 9:52 pm
Location: Texas

Re: compile with py3 and Qt5 on Debian Stretch

Postby kkremitzki » Thu Nov 22, 2018 4:22 pm

bernd wrote:
Thu Nov 22, 2018 9:36 am
FreeCAD Qt5 runs on Buster. Next step is Python 3.

kkremitzki wrote:
Mon Nov 19, 2018 8:02 pm
Right now all you need to build Qt5 + Py3 on Debian Buster is a python3-pivy package. You can refer to my package for that here: https://salsa.debian.org/kkremitzki-guest/pivy
The pivy from your repo are just Python files. What do I need to do with them?

How do I tell cmake that it trys to compile against Python3 and it finds my brand new pivy?

Bernd
It's the debian folder that contains the magic, if you're in the top-level folder you should be able to run:

Code: Select all

git archive upstream | gzip > ../pivy_0.6.4.orig.tar.gz
dpkg-buildpackage -us -uc
to produce all the .deb files associated with that package.
Like my FreeCAD work? I'd appreciate any level of support via Patreon, Liberapay, or PayPal! Read more about what I do at my blog.
abdullah
Posts: 3174
Joined: Sun May 04, 2014 3:16 pm

Re: compile with py3 and Qt5 on Debian Stretch

Postby abdullah » Sun Nov 25, 2018 6:02 am

EDIT: I really replied to something old. You might delete this post.