Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
user_of_freecad
Posts: 14
Joined: Wed Dec 13, 2017 11:40 pm

Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby user_of_freecad » Sat Jan 26, 2019 10:20 pm

And as a result, I can't open projects. Saving them works just fine, I can extract the files and it contains a list of other files but I can't get them to open in FreeCAD any more.

Even if I add the extension to the file, it will fill refuse to open it stating that 'the filetype is not supported'

I haven't made any changes to FreeCAD, I deleted my user and system config files and that did not fix the problem.

The last thing I was doing was following this tutorial by Ha Gei and saving my project halfway through: https://www.youtube.com/watch?v=8Bmcgn2RBGI

OS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

Similar issues have been reported in the past:

https://forum.freecadweb.org/viewtopic.php?t=31122

What's going on? How do I repair this?

I can't upload my files for display here because they're the wrong file type according the forum.
user_of_freecad
Posts: 14
Joined: Wed Dec 13, 2017 11:40 pm

Re: Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby user_of_freecad » Sat Jan 26, 2019 10:28 pm

Running FreeCAD with sudo seems to fix the problem but instead of using the more native Gnome file explorer, I seem to end up with a more sleek looking file explorer that I have not seen before. The save icon is different as well.

Edit: I can even open the file I saved with the un-sudo'ed FreeCAD after giving it the .fcstd file extension this way.

Not sure how this happened overnight, must have been an Ubuntu update that broke something ... if anyone knows how to get it back to normal, that'd be dandy.
trevelyon
Posts: 22
Joined: Thu Dec 27, 2018 3:32 am

Re: Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby trevelyon » Sun Jan 27, 2019 3:43 am

I can confirm this behavior. It is, however, not universal. The following exports with no extension:
-save freecad file
-export stl mesh

The following exports with extension:
save picture (tested for bmp and png)


@user_of_freecad
you might want to try the following as your normal user:

1. save the file as <filename>.fcstd (example: myfile.fcstd)
2. browse the location where the file is in nautilus
3. right click on file and select properties
4. click "open with" tab, select freecad then click "set as default"

Note: I am running gnome-flashback so these instructions might be a bit different on your system. Try it and see if it is an acceptable work-around.

Hope this helps,
user_of_freecad
Posts: 14
Joined: Wed Dec 13, 2017 11:40 pm

Re: Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby user_of_freecad » Sun Jan 27, 2019 9:51 am

trevelyon wrote:
Sun Jan 27, 2019 3:43 am

4. click "open with" tab, select freecad then click "set as default"
Thank you but that already seemed to be the case.

I did notice that renaming the file and double clicking on it allows me to open my project. I suppose that's a pretty acceptable workaround, thanks.

For the sake of experimenting, I tried exporting to STL and FreeCAD adds .stl extension to the file for me and also allows me to open it through the FreeCAD file browser. JPG, TIF and BMP export properly as well.
wmayer
Site Admin
Posts: 14644
Joined: Thu Feb 19, 2009 10:32 am

Re: Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby wmayer » Sun Jan 27, 2019 11:23 am

What's going on? How do I repair this?
The problem is somehow with the native file dialog on some DEs. The easiest would be to upgrade to v0.18 where we have added an option to change at runtime between the native and Qt file dialog.

Therefore open the Parameter editor from the Tools menu and navigate to BaseApp/Preferences/Dialog. Now create a boolean parameter DontUseNativeDialog and set it to true.
sawozny
Posts: 20
Joined: Mon Aug 31, 2015 9:21 pm
Location: NYC

Re: Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby sawozny » Sun Jan 27, 2019 5:08 pm

FYI, I also have this problem with v17 on Ubuntu 18.04. I've been able to work around it with manually adding the extension (either in the save dialog, or afterwards in Nautilus). The problem is gone in v18 for me even without adding the boolean, but I'm not sure I want to migrate yet, so I'm just dong manual extension management.
user_of_freecad
Posts: 14
Joined: Wed Dec 13, 2017 11:40 pm

Re: Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby user_of_freecad » Mon Jan 28, 2019 1:12 pm

I'll wait for it to be added to the official repository but glad to see there is a workaround in the new version, thanks!
sawozny
Posts: 20
Joined: Mon Aug 31, 2015 9:21 pm
Location: NYC

Re: Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby sawozny » Mon Jan 28, 2019 5:27 pm

FWIW, I tried the v17 AppImage and the file extension problem didn't happen there. It also uses a different version of Qt than what's in the PPA version, which may be why it's not a problem in that version. I'm not going to use it long-term because the issue doesn't bother me that much and I don't want to give up the notifications of updates that comes with using the PPA version, but I thought I'd mention it.

You can get it here:
https://github.com/FreeCAD/FreeCAD/releases/tag/0.17

Just download, make executable and run.
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Freecad 0.17 (Ubuntu 18.04) stopped using the .fcstd extension when saving files

Postby NormandC » Tue Jan 29, 2019 3:30 pm

I confirm.

Let's call the package manager on this.

kkremitzki wrote:ping
Kurt, is it possible that you changed the package to use the native file dialog?