PPA problem updating to Release of 0.18

Having trouble installing or compiling FreeCAD? Get help here.
User avatar
sgrogan
Posts: 5242
Joined: Wed Oct 22, 2014 5:02 pm

Re: PPA problem updating to Release of 0.18

Postby sgrogan » Thu Apr 11, 2019 12:30 am

Renato Rebelo wrote:
Thu Apr 11, 2019 12:22 am
I think everything is clean

Code: Select all

sudo add-apt-repository ppa:freecad-maintainers/freecad-stable
sudo apt-get update
sudo apt-get freecad
I think the log from this is key.
Renato Rebelo
Posts: 255
Joined: Mon May 19, 2014 1:14 pm
Location: Vouzela - Portugal

Re: PPA problem updating to Release of 0.18

Postby Renato Rebelo » Thu Apr 11, 2019 12:36 am

sgrogan wrote:
Thu Apr 11, 2019 12:30 am
Renato Rebelo wrote:
Thu Apr 11, 2019 12:22 am
I think everything is clean

Code: Select all

sudo add-apt-repository ppa:freecad-maintainers/freecad-stable
sudo apt-get update
sudo apt-get freecad
I think the log from this is key.
Step 1 and 2 ok,
then
renato@ubuntussd:~$ sudo apt-get freecad
E: Operação freecad inválida

you did not mean?
sudo apt-get install freecad
my native language is not English, please excuse me any incorrectness, I apologize for any inconvenience caused, thank you
User avatar
sgrogan
Posts: 5242
Joined: Wed Oct 22, 2014 5:02 pm

Re: PPA problem updating to Release of 0.18

Postby sgrogan » Thu Apr 11, 2019 12:43 am

Renato Rebelo wrote:
Thu Apr 11, 2019 12:36 am
sudo apt-get install freecad
Yes, sorry. Watch the messages.
Renato Rebelo
Posts: 255
Joined: Mon May 19, 2014 1:14 pm
Location: Vouzela - Portugal

Re: PPA problem updating to Release of 0.18

Postby Renato Rebelo » Thu Apr 11, 2019 12:53 am

sgrogan wrote:
Thu Apr 11, 2019 12:43 am
Renato Rebelo wrote:
Thu Apr 11, 2019 12:36 am
sudo apt-get install freecad
Yes, sorry. Watch the messages.
The freecad continues without workbenches ...

Code: Select all

renato@ubuntussd:~$ sudo apt-get install freecad
A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
The following additional packages will be installed:
  calculix-ccx freecad-common freecad-python3 freecad-runtime libclang1-6.0 libcoin80c libfreecad-python3-0.18
  libfreeimage3 libgl2ps1.4 libhdf5-openmpi-100 libjxr0 libmedc1v5 libnetcdf-c++4 libocct-data-exchange-7.3
  libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3
  libocct-visualization-7.3 libpyside2-py3-5.11 libshiboken2-py3-5.11 libsoqt520 libspooles2.2 libvtk7.1 libzipios++0v5
  python3-pivy python3-pyside2.qtcore python3-pyside2.qtgui python3-pyside2.qtopengl python3-pyside2.qtsvg
  python3-pyside2.qtwidgets python3-pyside2uic shiboken2
Pacotes sugeridos:
  povray libopenal0a libsimage-dev libmed-doc libmed-tools vtk7-doc vtk7-examples python-pyside2-doc
Serão instalados os seguintes NOVOS pacotes:
  calculix-ccx freecad freecad-common freecad-python3 freecad-runtime libclang1-6.0 libcoin80c libfreecad-python3-0.18
  libfreeimage3 libgl2ps1.4 libhdf5-openmpi-100 libjxr0 libmedc1v5 libnetcdf-c++4 libocct-data-exchange-7.3
  libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3
  libocct-visualization-7.3 libpyside2-py3-5.11 libshiboken2-py3-5.11 libsoqt520 libspooles2.2 libvtk7.1 libzipios++0v5
  python3-pivy python3-pyside2.qtcore python3-pyside2.qtgui python3-pyside2.qtopengl python3-pyside2.qtsvg
  python3-pyside2.qtwidgets python3-pyside2uic shiboken2
0 pacotes actualizados, 34 pacotes novos instalados, 0 a remover e 0 não actualizados.
É necessário obter 0 B/104 MB de arquivos.
Após esta operação, serão utilizados 471 MB adicionais de espaço em disco.
Deseja continuar? [S/n] s
A extrair templates a partir dos pacotes: 100%
A seleccionar pacote anteriormente não seleccionado libspooles2.2:amd64.
(A ler a base de dados ... 635366 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../00-libspooles2.2_2.2-12build1_amd64.deb ...
A descompactar libspooles2.2:amd64 (2.2-12build1) ...
A seleccionar pacote anteriormente não seleccionado calculix-ccx.
A preparar para desempacotar .../01-calculix-ccx_2.11-1build1_amd64.deb ...
A descompactar calculix-ccx (2.11-1build1) ...
A seleccionar pacote anteriormente não seleccionado freecad-common.
A preparar para desempacotar .../02-freecad-common_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_all.deb ...
A descompactar freecad-common (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado freecad-runtime.
A preparar para desempacotar .../03-freecad-runtime_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_all.deb ...
A descompactar freecad-runtime (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libcoin80c.
A preparar para desempacotar .../04-libcoin80c_4.0.0~CMake~6f54f1602475+ds1-0ppa1~ubuntu18.04_amd64.deb ...
A descompactar libcoin80c (4.0.0~CMake~6f54f1602475+ds1-0ppa1~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libsoqt520.
A preparar para desempacotar .../05-libsoqt520_1.6.0~ea5cd76+ds1-0ppa1~ubuntu18.04_amd64.deb ...
A descompactar libsoqt520 (1.6.0~ea5cd76+ds1-0ppa1~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libshiboken2-py3-5.11.
A preparar para desempacotar .../06-libshiboken2-py3-5.11_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar libshiboken2-py3-5.11 (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libpyside2-py3-5.11.
A preparar para desempacotar .../07-libpyside2-py3-5.11_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar libpyside2-py3-5.11 (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtcore.
A preparar para desempacotar .../08-python3-pyside2.qtcore_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtcore (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtgui.
A preparar para desempacotar .../09-python3-pyside2.qtgui_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtgui (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtopengl.
A preparar para desempacotar .../10-python3-pyside2.qtopengl_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtopengl (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtwidgets.
A preparar para desempacotar .../11-python3-pyside2.qtwidgets_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtwidgets (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libclang1-6.0:amd64.
A preparar para desempacotar .../12-libclang1-6.0_1%3a6.0-1ubuntu2_amd64.deb ...
A descompactar libclang1-6.0:amd64 (1:6.0-1ubuntu2) ...
A seleccionar pacote anteriormente não seleccionado shiboken2.
A preparar para desempacotar .../13-shiboken2_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar shiboken2 (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pivy.
A preparar para desempacotar .../14-python3-pivy_0.6.4-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pivy (0.6.4-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtsvg.
A preparar para desempacotar .../15-python3-pyside2.qtsvg_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtsvg (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2uic.
A preparar para desempacotar .../16-python3-pyside2uic_5.11.2-0ppa2~ubuntu18.04_all.deb ...
A descompactar python3-pyside2uic (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libhdf5-openmpi-100:amd64.
A preparar para desempacotar .../17-libhdf5-openmpi-100_1.10.0-patch1+docs-4_amd64.deb ...
A descompactar libhdf5-openmpi-100:amd64 (1.10.0-patch1+docs-4) ...
A seleccionar pacote anteriormente não seleccionado libmedc1v5:amd64.
A preparar para desempacotar .../18-libmedc1v5_3.0.6-11build1_amd64.deb ...
A descompactar libmedc1v5:amd64 (3.0.6-11build1) ...
A seleccionar pacote anteriormente não seleccionado libocct-foundation-7.3:amd64.
A preparar para desempacotar .../19-libocct-foundation-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-foundation-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libocct-modeling-data-7.3:amd64.
A preparar para desempacotar .../20-libocct-modeling-data-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-modeling-data-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libocct-modeling-algorithms-7.3:amd64.
A preparar para desempacotar .../21-libocct-modeling-algorithms-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-modeling-algorithms-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libjxr0:amd64.
A preparar para desempacotar .../22-libjxr0_1.1-6build1_amd64.deb ...
A descompactar libjxr0:amd64 (1.1-6build1) ...
A seleccionar pacote anteriormente não seleccionado libfreeimage3:amd64.
A preparar para desempacotar .../23-libfreeimage3_3.17.0+ds1-5build2_amd64.deb ...
A descompactar libfreeimage3:amd64 (3.17.0+ds1-5build2) ...
A seleccionar pacote anteriormente não seleccionado libocct-visualization-7.3:amd64.
A preparar para desempacotar .../24-libocct-visualization-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-visualization-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libocct-ocaf-7.3:amd64.
A preparar para desempacotar .../25-libocct-ocaf-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-ocaf-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libocct-data-exchange-7.3:amd64.
A preparar para desempacotar .../26-libocct-data-exchange-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-data-exchange-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libgl2ps1.4.
A preparar para desempacotar .../27-libgl2ps1.4_1.4.0+dfsg1-1_amd64.deb ...
A descompactar libgl2ps1.4 (1.4.0+dfsg1-1) ...
A seleccionar pacote anteriormente não seleccionado libnetcdf-c++4.
A preparar para desempacotar .../28-libnetcdf-c++4_4.2-8_amd64.deb ...
A descompactar libnetcdf-c++4 (4.2-8) ...
A seleccionar pacote anteriormente não seleccionado libvtk7.1.
A preparar para desempacotar .../29-libvtk7.1_7.1.1+dfsg1-2_amd64.deb ...
A descompactar libvtk7.1 (7.1.1+dfsg1-2) ...
A seleccionar pacote anteriormente não seleccionado libzipios++0v5.
A preparar para desempacotar .../30-libzipios++0v5_0.1.5.9+cvs.2007.04.28-10_amd64.deb ...
A descompactar libzipios++0v5 (0.1.5.9+cvs.2007.04.28-10) ...
A seleccionar pacote anteriormente não seleccionado libfreecad-python3-0.18.
A preparar para desempacotar .../31-libfreecad-python3-0.18_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_amd64.deb ...
A descompactar libfreecad-python3-0.18 (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado freecad-python3.
A preparar para desempacotar .../32-freecad-python3_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_amd64.deb ...
A descompactar freecad-python3 (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado freecad.
A preparar para desempacotar .../33-freecad_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_all.deb ...
A descompactar freecad (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A instalar libocct-foundation-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libnetcdf-c++4 (4.2-8) ...
A instalar libhdf5-openmpi-100:amd64 (1.10.0-patch1+docs-4) ...
A instalar python3-pyside2uic (5.11.2-0ppa2~ubuntu18.04) ...
A processar 'triggers' para mime-support (3.60ubuntu1) ...
A processar 'triggers' para desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
A instalar libshiboken2-py3-5.11 (5.11.2-0ppa2~ubuntu18.04) ...
A instalar libocct-modeling-data-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libzipios++0v5 (0.1.5.9+cvs.2007.04.28-10) ...
A instalar libclang1-6.0:amd64 (1:6.0-1ubuntu2) ...
A instalar libcoin80c (4.0.0~CMake~6f54f1602475+ds1-0ppa1~ubuntu18.04) ...
A instalar libmedc1v5:amd64 (3.0.6-11build1) ...
A instalar libspooles2.2:amd64 (2.2-12build1) ...
A instalar libsoqt520 (1.6.0~ea5cd76+ds1-0ppa1~ubuntu18.04) ...
A instalar libocct-modeling-algorithms-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libjxr0:amd64 (1.1-6build1) ...
A processar 'triggers' para bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...
A processar 'triggers' para man-db (2.8.3-2ubuntu0.1) ...
A processar 'triggers' para shared-mime-info (1.9-2) ...
A processar 'triggers' para gnome-menus (3.13.3-11ubuntu1.1) ...
A instalar shiboken2 (5.11.2-0ppa2~ubuntu18.04) ...
A processar 'triggers' para hicolor-icon-theme (0.17-2) ...
A instalar freecad-common (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A instalar freecad-runtime (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A instalar libgl2ps1.4 (1.4.0+dfsg1-1) ...
A instalar calculix-ccx (2.11-1build1) ...
A instalar libpyside2-py3-5.11 (5.11.2-0ppa2~ubuntu18.04) ...
A instalar libfreeimage3:amd64 (3.17.0+ds1-5build2) ...
A instalar python3-pyside2.qtcore (5.11.2-0ppa2~ubuntu18.04) ...
A instalar libvtk7.1 (7.1.1+dfsg1-2) ...
A instalar python3-pyside2.qtgui (5.11.2-0ppa2~ubuntu18.04) ...
A instalar python3-pyside2.qtsvg (5.11.2-0ppa2~ubuntu18.04) ...
A instalar libocct-visualization-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar python3-pyside2.qtopengl (5.11.2-0ppa2~ubuntu18.04) ...
A instalar python3-pyside2.qtwidgets (5.11.2-0ppa2~ubuntu18.04) ...
A instalar python3-pivy (0.6.4-0ppa2~ubuntu18.04) ...
A instalar libocct-ocaf-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libocct-data-exchange-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libfreecad-python3-0.18 (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A instalar freecad-python3 (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
update-alternatives: a usar /usr/lib/freecad/bin/freecad-python3 para disponibilizar /usr/bin/freecad (freecad) em modo auto
A instalar freecad (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...
my native language is not English, please excuse me any incorrectness, I apologize for any inconvenience caused, thank you
Renato Rebelo
Posts: 255
Joined: Mon May 19, 2014 1:14 pm
Location: Vouzela - Portugal

Re: PPA problem updating to Release of 0.18

Postby Renato Rebelo » Thu Apr 11, 2019 12:53 am

Renato Rebelo wrote:
Thu Apr 11, 2019 12:53 am
sgrogan wrote:
Thu Apr 11, 2019 12:43 am
Renato Rebelo wrote:
Thu Apr 11, 2019 12:36 am
sudo apt-get install freecad
Yes, sorry. Watch the messages.
The freecad continues without workbenches ...

no messages on startup

Code: Select all

renato@ubuntussd:~$ sudo apt-get install freecad
A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
The following additional packages will be installed:
  calculix-ccx freecad-common freecad-python3 freecad-runtime libclang1-6.0 libcoin80c libfreecad-python3-0.18
  libfreeimage3 libgl2ps1.4 libhdf5-openmpi-100 libjxr0 libmedc1v5 libnetcdf-c++4 libocct-data-exchange-7.3
  libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3
  libocct-visualization-7.3 libpyside2-py3-5.11 libshiboken2-py3-5.11 libsoqt520 libspooles2.2 libvtk7.1 libzipios++0v5
  python3-pivy python3-pyside2.qtcore python3-pyside2.qtgui python3-pyside2.qtopengl python3-pyside2.qtsvg
  python3-pyside2.qtwidgets python3-pyside2uic shiboken2
Pacotes sugeridos:
  povray libopenal0a libsimage-dev libmed-doc libmed-tools vtk7-doc vtk7-examples python-pyside2-doc
Serão instalados os seguintes NOVOS pacotes:
  calculix-ccx freecad freecad-common freecad-python3 freecad-runtime libclang1-6.0 libcoin80c libfreecad-python3-0.18
  libfreeimage3 libgl2ps1.4 libhdf5-openmpi-100 libjxr0 libmedc1v5 libnetcdf-c++4 libocct-data-exchange-7.3
  libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3
  libocct-visualization-7.3 libpyside2-py3-5.11 libshiboken2-py3-5.11 libsoqt520 libspooles2.2 libvtk7.1 libzipios++0v5
  python3-pivy python3-pyside2.qtcore python3-pyside2.qtgui python3-pyside2.qtopengl python3-pyside2.qtsvg
  python3-pyside2.qtwidgets python3-pyside2uic shiboken2
0 pacotes actualizados, 34 pacotes novos instalados, 0 a remover e 0 não actualizados.
É necessário obter 0 B/104 MB de arquivos.
Após esta operação, serão utilizados 471 MB adicionais de espaço em disco.
Deseja continuar? [S/n] s
A extrair templates a partir dos pacotes: 100%
A seleccionar pacote anteriormente não seleccionado libspooles2.2:amd64.
(A ler a base de dados ... 635366 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../00-libspooles2.2_2.2-12build1_amd64.deb ...
A descompactar libspooles2.2:amd64 (2.2-12build1) ...
A seleccionar pacote anteriormente não seleccionado calculix-ccx.
A preparar para desempacotar .../01-calculix-ccx_2.11-1build1_amd64.deb ...
A descompactar calculix-ccx (2.11-1build1) ...
A seleccionar pacote anteriormente não seleccionado freecad-common.
A preparar para desempacotar .../02-freecad-common_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_all.deb ...
A descompactar freecad-common (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado freecad-runtime.
A preparar para desempacotar .../03-freecad-runtime_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_all.deb ...
A descompactar freecad-runtime (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libcoin80c.
A preparar para desempacotar .../04-libcoin80c_4.0.0~CMake~6f54f1602475+ds1-0ppa1~ubuntu18.04_amd64.deb ...
A descompactar libcoin80c (4.0.0~CMake~6f54f1602475+ds1-0ppa1~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libsoqt520.
A preparar para desempacotar .../05-libsoqt520_1.6.0~ea5cd76+ds1-0ppa1~ubuntu18.04_amd64.deb ...
A descompactar libsoqt520 (1.6.0~ea5cd76+ds1-0ppa1~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libshiboken2-py3-5.11.
A preparar para desempacotar .../06-libshiboken2-py3-5.11_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar libshiboken2-py3-5.11 (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libpyside2-py3-5.11.
A preparar para desempacotar .../07-libpyside2-py3-5.11_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar libpyside2-py3-5.11 (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtcore.
A preparar para desempacotar .../08-python3-pyside2.qtcore_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtcore (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtgui.
A preparar para desempacotar .../09-python3-pyside2.qtgui_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtgui (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtopengl.
A preparar para desempacotar .../10-python3-pyside2.qtopengl_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtopengl (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtwidgets.
A preparar para desempacotar .../11-python3-pyside2.qtwidgets_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtwidgets (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libclang1-6.0:amd64.
A preparar para desempacotar .../12-libclang1-6.0_1%3a6.0-1ubuntu2_amd64.deb ...
A descompactar libclang1-6.0:amd64 (1:6.0-1ubuntu2) ...
A seleccionar pacote anteriormente não seleccionado shiboken2.
A preparar para desempacotar .../13-shiboken2_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar shiboken2 (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pivy.
A preparar para desempacotar .../14-python3-pivy_0.6.4-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pivy (0.6.4-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2.qtsvg.
A preparar para desempacotar .../15-python3-pyside2.qtsvg_5.11.2-0ppa2~ubuntu18.04_amd64.deb ...
A descompactar python3-pyside2.qtsvg (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado python3-pyside2uic.
A preparar para desempacotar .../16-python3-pyside2uic_5.11.2-0ppa2~ubuntu18.04_all.deb ...
A descompactar python3-pyside2uic (5.11.2-0ppa2~ubuntu18.04) ...
A seleccionar pacote anteriormente não seleccionado libhdf5-openmpi-100:amd64.
A preparar para desempacotar .../17-libhdf5-openmpi-100_1.10.0-patch1+docs-4_amd64.deb ...
A descompactar libhdf5-openmpi-100:amd64 (1.10.0-patch1+docs-4) ...
A seleccionar pacote anteriormente não seleccionado libmedc1v5:amd64.
A preparar para desempacotar .../18-libmedc1v5_3.0.6-11build1_amd64.deb ...
A descompactar libmedc1v5:amd64 (3.0.6-11build1) ...
A seleccionar pacote anteriormente não seleccionado libocct-foundation-7.3:amd64.
A preparar para desempacotar .../19-libocct-foundation-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-foundation-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libocct-modeling-data-7.3:amd64.
A preparar para desempacotar .../20-libocct-modeling-data-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-modeling-data-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libocct-modeling-algorithms-7.3:amd64.
A preparar para desempacotar .../21-libocct-modeling-algorithms-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-modeling-algorithms-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libjxr0:amd64.
A preparar para desempacotar .../22-libjxr0_1.1-6build1_amd64.deb ...
A descompactar libjxr0:amd64 (1.1-6build1) ...
A seleccionar pacote anteriormente não seleccionado libfreeimage3:amd64.
A preparar para desempacotar .../23-libfreeimage3_3.17.0+ds1-5build2_amd64.deb ...
A descompactar libfreeimage3:amd64 (3.17.0+ds1-5build2) ...
A seleccionar pacote anteriormente não seleccionado libocct-visualization-7.3:amd64.
A preparar para desempacotar .../24-libocct-visualization-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-visualization-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libocct-ocaf-7.3:amd64.
A preparar para desempacotar .../25-libocct-ocaf-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-ocaf-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libocct-data-exchange-7.3:amd64.
A preparar para desempacotar .../26-libocct-data-exchange-7.3_7.3.0-0ppa4~ubuntu18.04.1_amd64.deb ...
A descompactar libocct-data-exchange-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado libgl2ps1.4.
A preparar para desempacotar .../27-libgl2ps1.4_1.4.0+dfsg1-1_amd64.deb ...
A descompactar libgl2ps1.4 (1.4.0+dfsg1-1) ...
A seleccionar pacote anteriormente não seleccionado libnetcdf-c++4.
A preparar para desempacotar .../28-libnetcdf-c++4_4.2-8_amd64.deb ...
A descompactar libnetcdf-c++4 (4.2-8) ...
A seleccionar pacote anteriormente não seleccionado libvtk7.1.
A preparar para desempacotar .../29-libvtk7.1_7.1.1+dfsg1-2_amd64.deb ...
A descompactar libvtk7.1 (7.1.1+dfsg1-2) ...
A seleccionar pacote anteriormente não seleccionado libzipios++0v5.
A preparar para desempacotar .../30-libzipios++0v5_0.1.5.9+cvs.2007.04.28-10_amd64.deb ...
A descompactar libzipios++0v5 (0.1.5.9+cvs.2007.04.28-10) ...
A seleccionar pacote anteriormente não seleccionado libfreecad-python3-0.18.
A preparar para desempacotar .../31-libfreecad-python3-0.18_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_amd64.deb ...
A descompactar libfreecad-python3-0.18 (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado freecad-python3.
A preparar para desempacotar .../32-freecad-python3_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_amd64.deb ...
A descompactar freecad-python3 (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A seleccionar pacote anteriormente não seleccionado freecad.
A preparar para desempacotar .../33-freecad_2%3a0.18.1+dfsg1~201904061907~ubuntu18.04.1_all.deb ...
A descompactar freecad (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A instalar libocct-foundation-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libnetcdf-c++4 (4.2-8) ...
A instalar libhdf5-openmpi-100:amd64 (1.10.0-patch1+docs-4) ...
A instalar python3-pyside2uic (5.11.2-0ppa2~ubuntu18.04) ...
A processar 'triggers' para mime-support (3.60ubuntu1) ...
A processar 'triggers' para desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
A instalar libshiboken2-py3-5.11 (5.11.2-0ppa2~ubuntu18.04) ...
A instalar libocct-modeling-data-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libzipios++0v5 (0.1.5.9+cvs.2007.04.28-10) ...
A instalar libclang1-6.0:amd64 (1:6.0-1ubuntu2) ...
A instalar libcoin80c (4.0.0~CMake~6f54f1602475+ds1-0ppa1~ubuntu18.04) ...
A instalar libmedc1v5:amd64 (3.0.6-11build1) ...
A instalar libspooles2.2:amd64 (2.2-12build1) ...
A instalar libsoqt520 (1.6.0~ea5cd76+ds1-0ppa1~ubuntu18.04) ...
A instalar libocct-modeling-algorithms-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libjxr0:amd64 (1.1-6build1) ...
A processar 'triggers' para bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...
A processar 'triggers' para man-db (2.8.3-2ubuntu0.1) ...
A processar 'triggers' para shared-mime-info (1.9-2) ...
A processar 'triggers' para gnome-menus (3.13.3-11ubuntu1.1) ...
A instalar shiboken2 (5.11.2-0ppa2~ubuntu18.04) ...
A processar 'triggers' para hicolor-icon-theme (0.17-2) ...
A instalar freecad-common (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A instalar freecad-runtime (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A instalar libgl2ps1.4 (1.4.0+dfsg1-1) ...
A instalar calculix-ccx (2.11-1build1) ...
A instalar libpyside2-py3-5.11 (5.11.2-0ppa2~ubuntu18.04) ...
A instalar libfreeimage3:amd64 (3.17.0+ds1-5build2) ...
A instalar python3-pyside2.qtcore (5.11.2-0ppa2~ubuntu18.04) ...
A instalar libvtk7.1 (7.1.1+dfsg1-2) ...
A instalar python3-pyside2.qtgui (5.11.2-0ppa2~ubuntu18.04) ...
A instalar python3-pyside2.qtsvg (5.11.2-0ppa2~ubuntu18.04) ...
A instalar libocct-visualization-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar python3-pyside2.qtopengl (5.11.2-0ppa2~ubuntu18.04) ...
A instalar python3-pyside2.qtwidgets (5.11.2-0ppa2~ubuntu18.04) ...
A instalar python3-pivy (0.6.4-0ppa2~ubuntu18.04) ...
A instalar libocct-ocaf-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libocct-data-exchange-7.3:amd64 (7.3.0-0ppa4~ubuntu18.04.1) ...
A instalar libfreecad-python3-0.18 (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A instalar freecad-python3 (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
update-alternatives: a usar /usr/lib/freecad/bin/freecad-python3 para disponibilizar /usr/bin/freecad (freecad) em modo auto
A instalar freecad (2:0.18.1+dfsg1~201904061907~ubuntu18.04.1) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...
my native language is not English, please excuse me any incorrectness, I apologize for any inconvenience caused, thank you
User avatar
sgrogan
Posts: 5242
Joined: Wed Oct 22, 2014 5:02 pm

Re: PPA problem updating to Release of 0.18

Postby sgrogan » Thu Apr 11, 2019 1:42 am

Renato Rebelo wrote:
Thu Apr 11, 2019 12:53 am
no messages on startup
Does qgis still work? I'm baffled.
jmaustpc
Posts: 9558
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: PPA problem updating to Release of 0.18

Postby jmaustpc » Thu Apr 11, 2019 3:56 am

I know it probably doesn't help much but, I just now updated and everything is working fine on kubuntu 18.04 64bit.

OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 3.6.7
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Australia (en_AU)

comments, that may also be irrelevant,
1) being English language I don't have any non-ascii characters, nor spaces, etc. in any of my directories.
2) My Kubuntu has "Universe" enabled, I think standard Ubuntu does not enable Universe by default, but I could be wrong.
3) I originally had Py2 version, I installed freecad-python3 and removed freecad-python2 from my system a week or so ago, but I have just noticed that libfreecad-python2-0.18 is still on my system, so I just removed it, still no problems so I started to wonder if it was something to do with one of its dependencies. So I "apt depends libfreecad-python2-0.18" and the same for libfreecad-python3-0.18 and compared the two in two tabs in Kate (kde text editor). As you would expect their dependencies are the same except for

libpyside2-5.11 versus libpyside2-py3-5.11
libpython2.7 (>=5.7.0) versus libpython3.6 (>=3.6.5)
libshiboken2-5.11 versus libshiboken2-py3-5.11

4)I also have the "now old" FreeCAD 0.18 from FreeCAD daily, it installs depends including various qt4 stuff, Py2, Py2 shiboken, Py2 Pyside, libvtk6.3 etc.

so regarding 2), 3) and 4), I wonder if there is any chance that one of those various dependencies etc. is making my "FreeCAD release ppa" version of FreeCAD 0.18.1 work without the errors others are seeing? If you wanted to test this theory you could try installing 'FreeCAD-daily" from the "daily FreeCAD PPA" and/or install lib "libfreecad-python2-0.18". Also check that the Ubuntu universe repository is enabled in your package manager.

By the way "apt-get" is deprecate in Ubuntu 18.04, its replacement is "apt" which for many things works the same way as "apt-get" but apparently has some extra features and advantages.
Renato Rebelo
Posts: 255
Joined: Mon May 19, 2014 1:14 pm
Location: Vouzela - Portugal

Re: PPA problem updating to Release of 0.18

Postby Renato Rebelo » Thu Apr 11, 2019 4:37 pm

sgrogan wrote:
Thu Apr 11, 2019 1:42 am
Renato Rebelo wrote:
Thu Apr 11, 2019 12:53 am
no messages on startup
Does qgis still work? I'm baffled.
yes
my native language is not English, please excuse me any incorrectness, I apologize for any inconvenience caused, thank you
Renato Rebelo
Posts: 255
Joined: Mon May 19, 2014 1:14 pm
Location: Vouzela - Portugal

Re: PPA problem updating to Release of 0.18

Postby Renato Rebelo » Thu Apr 11, 2019 4:57 pm

jmaustpc wrote:
Thu Apr 11, 2019 3:56 am
I know it probably doesn't help much but, I just now updated and everything is working fine on kubuntu 18.04 64bit.

OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 3.6.7
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Australia (en_AU)

comments, that may also be irrelevant,
1) being English language I don't have any non-ascii characters, nor spaces, etc. in any of my directories.
2) My Kubuntu has "Universe" enabled, I think standard Ubuntu does not enable Universe by default, but I could be wrong.
3) I originally had Py2 version, I installed freecad-python3 and removed freecad-python2 from my system a week or so ago, but I have just noticed that libfreecad-python2-0.18 is still on my system, so I just removed it, still no problems so I started to wonder if it was something to do with one of its dependencies. So I "apt depends libfreecad-python2-0.18" and the same for libfreecad-python3-0.18 and compared the two in two tabs in Kate (kde text editor). As you would expect their dependencies are the same except for

libpyside2-5.11 versus libpyside2-py3-5.11
libpython2.7 (>=5.7.0) versus libpython3.6 (>=3.6.5)
libshiboken2-5.11 versus libshiboken2-py3-5.11

4)I also have the "now old" FreeCAD 0.18 from FreeCAD daily, it installs depends including various qt4 stuff, Py2, Py2 shiboken, Py2 Pyside, libvtk6.3 etc.

so regarding 2), 3) and 4), I wonder if there is any chance that one of those various dependencies etc. is making my "FreeCAD release ppa" version of FreeCAD 0.18.1 work without the errors others are seeing? If you wanted to test this theory you could try installing 'FreeCAD-daily" from the "daily FreeCAD PPA" and/or install lib "libfreecad-python2-0.18". Also check that the Ubuntu universe repository is enabled in your package manager.

By the way "apt-get" is deprecate in Ubuntu 18.04, its replacement is "apt" which for many things works the same way as "apt-get" but apparently has some extra features and advantages.
Hello,
tried what you suggested without success ...
and then I decided to install everything in the freecad daily repository to see what happens and this warning came up:

Code: Select all

W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qt3dlogic:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qtwebchannel:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtconcurrent:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qttexttospeech:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtwebenginewidgets:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qt3dlogic:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qtwebchannel:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtconcurrent:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qttexttospeech:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtwebenginewidgets:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qt3dlogic:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qtwebchannel:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtconcurrent:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qttexttospeech:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtwebenginewidgets:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qt3dlogic:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qtwebchannel:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtconcurrent:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qttexttospeech:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtwebenginewidgets:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qt3dlogic:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python-pyside2.qtwebchannel:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtconcurrent:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qttexttospeech:amd64'.
W: Sources disagree on hashes for supposely identical version '5.11.2-0ppa2~ubuntu18.04' of 'python3-pyside2.qtwebenginewidgets:amd64'.
my native language is not English, please excuse me any incorrectness, I apologize for any inconvenience caused, thank you
User avatar
sgrogan
Posts: 5242
Joined: Wed Oct 22, 2014 5:02 pm

Re: PPA problem updating to Release of 0.18

Postby sgrogan » Thu Apr 11, 2019 5:00 pm

What does

Code: Select all

import sys
for p in sys.path: 
    print p
in the python console yield?