[Résolu]PPA cassé

Forum destiné aux questions et discussions en français
Forum rules
Règles du forum et informations utiles.

VEUILLEZ LIRE CECI AVANT DE DEMANDER DE L'AIDE
JeffWitz
Posts: 49
Joined: Fri Mar 27, 2015 9:14 am

Re: PPA cassé

Postby JeffWitz » Mon Apr 22, 2019 9:49 am

Merci NormandC pour ta réponse, je savais que tu trouverais le problème, c'est bien pour cela que j'ai posté en Français.

Je vais regarder cela demain au travail et je te tiendrais au courant.
JeffWitz
Posts: 49
Joined: Fri Mar 27, 2015 9:14 am

Re: PPA cassé

Postby JeffWitz » Tue Apr 23, 2019 8:37 am

Bon, jai fait ce qui m'a été proposé, et j'en suis au même point avec une base de données cassée, mais le message semble différent !

Code: Select all

 sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés : 
  libocct-data-exchange-7.3 libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3
  libocct-visualization-7.3
Les NOUVEAUX paquets suivants seront installés :
  libocct-data-exchange-7.3 libocct-foundation-7.3 libocct-modeling-algorithms-7.3 libocct-modeling-data-7.3 libocct-ocaf-7.3
  libocct-visualization-7.3
0 mis à jour, 6 nouvellement installés, 0 à enlever et 0 non mis à jour.
48 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/18,0 Mo dans les archives.
Après cette opération, 67,0 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 540996 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libocct-foundation-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-foundation-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-foundation-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKMath.so.7 », qui appartient aussi au paquet libopencascade-foundation-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-modeling-data-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-modeling-data-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-modeling-data-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKGeomBase.so.7 », qui appartient aussi au paquet libopencascade-modeling-data-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-modeling-algorithms-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-modeling-algorithms-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-modeling-algorithms-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKPrim.so.7 », qui appartient aussi au paquet libopencascade-modeling-algorithms-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-visualization-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-visualization-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-visualization-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKOpenGl.so.7 », qui appartient aussi au paquet libopencascade-visualization-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Préparation du dépaquetage de .../libocct-ocaf-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-ocaf-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-ocaf-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKCAF.so.7 », qui appartient aussi au paquet libopencascade-ocaf-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Préparation du dépaquetage de .../libocct-data-exchange-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb ...
Dépaquetage de libocct-data-exchange-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-data-exchange-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKXmlXCAF.so.7 », qui appartient aussi au paquet libopencascade-data-exchange-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu11) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libocct-foundation-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
 /var/cache/apt/archives/libocct-modeling-data-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
 /var/cache/apt/archives/libocct-modeling-algorithms-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
 /var/cache/apt/archives/libocct-visualization-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
 /var/cache/apt/archives/libocct-ocaf-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
 /var/cache/apt/archives/libocct-data-exchange-7.3_7.3.0-0ppa4~ubuntu16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
JeffWitz
Posts: 49
Joined: Fri Mar 27, 2015 9:14 am

Re: PPA cassé

Postby JeffWitz » Tue Apr 23, 2019 8:40 am

Visiblement, c'est opencascade cette fois qui pose problème.

Je n'ai pas d'autre PPA qui contient libocct

Code: Select all

Les paquets suivants contiennent des dépendances non satisfaites :
 libfreecad-python2-0.18 : Dépend: libocct-data-exchange-7.3 mais ne sera pas installé
                           Dépend: libocct-foundation-7.3 mais ne sera pas installé
                           Dépend: libocct-modeling-algorithms-7.3 mais ne sera pas installé
                           Dépend: libocct-modeling-data-7.3 mais ne sera pas installé
                           Dépend: libocct-ocaf-7.3 mais ne sera pas installé
                           Dépend: libocct-visualization-7.3 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
JeffWitz
Posts: 49
Joined: Fri Mar 27, 2015 9:14 am

Re: PPA cassé

Postby JeffWitz » Tue Apr 23, 2019 8:46 am

Si cela arrive à quelqu'un d'autre, la bonne solution pour récupérer sa base de donnée est de lancer les commandes

Code: Select all

sudo add-apt-repository --remove ppa:freecad-maintainers/freecad-stable
sudo apt-get update
sudo apt-get purge libfreecad-python2-0.18 freecad-python2 freecad
sudo apt-get autoremove --purge
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: PPA cassé

Postby NormandC » Tue Apr 30, 2019 2:15 am

JeffWitz wrote:
Mon Apr 22, 2019 9:49 am
Merci NormandC pour ta réponse, je savais que tu trouverais le problème, c'est bien pour cela que j'ai posté en Français.
Et pourtant tu as été chanceux que je réponde, je n'ai pratiquement pas posté dans le forum français depuis l'année dernière et j'ai à peine le temps de le survoler. Le meilleur moyen d'attirer mon attention (mais surtout d'obtenir de l'aide quant aux problèmes de paquets des dépôts PPA) est de poster dans les forums anglophones où de toute façon « toute l'action se passe », sans compter que plusieurs autres peuvent y répondre, y compris le mainteneur actuel des PPA (kkremitzki).

JeffWitz wrote:
Tue Apr 23, 2019 8:37 am

Code: Select all

tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKMath.so.7 », qui appartient aussi au paquet libopencascade-foundation-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
C'est la source du problème : les vieux paquets libopencascade-*-7.1.0 étaient encore installés sur ton système et entraient en conflit avec les paquets libocct-*-7.3.0 qui les remplacent. Le mainteneur actuel a décidé de renommer les paquets pour faire plus court, mais il a omis de définir un conflit avec les anciens paquets (afin qu'ils soient automatiquement supprimés lors de la mise à jour). Je l'en ai avisé, et ce sera corrigé dans la prochaine version des paquets.

Par ailleurs je crois qu'on peut s'attendre d'ici peu à une nouvelle mise à jour des paquets 0.18.1 pour corriger le problème de l'icône de document FreeCAD manquante.
JeffWitz
Posts: 49
Joined: Fri Mar 27, 2015 9:14 am

Re: PPA cassé

Postby JeffWitz » Tue Apr 30, 2019 10:09 am

Merci, je posterais sur le forum Anglais à l'avenir.

Je vais donc attendre un peu.
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: PPA cassé

Postby NormandC » Wed May 01, 2019 4:49 am

Pour info, de nouvelles versions des paquets freecad et libocct ont été publiées aujourd'hui et devraient corriger les ennuis de mise à niveau. Malheureusement, le correctif pour l'icône de document n'a pas été ajouté.
openBrain
Posts: 2409
Joined: Fri Nov 09, 2018 5:38 pm

Re: PPA cassé

Postby openBrain » Wed May 01, 2019 7:57 am

NormandC wrote:
Wed May 01, 2019 4:49 am
Malheureusement, le correctif pour l'icône de document n'a pas été ajouté.
C'est honteux. Où sont les bénévoles qui passent de leur temps libre à packager pour qu'on puisse leur jeter des pierres ? :lol: :twisted:
JeffWitz
Posts: 49
Joined: Fri Mar 27, 2015 9:14 am

Re: PPA cassé

Postby JeffWitz » Thu May 09, 2019 9:40 am

Malheureusement, cela ne fonctionne toujours pas ...

Code: Select all

(Lecture de la base de données... 541002 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libocct-foundation-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb ...
Dépaquetage de libocct-foundation-7.3:amd64 (7.3.0+dfsg1-5~ubuntu16.04.2) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-foundation-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKMath.so.7 », qui appartient aussi au paquet libopencascade-foundation-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-modeling-data-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb ...
Dépaquetage de libocct-modeling-data-7.3:amd64 (7.3.0+dfsg1-5~ubuntu16.04.2) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-modeling-data-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKGeomBase.so.7 », qui appartient aussi au paquet libopencascade-modeling-data-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-modeling-algorithms-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb ...
Dépaquetage de libocct-modeling-algorithms-7.3:amd64 (7.3.0+dfsg1-5~ubuntu16.04.2) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-modeling-algorithms-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKMesh.so.7 », qui appartient aussi au paquet libopencascade-modeling-algorithms-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Préparation du dépaquetage de .../libocct-visualization-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb ...
Dépaquetage de libocct-visualization-7.3:amd64 (7.3.0+dfsg1-5~ubuntu16.04.2) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-visualization-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKService.so.7 », qui appartient aussi au paquet libopencascade-visualization-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Préparation du dépaquetage de .../libocct-ocaf-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb ...
Dépaquetage de libocct-ocaf-7.3:amd64 (7.3.0+dfsg1-5~ubuntu16.04.2) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-ocaf-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKCDF.so.7 », qui appartient aussi au paquet libopencascade-ocaf-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Préparation du dépaquetage de .../libocct-data-exchange-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb ...
Dépaquetage de libocct-data-exchange-7.3:amd64 (7.3.0+dfsg1-5~ubuntu16.04.2) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libocct-data-exchange-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/x86_64-linux-gnu/libTKSTEP209.so.7 », qui appartient aussi au paquet libopencascade-data-exchange-7.1.0:amd64 7.1.0-0ppa1~ubuntu16.04.1
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu11) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libocct-foundation-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb
 /var/cache/apt/archives/libocct-modeling-data-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb
 /var/cache/apt/archives/libocct-modeling-algorithms-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb
 /var/cache/apt/archives/libocct-visualization-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb
 /var/cache/apt/archives/libocct-ocaf-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb
 /var/cache/apt/archives/libocct-data-exchange-7.3_7.3.0+dfsg1-5~ubuntu16.04.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
User avatar
flachyjoe
Posts: 632
Joined: Sat Mar 31, 2012 12:00 pm
Location: Limoges, France

Re: PPA cassé

Postby flachyjoe » Thu May 09, 2019 10:58 am

JeffWitz : Tu as une interférence entre les paquets libopencascade 7.1 et libocct 7.3, solution possible :

Code: Select all

sudo apt-get remove --purge libopencascade-*
- Flachy Joe -
alias FFW @ irc.freenode.net #freecad et #freecad-fr
"Puisqu’on ne peut changer la direction du vent, il faut apprendre à orienter les voiles." Anonyme