[Solved] Possible to Disable Auto Switching to Tasks Tab?

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
rebeltaz
Posts: 69
Joined: Wed Apr 03, 2019 5:03 pm

[Solved] Possible to Disable Auto Switching to Tasks Tab?

Postby rebeltaz » Wed Jul 10, 2019 3:00 am

Is it possible to keep FreeCAD from automatically switching to the [Tasks] tab when switching workbenches?
Last edited by Kunda1 on Sun Jul 14, 2019 2:47 pm, edited 1 time in total.
openBrain
Posts: 1962
Joined: Fri Nov 09, 2018 5:38 pm

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby openBrain » Thu Jul 11, 2019 12:02 pm

Here it stays on the Model tab (if this one is active) when switching between workbenches...
What is your version ? Could you try to reset your custom settings ?
rebeltaz
Posts: 69
Joined: Wed Apr 03, 2019 5:03 pm

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby rebeltaz » Fri Jul 12, 2019 2:19 am

I reset my custom settings :( and that didn't help. The version is 0.18.1 under Ubuntu 18.04 LTS
chrisb
Posts: 18218
Joined: Tue Mar 17, 2015 9:14 am

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby chrisb » Fri Jul 12, 2019 6:20 am

Perhaps the reason for this behaviour is similar to what I have seen on two different Mac systems: Some events seem to double fire. DeepSOIC has worked on this, so you may try a current 0.19 version.
If the issue persists, try different Mouse Models. Please report back with your full FreeCAD infos included.
rebeltaz
Posts: 69
Joined: Wed Apr 03, 2019 5:03 pm

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby rebeltaz » Fri Jul 12, 2019 6:35 am

chrisb wrote:
Fri Jul 12, 2019 6:20 am
Please report back with your full FreeCAD infos included.
Where would I find this?
chrisb
Posts: 18218
Joined: Tue Mar 17, 2015 9:14 am

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby chrisb » Fri Jul 12, 2019 6:40 am

rebeltaz wrote:
Fri Jul 12, 2019 6:35 am
Where would I find this?
Point 4 following the IMPORTANT link on the top of the page.
rebeltaz
Posts: 69
Joined: Wed Apr 03, 2019 5:03 pm

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby rebeltaz » Fri Jul 12, 2019 6:57 am

Ah...

OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 3.6.7
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)
chrisb
Posts: 18218
Joined: Tue Mar 17, 2015 9:14 am

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby chrisb » Fri Jul 12, 2019 7:15 am

So it remains to reproduce this in a current 0.19 version.
openBrain
Posts: 1962
Joined: Fri Nov 09, 2018 5:38 pm

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby openBrain » Fri Jul 12, 2019 11:30 am

...And try with another Mouse Model as you also suggested above. ;)
rebeltaz
Posts: 69
Joined: Wed Apr 03, 2019 5:03 pm

Re: Possible to Disable Auto Switching to Tasks Tab?

Postby rebeltaz » Fri Jul 12, 2019 4:15 pm

openBrain wrote:
Fri Jul 12, 2019 11:30 am
...And try with another Mouse Model as you also suggested above. ;)
I did try another mouse mode last night. I just didn't want to reply back with that until after I tried the .19 pre-release. WIth a different mouse mode, I still have the same issue.

I may want to clarify something. The "switching to the tasks tab" seems to be only when I switch to the "Parts Design" workbench. I haven't tried all of the work benches but I will do that this weekend.