Help. Render with povray does not work

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
User avatar
dcapeletti
Posts: 383
Joined: Wed Jul 23, 2014 2:27 pm

Help. Render with povray does not work

Postby dcapeletti » Thu Aug 01, 2019 10:49 pm

Hi, I'm using the Render workbench. I'm currently trying to render the attached file. But for some reason I don't know, the render doesn't happen.

I'm using povray as a rendering engine.

I attach the file of the object I want to render. The payments I make are as follows:
1- I create a povray project. I select the template povray_standart.pov.
2- I put the project in perspective view.
3- I select the objects, in this case the gear body and I give to create a render with the selected objects.
4- Now I press the green ball to render the project and nothing happens. There are no messages, nothing at all.

Is there something I need to do or am I doing wrong?

I enclose the file to render with a copy of the render module configuration. I downloaded the povray executable from http://www.povray.org/ftp/pub/povray/Ol ... ux-3.6.tgz

I hope you can help me.

Thanks

OS: Debian GNU/Linux 9 (stretch) (GNOME/default)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.17445 (Git) AppImage
Build type: Release
Branch: master
Hash: 741dddf25485f692596faa9b7911e2e0f5d362a3
Python version: 3.7.3
Qt version: 5.9.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Spanish/Argentina (es_AR)
Attachments
Engranaje.FCStd
(620.55 KiB) Downloaded 11 times
Config render.png
Config render.png (74.75 KiB) Viewed 237 times
User avatar
dcapeletti
Posts: 383
Joined: Wed Jul 23, 2014 2:27 pm

Re: Help. Render with povray does not work

Postby dcapeletti » Fri Aug 02, 2019 10:35 am

I've been looking at the module code, but it will take me even longer to understand how it works. Even making a simple cube doesn't work, the point is that it doesn't produce any images.
User avatar
yorik
Site Admin
Posts: 11510
Joined: Tue Feb 17, 2009 9:16 pm
Location: São Paulo, Brazil
Contact:

Re: Help. Render with povray does not work

Postby yorik » Fri Aug 02, 2019 2:11 pm

There is probably something wrong/missing with your povray install... I remember, long time ago, that povray was unable to write png files outside its own folder unless you turned some variable on.. :roll: Not sure it still applies...

One thing you can do to test: in <your FreeCAD modules folder>/Render/renderers/Povray.py, at line 147, just before the line that begins with os.system, add this line:

Code: Select all

print("executing",prefix+rpath+" "+args+project.PageResult)
So when running the render, you'll get in the python console the exact command that gets executed. You can copy it and run it from a terminal, we might see better what's wrong...
User avatar
dcapeletti
Posts: 383
Joined: Wed Jul 23, 2014 2:27 pm

Re: Help. Render with povray does not work

Postby dcapeletti » Fri Aug 02, 2019 10:34 pm

Hey, thanks for your help. The message that appeared is:

Code: Select all

executing /home/dcapeletti/Descargas/povlinux-3.6/povray-3.6/povray +P +A +W800 +H600 /tmp/FreeCAD_Doc_396fb32a-e799-47d8-a351-c9df0ce82e99_da39a3_15911/PovrayProjectnx5kogjp.pov
Now everything works fine. I installed povray using apt-get. I had done it before by unzipping the directory I had downloaded from the url I had previously passed and pointing the configuration to the executable. Now instead, point the executable to /usr/bin/povray.

Now it works well with:

Code: Select all

executing /usr/bin/povray +P +A +W800 +H600 /tmp/FreeCAD_Doc_396fb32a-e799-47d8-a351-c9df0ce82e99_da39a3_15911/PovrayProjectnx5kogjp.pov
Thank you, problem solved. :)
User avatar
dcapeletti
Posts: 383
Joined: Wed Jul 23, 2014 2:27 pm

Re: Help. Render with povray does not work

Postby dcapeletti » Fri Aug 02, 2019 11:08 pm

Well after all, I attach the result of the rendering of different workbenches. You can see the differences, maybe the light or the material is not well calibrated.

The gear is the file I attached in the first post.

Thanks
Attachments
Render result.png
Render result.png (257.34 KiB) Viewed 165 times