NaviCube: improved style

A forum for research and development of the user interface of FreeCAD

Moderator: agryson

triplus
Posts: 9431
Joined: Mon Dec 12, 2011 4:45 pm

Re: NaviCube: improved style

Postby triplus » Tue Oct 08, 2019 4:08 am

This is how it currently looks on my side:
Sample.png
Sample.png (5.11 KiB) Viewed 677 times
P.S. I guess there is still some room left, for improvements.
adrianinsaval
Posts: 327
Joined: Thu Apr 05, 2018 5:15 pm

Re: NaviCube: improved style

Postby adrianinsaval » Tue Oct 08, 2019 9:44 pm

triplus wrote:
Sat Oct 05, 2019 6:19 pm
Cube.png

I noticed something familiar in OCCT 7.4 release notes.
The offset between the axis and the cube is really nice, in FreeCAD it's sometimes hard to see the axis as they don't have this offset.

vocx wrote:
Mon Oct 07, 2019 2:44 am
At least the text should look better.
+1 maybe using bold text would improve readability?
steve123
Posts: 30
Joined: Fri Sep 04, 2015 8:58 pm

Re: NaviCube: improved style

Postby steve123 » Sat Feb 01, 2020 8:10 pm

There is a problem with the rendering of the navigation cube on macOS. I have attached a screenshot. If you look closely, you can see that the desktop shows behind the nav cube (there is a "PDF printer" icon on the desktop underneath the FreeCAD window at that screen location). It appears that the transparency extends beyond the canvas all the way to the desktop.
Screen Shot 2020-02-01 at 1.06.25 PM.png
Screen Shot 2020-02-01 at 1.06.25 PM.png (14.12 KiB) Viewed 371 times
DanielLeeWenger
Posts: 13
Joined: Sun Feb 02, 2020 4:02 am

Re: NaviCube: improved style

Postby DanielLeeWenger » Sun Feb 02, 2020 4:18 am

I too have a similar problem. The document window is transparent. The desktop behind FreeCAD is fully visible.

OS: macOS Mojave (10.14)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.19405 (Git)
Build type: Release
Branch: master
Hash: d2b943e8b7d8fe2673a4e20671b6cb0f8180fdbd
Python version: 3.8.1
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)
steve123
Posts: 30
Joined: Fri Sep 04, 2015 8:58 pm

Re: NaviCube: improved style

Postby steve123 » Sun Feb 02, 2020 7:13 pm

I can also get the desktop to show through an object on the canvas as well by hovering over an element in the model tree. In the screen shot below, if I mouse over the object in the document window, you cannot see the background. If you hover over the element in the model tree, the desktop shows through as can be seen in the screen shot.
Screen Shot 2020-02-02 at 12.03.56 PM.png
Screen Shot 2020-02-02 at 12.03.56 PM.png (63.21 KiB) Viewed 312 times
fc_tofu
Posts: 521
Joined: Sun Jan 05, 2020 4:56 pm

Re: NaviCube: improved style

Postby fc_tofu » Mon Feb 03, 2020 1:24 pm

steve123 wrote:
Sun Feb 02, 2020 7:13 pm
I can also get the desktop to show through an object on the canvas as well by hovering over an element in the model tree. In the screen shot below, if I mouse over the object in the document window, you cannot see the background. If you hover over the element in the model tree, the desktop shows through as can be seen in the screen shot.
Screen Shot 2020-02-02 at 12.03.56 PM.png
version and os please.
triplus
Posts: 9431
Joined: Mon Dec 12, 2011 4:45 pm

Re: NaviCube: improved style

Postby triplus » Mon Feb 03, 2020 2:42 pm

And if the navigation cube is turned off in the preferences, the issue still persists?

P.S. Highly likely this is GPU drivers related.
steve123
Posts: 30
Joined: Fri Sep 04, 2015 8:58 pm

Re: NaviCube: improved style

Postby steve123 » Tue Feb 04, 2020 5:09 pm

Version information is in my earlier post above (copied here):

OS: macOS Mojave (10.14)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.19405 (Git)
Build type: Release
Branch: master
Hash: d2b943e8b7d8fe2673a4e20671b6cb0f8180fdbd
Python version: 3.8.1
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)
triplus
Posts: 9431
Joined: Mon Dec 12, 2011 4:45 pm

Re: NaviCube: improved style

Postby triplus » Tue Feb 04, 2020 6:59 pm

That doesn't help me. If you go under:

Edit -> Preferences ... -> Display -> and uncheck the Show navigation cube checkbox.

Does the issue with the transparency still exists? If yes, that is likely not related to navigation cube, but to some other setting or to GPU drivers.
steve123
Posts: 30
Joined: Fri Sep 04, 2015 8:58 pm

Re: NaviCube: improved style

Postby steve123 » Thu Feb 06, 2020 3:16 pm

If I turn off the navigation cube in preferences, I can still see through the canvas to the desktop when I mouse over an element in the model view.