0.19 Daily Build update fail

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
Post Reply
alberich
Posts: 54
Joined: Thu Aug 17, 2017 2:09 pm
Location: Texas

0.19 Daily Build update fail

Post by alberich » Fri Oct 04, 2019 4:32 pm

When attempting to update my 0.19 daily on

Code: Select all

OS: Linux Mint 19.1 (MATE/mate)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.
Build type: Release
Python version: 3.6.8
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)
I get a failure with this message

Code: Select all

E: /tmp/apt-dpkg-install-ogJ3dW/1-freecad-daily-runtime_0.19~pre1~201910032155~ubuntu18.04.1_all.deb: trying to overwrite '/usr/share/freecad-daily/Mod/Arch/Presets/ifc_products_IFC2X3.json', which is also in package freecad-daily-common 0.19~pre1~201910032155~ubuntu18.04.1
Seems like a packaging problem.

vocx
Posts: 3965
Joined: Thu Oct 18, 2018 9:18 pm

Re: 0.19 Daily Build update fail

Post by vocx » Sat Oct 05, 2019 5:21 am

alberich wrote:
Fri Oct 04, 2019 4:32 pm
...
Seems like a packaging problem.
vocx wrote:
Sat Oct 05, 2019 4:11 am
Yes, the main packager is looking into this at the moment. The daily package has been broken for about a month. So hold tight, in the following days and weeks you should expect to see more daily updates, maybe with errors still. If you really need to use the latest code, probably the AppImage or self compilation (CompileOnUnix) is a better option at the moment.

old TempoVis.py in recent builds
kkremitzki wrote:
Fri Oct 04, 2019 10:02 pm
I removed those because, in my testing trying to fix the builds, I was getting errors about them not being present. There's a bug somewhere screwing with all this.
kkremitzki wrote:
Sat Oct 05, 2019 12:27 am
That was the idea with the distinction between freecad-runtime and freecad-common files, with freecad-runtime being meant to solely have Python files. But there's no need for that, in retrospect, so eventually I'll combine the two and just have freecad-common, I think. With 0.19 there will be a break in the binary packages, i.e. libfreecad-python3-0.18 will have its name changed, so that would be a good time to do it.
Always add the important information to your posts if you need help.
To support the documentation effort, and code development, your donation is appreciated: paypal.

alberich
Posts: 54
Joined: Thu Aug 17, 2017 2:09 pm
Location: Texas

Re: 0.19 Daily Build update fail

Post by alberich » Sat Oct 05, 2019 10:40 am

vocx wrote:
Sat Oct 05, 2019 4:11 am
Yes, the main packager is looking into this at the moment. The daily package has been broken for about a month. So hold tight, in the following days and weeks you should expect to see more daily updates, maybe with errors still. If you really need to use the latest code, probably the AppImage or self compilation (CompileOnUnix) is a better option at the moment.

old TempoVis.py in recent builds
Gracias por la info. I'll just wait it out.

User avatar
pl7i92LCNC
Posts: 209
Joined: Tue Mar 12, 2019 3:03 pm
Location: RLP DE

Re: 0.19 Daily Build update fail

Post by pl7i92LCNC » Sat Oct 05, 2019 6:33 pm

i got over this as i used the Appimage as long as this mess is up
THANKS to all that try to fix this

alberich
Posts: 54
Joined: Thu Aug 17, 2017 2:09 pm
Location: Texas

Re: 0.19 Daily Build update fail

Post by alberich » Sun Oct 06, 2019 12:58 pm

pl7i92LCNC wrote:
Sat Oct 05, 2019 6:33 pm
i got over this as i used the Appimage as long as this mess is up
THANKS to all that try to fix this
Yes. That's also what I decided to do. I removed freecad-daily so the update notices for the defective package would stop, then I installed the latest 0.19 appimage. All is well now.

Post Reply