New libpacks for Windows with Qt5.15, OCC7.5

Having trouble installing or compiling FreeCAD? Get help here.
User avatar
HakanSeven12
Posts: 1065
Joined: Wed Feb 06, 2019 10:30 pm

Re: New libpacks for Windows with Qt5.12.6, OCC7.4

Post by HakanSeven12 » Wed Nov 11, 2020 11:09 pm

HakanSeven12 wrote:
Tue Jun 23, 2020 7:36 am
Can someone update pivy for LP? With Conda build SoGeo classes working fine. But LP build gives error.

Code: Select all

During initialization the error "module 'pivy.coin' has no attribute 'SoGeoCoordinate'" occurred in freecad.trails
--------------------------------------------------------------------------------
Traceback (most recent call last):
  File "<string>", line 148, in InitApplications
  File "importlib\__init__.py", line 126, in import_module
  File "<frozen importlib._bootstrap>", line 994, in _gcd_import
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 678, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  ...
  File "C:\Users\thomas.schrader\AppData\Roaming\FreeCAD\Mod\Trails\pivy_trackers\pivy_trackers\coin\coin_enums.py", line 342, in NodeTypes
    GEO_COORDINATE = coin.SoGeoCoordinate
AttributeError: module 'pivy.coin' has no attribute 'SoGeoCoordinate'
--------------------------------------------------------------------------------
I noticed this issue months ago. LP versions doesn't support SoGeo nodes. This nodes are my workbench dependences. If someone can fix it that would be great. Conda versions doesn't have this issue.

User avatar
sgrogan
Posts: 6205
Joined: Wed Oct 22, 2014 5:02 pm

Re: New libpacks for Windows with Qt5.12.6, OCC7.4

Post by sgrogan » Wed Nov 11, 2020 11:17 pm

HakanSeven12 wrote:
Wed Nov 11, 2020 11:09 pm
I noticed this issue months ago. LP versions doesn't support SoGeo nodes. This nodes are my workbench dependences. If someone can fix it that would be great. Conda versions doesn't have this issue.
Can you please post here: https://forum.freecadweb.org/viewtopic.php?f=42&t=52043
"fight the good fight"

User avatar
apeltauer
Posts: 359
Joined: Fri Aug 11, 2017 2:19 pm

Re: New libpacks for Windows with Qt5.12.6, OCC7.4

Post by apeltauer » Thu Dec 03, 2020 2:24 pm


kisolre
Posts: 2936
Joined: Wed Nov 21, 2018 1:13 pm

Re: New libpacks for Windows with Qt5.15, OCC7.5

Post by kisolre » Fri Dec 11, 2020 1:57 pm

Not sure if it is related to the LibPack or the new compiler so decided to post here. I made a fresh build to try the latest 12.4.2 libpack and Visual Studio 2019. All went well (ALL_BUILD, INSTALL) but when I run that newly built FreeCAD without any command line parameters I get 3 error windows about unrecognized command line option:
.
Unrecognized option m.JPG
Unrecognized option m.JPG (79.83 KiB) Viewed 418 times
.

FreeCAD then runs normally.
Here is also the report view output if it is relevant:

Code: Select all

15:47:18  OpenGL version is: 4.6 (4.6.0 NVIDIA 445.75)
15:47:18  Run Gui init script
15:47:18  Init: Running FreeCADGuiInit.py start script...
15:47:18  Init:   Searching modules...
15:47:19  Init:      Initializing E:\FC_Local\Mod\AddonManager... done
15:47:19  Init:      Initializing E:\FC_Local\Mod\Arch... done
15:47:19  Init:      Initializing E:\FC_Local\Mod\Draft... done
15:47:19  Init:      Initializing E:\FC_Local\Mod\Drawing... done
15:47:19  Init:      Initializing E:\FC_Local\Mod\Fem... done
15:47:19  Init:      Initializing E:\FC_Local\Mod\Idf(InitGui.py not found)... ignore
15:47:19  Init:      Initializing E:\FC_Local\Mod\Image... done
15:47:19  Init:      Initializing E:\FC_Local\Mod\Import... done
15:47:19  Init:      Initializing E:\FC_Local\Mod\Inspection... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Material... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Measure(InitGui.py not found)... ignore
15:47:20  Init:      Initializing E:\FC_Local\Mod\Mesh... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\MeshPart... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\OpenSCAD... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Part... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\PartDesign... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Path... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Points... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Raytracing... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\ReverseEngineering... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Robot... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Show(InitGui.py not found)... ignore
15:47:20  Init:      Initializing E:\FC_Local\Mod\Sketcher... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Spreadsheet... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Start... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Surface... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\TechDraw... done
15:47:20  Init:      Initializing E:\FC_Local\Mod\Test... done
15:47:21  Init:      Initializing E:\FC_Local\Mod\Tux... done
15:47:21  Init:      Initializing E:\FC_Local\Mod\Web... done
15:47:21  Module: Part
15:47:21  Loading Part module... done
15:47:21  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\A2plus... done
15:47:21  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\ArchTextures... done
15:47:21  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Assembly4... done
15:47:21  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Autoload... done
15:47:21  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\BIM... done
15:47:21  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\BOLTSFC(InitGui.py not found)... ignore
15:47:21  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\CfdOF... done
15:47:21  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\CubeMenu... done
15:47:22  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\CurvedShapes... done
15:47:22  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Curves... done
15:47:22  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\CycloidGearBox... done
15:47:22  Loading Path module... done
15:47:22  Loading PathStock... done
15:47:22  Loading Sketcher module... done
15:47:22  Loading PathToolControllerGui... done
15:47:22  Loading PathToolController... done
15:47:22  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Defeaturing... done
15:47:22  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\dodo... done
15:47:22  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\DynamicData... done
15:47:23  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\ExplodedAssembly... done
15:47:23  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\fasteners... done
15:47:23  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\FCGear(InitGui.py not found)... ignore
15:47:23  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\flamingo... failed
15:47:23  ----------------------------------------------------------------------------------------------------
15:47:23  Traceback (most recent call last):
  File "<string>", line 131, in InitApplications
  File "<string>", line 25, in <module>
  File "<string>", line 30, in flamingoToolsWorkbench
  File "E:\FC_Local\bin\Lib\site-packages\shiboken2\files.dir\shibokensupport\__feature__.py", line 142, in _import
    return original_import(name, *args, **kwargs)
ModuleNotFoundError: No module named 'DraftSnap'
15:47:23  ----------------------------------------------------------------------------------------------------
15:48:08  During initialization the error "No module named 'DraftSnap'" occurred in C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\flamingo\InitGui.py
15:48:08  Please look into the log file for further information
15:48:08  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\InventorLoader... failed
15:48:08  ----------------------------------------------------------------------------------------------------
15:48:08  Traceback (most recent call last):
  File "<string>", line 131, in InitApplications
  File "<string>", line 56, in <module>
  File "<string>", line 46, in checkImports
  File "E:\FC_Local\bin\Lib\site-packages\shiboken2\files.dir\shibokensupport\__feature__.py", line 142, in _import
    return original_import(name, *args, **kwargs)
  File "C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\InventorLoader\importerUtils.py", line 14, in <module>
    from olefile       import OleFileIO
  File "E:\FC_Local\bin\Lib\site-packages\shiboken2\files.dir\shibokensupport\__feature__.py", line 142, in _import
    return original_import(name, *args, **kwargs)
ModuleNotFoundError: No module named 'olefile'
15:48:08  ----------------------------------------------------------------------------------------------------
15:48:09  During initialization the error "No module named 'olefile'" occurred in C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\InventorLoader\InitGui.py
15:48:09  Please look into the log file for further information
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\kicadStepUpMod... done
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\lattice2... done
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Manipulator... done
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Mechatronic... done
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\MeshRemodel... done
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Mod.rar(InitGui.py not found)... ignore
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\modlist.txt(InitGui.py not found)... ignore
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\modlist2019_09_26.txt(InitGui.py not found)... ignore
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\modlist_2019.09.28.txt(InitGui.py not found)... ignore
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\parts_library(InitGui.py not found)... ignore
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Plot(InitGui.py not found)... ignore
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Render... done
15:48:09  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\sheetmetal... done
15:48:10  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\Silk... done
15:48:10  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\symbols_library(InitGui.py not found)... ignore
15:48:10  Init:      Initializing C:\Users\Wivern\AppData\Roaming\FreeCAD\Mod\ThreadProfile... done
15:48:10  Init: Initializing freecad.plot
15:48:10  Init: Initializing freecad.plot... done
15:48:10  Init: Initializing freecad.gears
15:48:10  Init: Initializing freecad.gears... done
15:48:10  Init: Loading FreeCAD GUI
15:48:11  Init: Running FreeCADGuiInit.py start script... done
15:48:12  Init: Activating default workbench StartWorkbench
15:48:12  Loading PartDesign module... done
15:48:12  Loading GUI of Part module... done
15:48:12  Loading GUI of Sketcher module... done
15:48:12  Loading GUI of PartDesign module... done
15:48:12  Init: Showing main window
15:48:12  Main window restored
15:48:12  Show main window
15:48:12  Toolbars restored
15:48:12  3Dconnexion device not attached.
15:48:12  Init: Entering event loop
15:48:15  Init: Processing command line files
15:48:15  Loading Draft workbench, done.
15:48:15  Draft workbench activated.
15:48:15  Draft workbench deactivated.
15:48:15  Checking for available updates of the DynamicData addon

Code: Select all

OS: Windows 8.1 Version 6.3 (Build 9600)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23307 (Git)
Build type: Release
Branch: master
Hash: 9add3ba199c01f5f6ff4eae60557c4b22b625940
Python version: 3.8.6+
Qt version: 5.15.1
Coin version: 4.0.1
OCC version: 7.5.0
Locale: Bulgarian/Bulgaria (bg_BG)
Edit: the parameter issue is gone with

Code: Select all

OS: Windows 8.1 Version 6.3 (Build 9600)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23323 (Git)
Build type: Release
Branch: master
Hash: 512d5c6141aec52b6eecc67370336a28fde862a6
Python version: 3.8.6+
Qt version: 5.15.1
Coin version: 4.0.1
OCC version: 7.5.0
Locale: Bulgarian/Bulgaria (bg_BG)

kisolre
Posts: 2936
Joined: Wed Nov 21, 2018 1:13 pm

Re: New libpacks for Windows with Qt5.15, OCC7.5

Post by kisolre » Mon Dec 14, 2020 6:04 pm

Something else that I noticed - my local built FreeCAD with this LibPack uses a lot more memory then the downloaded ones. Started at the same time, no file loaded or any interaction, from top to bottom - LP build, Conda build, local build:
.
PrivateMemory.JPG
PrivateMemory.JPG (29.71 KiB) Viewed 360 times
.
Conda info:
OS: Windows 8.1 (6.3)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23258 (Git)
Build type: Release
Branch: master
Hash: 78c6cc1362c39e3f1f778c52ae2a1c82badeec20
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: Bulgarian/Bulgaria (bg_BG)

LP info:
OS: Windows 8.1 (6.3)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23266 (Git)
Build type: Release
Branch: master
Hash: ed063646edb2803b035b800e645e0bfa5384d980
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Bulgarian/Bulgaria (bg_BG)

Local build info:
OS: Windows 8.1 Version 6.3 (Build 9600)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23327 (Git)
Build type: Release
Branch: master
Hash: 68eba58e649e83842cc3bfe24b8c5981e317213f
Python version: 3.8.6+
Qt version: 5.15.1
Coin version: 4.0.1
OCC version: 7.5.0
Locale: Bulgarian/Bulgaria (bg_BG)

Post Reply