FEM constraints not on object when using placement (part design workbench)

About the development of the FEM module/workbench.

Moderator: bernd

LSoltmann
Posts: 5
Joined: Sun Jul 19, 2020 3:19 pm

FEM constraints not on object when using placement (part design workbench)

Post by LSoltmann » Sun Jul 19, 2020 3:54 pm

Not sure if this is a bug or limitation or I'm just not doing this correctly. Let say I make a 1x1x1in cube using the part design workbench, create a FEM analysis using the FEM workbench, and then add a fixed and force constraint to the cube. In this scenario, everything works/looks as expected.
Screen Shot 2020-07-19 at 8.36.40 AM.png
Screen Shot 2020-07-19 at 8.36.40 AM.png (128.81 KiB) Viewed 594 times
However, if before you add the constraints you move the cube 1in in the y-direction using the placement property and then add the constraints to the same locations on the cube as in the previous case, they aren't attached to the location you specified.
Screen Shot 2020-07-19 at 8.43.55 AM.png
Screen Shot 2020-07-19 at 8.43.55 AM.png (146.6 KiB) Viewed 594 times
Is this a bug or limitation? It doesn't appear to matter if you move the cube before or after applying the constrains, the result is the same and in that the constraint graphics only show as if the part were still at the global origin. Running the FEM analysis confirms that the constrains are in fact not on the object.

Thanks,
Lars

OS: macOS Mojave (10.14)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21857 (Git)
Build type: Release
Branch: master
Hash: 750c169a6cb999f084915494f2fbec7c07297aae
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)
Last edited by LSoltmann on Mon Jul 20, 2020 11:13 pm, edited 2 times in total.
jmaustpc
Posts: 10367
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: FEM constraints not on object when using placement

Post by jmaustpc » Sun Jul 19, 2020 4:04 pm

Hi and welcome to FreeCAD.

I have no idea if it will effect you or not but there is an update available for OSX, its now 0.19.21938, so 81 commits more, like I said though I have no idea if it effect you.
LSoltmann
Posts: 5
Joined: Sun Jul 19, 2020 3:19 pm

Re: FEM constraints not on object when using placement

Post by LSoltmann » Sun Jul 19, 2020 7:34 pm

Tried the newest build (0.19.21938) but the problem still exists.

OS: macOS Mojave (10.14)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21938 (Git)
Build type: Release
Branch: master
Hash: 5666598a6be219830a992610243fe23144a61453
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)
jmaustpc
Posts: 10367
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: FEM constraints not on object when using placement

Post by jmaustpc » Mon Jul 20, 2020 5:17 am

LSoltmann wrote:
Sun Jul 19, 2020 7:34 pm
Tried the newest build (0.19.21938) but the problem still exists.

OS: macOS Mojave (10.14)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21938 (Git)
Build type: Release
Branch: master
Hash: 5666598a6be219830a992610243fe23144a61453
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)
OK, I will move this topic to the FEM development forum to help bring it to the attention of one of the FEM experts/developers.

Thanks for testing in the update first.

Jim
thschrader
Posts: 1903
Joined: Sat May 20, 2017 12:06 pm
Location: Germany

Re: FEM constraints not on object when using placement

Post by thschrader » Mon Jul 20, 2020 4:58 pm

LSoltmann wrote:
Sun Jul 19, 2020 3:54 pm
Not sure if this is a bug or limitation or I'm just not doing this correctly.
....
Confirmed. When using part-design the fixing/load/mesh does not move after moving the body.
Use the sketcher/part-wb to create the body, that works.
(thats why I like the part-wb)
moving_constraints_and_mesh.JPG
moving_constraints_and_mesh.JPG (98.94 KiB) Viewed 510 times
done with:
OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21937 (Git)
Build type: Release
Branch: master
Hash: 0de5a290113800dc5779a76d7e216bd882e0ed1e
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)
User avatar
bernd
Posts: 10956
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: FEM constraints not on object when using placement

Post by bernd » Mon Jul 20, 2020 7:29 pm

It is a known problem PartDesign and FEM may work or may not work together properly. I do not use PartDesign. I even do not know how to use PartDesign. I only use Arch, Draft and Part to make geometry. Furthermore most of this kind of problems need to be fixed in FEMs C++ code. Thus I do not fix most problems in this regard.

Best is to make a bug report and clearly state it is about FEM not working with PartDesign. Latelly we had similar problems, see https://forum.freecadweb.org/viewtopic. ... 79#p415042
User avatar
bernd
Posts: 10956
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: FEM constraints not on object when using placement

Post by bernd » Mon Jul 20, 2020 7:31 pm

@LSoltermann:

would be good if you could change the topic subject to something which contains PartDesign, as this only is a problem if PartDesign body is used?
LSoltmann
Posts: 5
Joined: Sun Jul 19, 2020 3:19 pm

Re: FEM constraints not on object when using placement

Post by LSoltmann » Mon Jul 20, 2020 11:10 pm

Thanks for the confirmation. I'll make sure to use the part workbench when using FEM.
LSoltmann
Posts: 5
Joined: Sun Jul 19, 2020 3:19 pm

Re: FEM constraints not on object when using placement (part design workbench)

Post by LSoltmann » Fri Jul 24, 2020 4:49 pm

I found a workaround for this issue until it can be fixed. Export the part design object to a STEP file, import the STEP file, apply the constraints to the newly imported object. Now the constraints follow the object as it's moved using placement.
Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest