error when accessing the Assembly 4 workbench

Discussion about the development of the Assembly workbench.
Post Reply
dwebman
Posts: 5
Joined: Wed Jan 08, 2020 6:44 pm

error when accessing the Assembly 4 workbench

Post by dwebman » Wed Jan 08, 2020 6:52 pm

OS: Ubuntu 16.04
Freecad Version: 0.19 freecad-daily:
Installed: 0.19~pre2~202001071536~ubuntu16.04.1
Candidate: 0.19~pre2~202001071536~ubuntu16.04.1
Version table:
*** 0.19~pre2~202001071536~ubuntu16.04.1 500
500 http://ppa.launchpad.net/freecad-mainta ... ily/ubuntu xenial/main i386 Packages
100 /var/lib/dpkg/status
The error is:
Workbench failure
Internal C++ object (PySide.QtGui.QToolBar) already deleted.
Traceback (most recent call last):
File "<string>", line 223, in Activated

Any ideas or advice?
vocx
Posts: 2829
Joined: Thu Oct 18, 2018 9:18 pm

Re: error when accessing the Assembly 4 workbench

Post by vocx » Thu Jan 09, 2020 12:24 am

dwebman wrote:
Wed Jan 08, 2020 6:52 pm
OS: Ubuntu 16.04
...
Internal C++ object (PySide.QtGui.QToolBar) already deleted.
Traceback (most recent call last):
File "<string>", line 223, in Activated
Any ideas or advice?
This sounds like it could be a problem with your version of Qt.

Since you are using an old version of Ubuntu, maybe some features don't work if you don't use a reasonably recent Qt, like Qt 5.9. I think most users are using some version between 5.9 and 5.12.

Why not upgrading to Ubuntu 18.04? FreeCAD works quite well in this version.
To support the documentation effort, and code development, your donation is appreciated: paypal.
dwebman
Posts: 5
Joined: Wed Jan 08, 2020 6:44 pm

Re: error when accessing the Assembly 4 workbench

Post by dwebman » Thu Jan 09, 2020 6:12 am

Thank you. I'll try the upgrade of Ubuntu.
Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests