Rename: Part_Booleans to Part_Boolean

Discussions about the wiki documentation of FreeCAD and its translation.
Post Reply
vocx
Posts: 3956
Joined: Thu Oct 18, 2018 9:18 pm

Rename: Part_Booleans to Part_Boolean

Post by vocx » Wed Mar 18, 2020 6:56 am

The Part_Booleans (plural) page should be renamed to Part_Boolean (singular).

The name of the wiki page must match the sWhatsThis value.

https://github.com/FreeCAD/FreeCAD/blob ... 1275-L1287

Code: Select all

DEF_STD_CMD_A(CmdPartBoolean)

CmdPartBoolean::CmdPartBoolean()
  :Command("Part_Boolean")
{
    sAppModule    = "Part";
    sGroup        = QT_TR_NOOP("Part");
    sMenuText     = QT_TR_NOOP("Boolean...");
    sToolTipText  = QT_TR_NOOP("Run a boolean operation with two shapes selected");
    sWhatsThis    = "Part_Boolean";
    sStatusTip    = sToolTipText;
    sPixmap       = "Part_Booleans";
}
The icon name is "Part_Booleans", however, the command itself is named "Part_Boolean" in singular, and thus the wiki page should use this same name.
Always add the important information to your posts if you need help.
To support the documentation effort, and code development, your donation is appreciated: paypal.
renatorivo
Posts: 2439
Joined: Tue Feb 21, 2012 8:07 pm
Location: Torino - Italy

Re: Rename: Part_Booleans to Part_Boolean

Post by renatorivo » Fri Mar 20, 2020 10:23 pm

Done
vocx
Posts: 3956
Joined: Thu Oct 18, 2018 9:18 pm

Re: Rename: Part_Booleans to Part_Boolean

Post by vocx » Fri Mar 20, 2020 11:45 pm

renatorivo wrote:
Fri Mar 20, 2020 10:23 pm
Done
You have to leave a redirection, otherwise many pages will get broken links.
Always add the important information to your posts if you need help.
To support the documentation effort, and code development, your donation is appreciated: paypal.
Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests