Help Debugging 0.16 please...

Having trouble installing or compiling FreeCAD? Get help here.
gntech
Posts: 49
Joined: Tue May 23, 2017 9:03 am

Re: Help Debugging 0.16 please...

Post by gntech » Thu Apr 12, 2018 4:30 pm

I have the same problem on Ubuntu. This problem is somehow related to DRI3. See https://forums.opensuse.org/showthread. ... ost2861858

A workaround is to either disable DRI3 for all applications by adding the following line to /etc/environment

Code: Select all

LIBGL_DRI3_DISABLE=true
Or to disable DRI3 just for Freecad by launching freecad from the terminal with the following command.

Code: Select all

LIBGL_DRI3_DISABLE=true freecad
triplus
Posts: 8422
Joined: Mon Dec 12, 2011 4:45 pm

Re: Help Debugging 0.16 please...

Post by triplus » Thu Apr 12, 2018 8:25 pm

Hi @gntech.

I guess this confirms there is some issue concerning graphic driver/stack involved. I searched a bit and it does look like a lot of users are affected by this. This will likely result in a fix/workaround being applied upstream (Mesa or Xorg or wherever it is needed) a bit sooner. And thanks for sharing the workaround. I am sure in the following months more FreeCAD users will emerge and suggesting to disable DRI3 support with environment variable will likely do it for them too.
gntech wrote:
Thu Apr 12, 2018 4:30 pm
Or to disable DRI3 just for Freecad by launching freecad from the terminal with the following command.
Note that you could modify the FreeCAD launcher. Like we did back in the days when pixel bufferers were trending:

https://forum.freecadweb.org/viewtopic. ... 503#p27326
Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests