Help with Installing Freecad 0.18 Plugin on Linux

Having trouble installing or compiling FreeCAD? Get help here.
Post Reply
TOMCAD
Posts: 5
Joined: Mon Mar 16, 2020 12:50 pm

Help with Installing Freecad 0.18 Plugin on Linux

Post by TOMCAD » Tue Mar 17, 2020 2:17 pm

Hello,
I am trying to install the Inventor loader plugin https://github.com/jmplonka/InventorLoader
I can't do this from the Application loader in 0.18 due to missing library files.

I have cloned the github project to my drive.
I have unzipped the libs.zip file and try to run the ./installLibs.py from terminal it gives me the modulenotfounderror: No module found called Freecad.
Following this link https://forum.freecadweb.org/viewtopic.php?t=37099 I copied the symbolic links into the freecad-Python3 folder, but that didn't fix the error.

I'm new to linux so I'm sure I'm doing something wrong.
I do know that running "python --version" reports back "Python 3.6.9"

Interesting, I just noticed that the python version reported by the terminal and what is reported by Freecad doesn't match. Maybe that is my whole problem. Terminal is reporting 3.6.9 while Freecad is displaying 3.6.8

OS: Ubuntu 18.04.4 LTS
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.18.4.
Build type: Release
Python version: 3.6.8
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

Thanks for any help you can provide.
TOMCAD
Posts: 5
Joined: Mon Mar 16, 2020 12:50 pm

Re: Help with Installing Freecad 0.18 Plugin on Linux

Post by TOMCAD » Fri Mar 27, 2020 2:22 am

Bump
Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests