Ubuntu 19.10 install issues

Having trouble installing or compiling FreeCAD? Get help here.
Post Reply
alterself
Posts: 1
Joined: Sun Mar 22, 2020 11:19 pm

Ubuntu 19.10 install issues

Post by alterself » Sun Mar 22, 2020 11:27 pm

TLDR; installed libglvnd0 is too new (1.3.1-1)

while libopengl0 wants 1.1.1. Tried to downgrade to 1.1.1, but that appears to break all sorts of QT/kde stuff

truncated dependency apt install walk:

Code: Select all

root@owner-desktop:~# apt install freecad
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
freecad : Depends: freecad-python3 but it is not going to be installed
...
freecad-python3 : Depends: python3-pivy but it is not going to be installed
                   Depends: libfreecad-python3-0.18 (< 2:0.18.4+dfsg1~201911060031~ubuntu19.10.1+1~) but it is not going to be installed
                   Depends: libfreecad-python3-0.18 (>= 2:0.18.4+dfsg1~201911060031~ubuntu19.10.1) but it is not going to be installed
...
python3-pivy : Depends: libcoin80c but it is not going to be installed
                Depends: libsoqt520 but it is not going to be installed
...
libcoin80c : Depends: libopengl0 but it is not going to be installed
...
libopengl0 : Depends: libglvnd0 (= 1.1.1-0ubuntu1) but 1.3.1-1~oibaf~e is to be installed
...
libglvnd0 is already the newest version (1.3.1-1~oibaf~e).
Any thoughts on how to go about resolving these library issues? I realize most/all of this is outside of FreeCAD directly, but the system is fairly stock and 100% working otherwise.
vocx
Posts: 3962
Joined: Thu Oct 18, 2018 9:18 pm

Re: Ubuntu 19.10 install issues

Post by vocx » Mon Mar 23, 2020 1:52 am

alterself wrote:
Sun Mar 22, 2020 11:27 pm
Any thoughts on how to go about resolving these library issues? I realize most/all of this is outside of FreeCAD directly, but the system is fairly stock and 100% working otherwise.
How are you installing FreeCAD, and what version? That's the most important aspect.

FreeCAD works pretty well on LTS versions like 18.04. If you have no luck with the dependencies, you should try the AppImage.
Always add the important information to your posts if you need help.
To support the documentation effort, and code development, your donation is appreciated: paypal.
Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests