appimage

Here's the place for discussion related to coding in FreeCAD, C++ or Python. Design, interfaces and structures.
looo
Posts: 2234
Joined: Mon Nov 11, 2013 5:29 pm

Re: appimage

Postby looo » Mon Feb 11, 2019 4:04 am

I corrected this one. But this simple hides the report that matplotlib is missing...
User avatar
fosselius
Posts: 267
Joined: Sat Apr 23, 2016 10:03 am

Re: appimage

Postby fosselius » Mon Feb 11, 2019 8:36 pm

triplus wrote:
Sun Feb 10, 2019 6:13 pm
Please test again with latest Conda AppImage.
I did test, menu looks fine! icons is still wrong, have not tested the "fix" posted earlier in this thread.
But i think my issues are QT related rather then "appimage" specific?
Screenshot from 2019-02-11 21-29-00.png
Screenshot from 2019-02-11 21-29-00.png (40.78 KiB) Viewed 113 times
however i did notice another issue, the text input box in sketcher is to slim.
Screenshot from 2019-02-11 21-29-39.png
Screenshot from 2019-02-11 21-29-39.png (9.7 KiB) Viewed 113 times
minor note: splash screen is a "white box" (actually what ever covered area that is rendered), 80% of load time, then the correct graphics is showed for a brief moment before application launches.
Screenshot from 2019-02-11 21-36-51.png
Screenshot from 2019-02-11 21-36-51.png (17.95 KiB) Viewed 111 times
FreeCAD_0.18.15823_Conda_Py3Qt5_glibc2.12-x86_64.AppImage

OS: Ubuntu 18.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15823 (Git) AppImage
Build type: Release
Branch: master
Hash: 2ac0851d4cffa351ca8da06779e14b7f9be2173d
Python version: 3.6.7
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)
triplus
Posts: 7927
Joined: Mon Dec 12, 2011 4:45 pm

Re: appimage

Postby triplus » Tue Feb 12, 2019 11:34 pm

fosselius wrote:
Mon Feb 11, 2019 8:36 pm
I did test, menu looks fine!
Good to hear that.
icons is still wrong, have not tested the "fix" posted earlier in this thread.
Why not?
however i did notice another issue, the text input box in sketcher is to slim.
Could be desktop theme related issue like seen here.
User avatar
fosselius
Posts: 267
Joined: Sat Apr 23, 2016 10:03 am

Re: appimage

Postby fosselius » Thu Feb 14, 2019 6:04 am

triplus wrote:
Tue Feb 12, 2019 11:34 pm
icons is still wrong, have not tested the "fix" posted earlier in this thread.
Why not?

Code: Select all

p = FreeCAD.ParamGet("User parameter:BaseApp/Preferences/Bitmaps/Theme")
p.SetString("Name", "None")
Did not have time before, just made a quick test.
Did try it today and pasting the above code in the python console and then restarting FreeCAD did give me the correct icons.