[Solved][Ubuntu PPA] freecad-0.16 can't be installed alongside freecad-stable

Having trouble installing or compiling FreeCAD? Get help here.
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

[Solved][Ubuntu PPA] freecad-0.16 can't be installed alongside freecad-stable

Postby NormandC » Tue Apr 10, 2018 2:12 am

@sgrogan

The freecad-0.16 package from the freecad-legacy PPA won't install if freecad from the freecad-stable PPA is installed. There's an icon conflict.

Code: Select all

E: /var/cache/apt/archives/freecad-0.16_1%3a0.16.6712-0ppa5~ubuntu16.04.1_amd64.deb: attempt to replace "/usr/share/icons/hicolor/64x64/mimetypes/application-x-extension-fcstd.png", which is also owned by package freecad 1:0.17.13509-1ppa2~ubuntu16.04.1
This is caused by the last line in the debian/rules file, which has the same destination for both.

https://git.launchpad.net/~freecad-main ... elease#n48
https://git.launchpad.net/~freecad-main ... legacy#n48

Code: Select all

override_dh_icons:
	install -m 644 debian/freecad/usr/share/freecad/freecad-icon-16.png debian/freecad/usr/share/icons/hicolor/16x16/apps/freecad.png
	install -m 644 debian/freecad/usr/share/freecad/freecad-icon-32.png debian/freecad/usr/share/icons/hicolor/32x32/apps/freecad.png
	install -m 644 debian/freecad/usr/share/freecad/freecad-icon-32.png debian/freecad/usr/share/icons/hicolor/48x48/apps/freecad.png
	install -m 644 debian/freecad/usr/share/freecad/freecad-icon-64.png debian/freecad/usr/share/icons/hicolor/64x64/apps/freecad.png
	install -m 644 debian/freecad/usr/share/freecad/freecad.svg debian/freecad/usr/share/icons/hicolor/scalable/apps/freecad.svg
	install -m 644 debian/freecad/usr/share/freecad/freecad-doc.png debian/freecad/usr/share/icons/hicolor/64x64/mimetypes/application-x-extension-fcstd.png
The conflict was solved in the freecad-daily package by deleting the last line. But this means that if freecad-daily is the only package installed, no icon is defined for fcstd documents.
kkremitzki wrote:ping
Would you have an idea how to solve that?
Last edited by NormandC on Thu Apr 12, 2018 11:01 am, edited 1 time in total.
User avatar
sgrogan
Posts: 6166
Joined: Wed Oct 22, 2014 5:02 pm

Re: [Ubuntu PPA] freecad-0.16 can't be installed alongside freecad-stable

Postby sgrogan » Tue Apr 10, 2018 10:34 pm

NormandC wrote:
Tue Apr 10, 2018 2:12 am
The conflict was solved in the freecad-daily package by deleting the last line. But this means that if freecad-daily is the only package installed, no icon is defined for fcstd documents.
Should I do this temporarily?
"fight the good fight"
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: [Ubuntu PPA] freecad-0.16 can't be installed alongside freecad-stable

Postby NormandC » Wed Apr 11, 2018 1:10 am

Yes, we have to do something, it's not ideal but we know it'll work. I figure if people install the freecad-0.16 package, they already installed the latest freecad one, so the application-x-extension icon will already be installed.

You'll be interested to know I found a script to get download stats from the PPA... I was very surprised by the numbers! Not Windows territory of course, but pretty respectable. We're providing freecad packages to a lot more Ubuntu users than I thought.

Just for the freecad-stable PPA, there were 156,500 downloads since 2013. That includes all the packages made from 0.13.1830 to 0.16.6712.
chrisb
Posts: 29146
Joined: Tue Mar 17, 2015 9:14 am

Re: [Ubuntu PPA] freecad-0.16 can't be installed alongside freecad-stable

Postby chrisb » Wed Apr 11, 2018 6:11 am

NormandC wrote:
Wed Apr 11, 2018 1:10 am
You'll be interested to know I found a script to get download stats from the PPA... I was very surprised by the numbers! Not Windows territory of course, but pretty respectable. We're providing freecad packages to a lot more Ubuntu users than I thought.

Just for the freecad-stable PPA, there were 156,500 downloads since 2013. That includes all the packages made from 0.13.1830 to 0.16.6712.
That an interesting number. Does this include updates or is it new installations? I don't even know if it can be distinguished.

Edit: I have seen that you posted details here: https://forum.freecadweb.org/viewtopic.php?f=8&t=28010
A Sketcher Lecture with in-depth information is available in English, auf deutsch, en français, en español.
User avatar
sgrogan
Posts: 6166
Joined: Wed Oct 22, 2014 5:02 pm

Re: [Ubuntu PPA] freecad-0.16 can't be installed alongside freecad-stable

Postby sgrogan » Wed Apr 11, 2018 8:56 pm

NormandC wrote:
Wed Apr 11, 2018 1:10 am
Yes, we have to do something, it's not ideal but we know it'll work.
Does it work now?
"fight the good fight"
User avatar
NormandC
Posts: 18534
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: [Ubuntu PPA] freecad-0.16 can't be installed alongside freecad-stable

Postby NormandC » Thu Apr 12, 2018 2:46 am

Thanks, it works now.

So I now have installed

freecad-0.16 (freecad-legacy)
freecad-0.17.13509 (freecad-stable)
freecad-0.18~beta (freecad-daily)
freecad compiled from source

Is that too much freecad? :D
User avatar
sgrogan
Posts: 6166
Joined: Wed Oct 22, 2014 5:02 pm

Re: [Ubuntu PPA] freecad-0.16 can't be installed alongside freecad-stable

Postby sgrogan » Thu Apr 12, 2018 10:34 am

NormandC wrote:
Thu Apr 12, 2018 2:46 am
Is that too much freecad?
No, I am working on freecad-testing that will be used for the PY3 port. :lol:
"fight the good fight"