.stl file exported is not smooth

Post here for help on using FreeCAD's graphical user interface (GUI).
Lovesuiyuan
Posts: 3
Joined: Thu May 17, 2018 9:14 am

.stl file exported is not smooth

Postby Lovesuiyuan » Thu May 17, 2018 9:31 am

I use the latest FreeCAD 0.17, now I import a step file, then export stl format file.but when I open the stl file exported, I found the model surface is not smooth, I can see obvious edges and corners.
Then I use another 3D software to deal with the same step file, the stl file is very smooth.

other 3D software export file effect as follows:
otherSoftwareEffect.png
oherSoftwareEffect
otherSoftwareEffect.png (171.1 KiB) Viewed 206 times
FreeCAD export file effect as follows:
FreeCADEffect.png
FreeCAD stl file effect
FreeCADEffect.png (162.99 KiB) Viewed 206 times
Please Help, so, what should I do to improve the surface effects, any suggestion is appreciate!!
User avatar
bejant
Posts: 4762
Joined: Thu Jul 11, 2013 3:06 pm

Re: .stl file exported is not smooth

Postby bejant » Thu May 17, 2018 10:39 am

Lovesuiyuan wrote:
Thu May 17, 2018 9:31 am
what should I do to improve the surface effects,
Hi Lovesuiyuan, and welcome! You can get smoother surfaces in the .stl Export by using the pull-down menu and changing Edit > Preferences > Part Design (icon in left pane) > Shape view (tab at top of right pane) and changing the "Maximum deviation depending on..." setting from the default setting of 0.5 % to something smaller.

A lower number will make smoother surfaces when the file is Exported to .stl., but the file sizes will be larger. Objects in the 3D view will also appear smoother on your computer monitor, but it will take FreeCAD more time to display them. On complicated models this might make FreeCAD too slow, so after Exporting the .stl you might want to change that "Maximum deviation..." setting back to the default.

(edited typo)
Last edited by bejant on Fri May 18, 2018 3:12 pm, edited 1 time in total.
My Part Design tutorials on YouTube (aimed at beginners). For FreeCAD through release 0.16.
User avatar
HarryGeier
Posts: 476
Joined: Mon Jul 10, 2017 12:36 pm
Location: Hof Germany

Re: .stl file exported is not smooth

Postby HarryGeier » Thu May 17, 2018 12:47 pm

I guess.. you chosse the wrong way or the wrong mesher to create the STL..

look at the end of this video to see how i export STL and they look smooth ...

https://www.youtube.com/watch?v=rgstQi9jpGc&t=280s
Kaum macht man´s richtig , gehts´s
jmaustpc
Posts: 8747
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: .stl file exported is not smooth

Postby jmaustpc » Thu May 17, 2018 2:41 pm

If you convert a solid to a mesh in mesh workbench you will get more control over the triangulation of the resultant mesh than simply exporting as stl. Exporting as stl does so by reading the opengl display triangulation, which is why bejants suggestion works.
jmaustpc
Posts: 8747
Joined: Tue Jul 26, 2011 6:28 am
Location: Australia

Re: .stl file exported is not smooth

Postby jmaustpc » Thu May 17, 2018 2:45 pm

Another tip, don't forget that stl is a lossy format that by definition is impossible to convert properly back to a cad solid format like step etc. Stl has its uses as an output format, but from a cad point of view is a garbage format.
User avatar
oldmachine
Posts: 116
Joined: Wed May 31, 2017 11:49 pm

Re: .stl file exported is not smooth

Postby oldmachine » Thu May 17, 2018 3:34 pm

Change the Tessellation value in the export pref's panel - that is what controls the smoothness...
Attachments
Screen Shot 2018-05-17 at 8.30.57 AM.png
Screen Shot 2018-05-17 at 8.30.57 AM.png (100.76 KiB) Viewed 145 times
MAC OSX Sierra
3D Parts & Links (made using FreeCad and Solidworks): https://www.thingiverse.com/Still_Breathing/designs
Android App & Links: https://play.google.com/store/apps/deta ... .bestknots
User avatar
sgrogan
Posts: 4131
Joined: Wed Oct 22, 2014 5:02 pm

Re: .stl file exported is not smooth

Postby sgrogan » Thu May 17, 2018 8:56 pm

bejant wrote:
Thu May 17, 2018 10:39 am
Hi Lovesuiyuan, and welcome! You can get smoother surfaces in the .stl Export by using the pull-down menu and changing Edit > Preferences > Part Design (icon in left pane) > Shape view (tab at top of right pane) and changing the "Maximum deviation depending on..." setting from the default setting of 0.5 % to something smaller.
For .stl .obj and .amf this is no longer true.
The Shape view only effects the display tessellation in FreeCAD.
The default export tessellation is controlled by Edit > Preferences > Import-Export Mesh Formats tab.
You need to activate the Mesh Design workbench first for the preference option to be available.
This was done so a coarser tessellation can be used for display to keep the FreeCAD gui responsive and to be able to export a very fine tessellation without switching the Shape view preference back and forth.
Lovesuiyuan
Posts: 3
Joined: Thu May 17, 2018 9:14 am

Re: .stl file exported is not smooth

Postby Lovesuiyuan » Fri May 18, 2018 2:40 am

bejant wrote:
Thu May 17, 2018 10:39 am
Lovesuiyuan wrote:
Thu May 17, 2018 9:31 am
what should I do to improve the surface effects,
Hi Lovesuiyuan, and welcome! You can get smoother surfaces in the .stl Export by using the pull-down menu and changing Edit > Preferences > Part Design (icon in left pane) > Shape view (tab at top of right pane) and changing the "Maximum deviation depending on..." setting from the default setting of 0.5 % to something smaller.

A lower number will make smoother surfaces when the file is Exported to .stl., but the file sizes will be larger. Objects in the 3D view will also appear smoother on your computer monitor, but it will take FreeCAD more time to display them. On complicated models this might make slow FreeCAD too slow, so after Exporting the .stl you might want to change that "Maximum deviation..." setting back to the default.
Thank you very much.I use your method, and it works, I get smoother 3D file. it solve my big problem, Thank you again!
Lovesuiyuan
Posts: 3
Joined: Thu May 17, 2018 9:14 am

Re: .stl file exported is not smooth

Postby Lovesuiyuan » Fri May 18, 2018 2:47 am

Thank you for everone, especially bejant.It can be solved by using the pull-down menu and changing Edit > Preferences > Part Design (icon in left pane) > Shape view (tab at top of right pane) and changing the "Maximum deviation depending on..." setting from the default setting of 0.5 % to something smaller.
User avatar
bejant
Posts: 4762
Joined: Thu Jul 11, 2013 3:06 pm

Re: .stl file exported is not smooth

Postby bejant » Fri May 18, 2018 3:19 pm

sgrogan wrote:
Thu May 17, 2018 8:56 pm
The default export tessellation is controlled by Edit > Preferences > Import-Export Mesh Formats tab.
I've never tried that method, but like that it doesn't change the display....

Lovesuiyuan wrote:
Fri May 18, 2018 2:40 am
Thank you very much.
You're welcome, and post back if you need more help.
My Part Design tutorials on YouTube (aimed at beginners). For FreeCAD through release 0.16.