Sweep not following sweep path

Post here for help on using FreeCAD's graphical user interface (GUI).
chrisb
Posts: 10412
Joined: Tue Mar 17, 2015 9:14 am

Re: Sweep not following sweep path

Postby chrisb » Sun Sep 16, 2018 3:10 pm

NormandC wrote:
Sun Sep 16, 2018 2:16 pm
UR_ wrote:
Sun Sep 16, 2018 1:02 pm
But task panels or property editor should reflect all circumstances of creation at least for further editing.
That is just one of many usability issues with PartDesign, unfortunately, this workbench has been orphaned for a year now. Occasionally a developer will create a commit for this workbench, but there is no longer someone dedicated to its development.

chrisb wrote:
Sun Sep 16, 2018 1:51 pm
Of course they should! I think there is a ticket, but you might check.
I just scanned the tracker, I didn't find any (unless it was reported in the wrong project). There's issue #3297 that you reported but it's not completely related to what's discussed here.
Thanks for scanning, I created the issue: issue #3598. 3297 was in fact something different, it was about the selection mechanism itself.
I have classified the ticket as Feature Request, although I would have liked to see it as a very urgent one.
User avatar
NormandC
Posts: 16569
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Sweep not following sweep path

Postby NormandC » Sun Sep 16, 2018 3:24 pm

Aw man, we made duplicates. :oops:

issue #3598 (yours)
issue #3599 (mine)
I had just created issue #3597 for the PD Additive/subtractive loft.
User avatar
meme2704
Posts: 1855
Joined: Sat Apr 01, 2017 2:47 pm
Location: Vosges

Re: Sweep not following sweep path

Postby meme2704 » Sun Sep 16, 2018 3:29 pm

"Mettre en musique"
That means: to implement correctly and harmoniously the work to be done for that is in adequacy with the requirements of PartDesign
corectly do the cylinder and in the right body
correctly draw the triangle (s) of the thread
rightly draw the right helix, and the conic, join them if necessary
do the Subtractive Sweep (s)
chrisb
Posts: 10412
Joined: Tue Mar 17, 2015 9:14 am

Re: Sweep not following sweep path

Postby chrisb » Sun Sep 16, 2018 5:42 pm

NormandC wrote:
Sun Sep 16, 2018 3:24 pm
Aw man, we made duplicates. :oops:
You were later, because you attached an example. My hope is,that it is all there and it is only a visibility thing of the list and setting the mode.
User avatar
NormandC
Posts: 16569
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: Sweep not following sweep path

Postby NormandC » Sat Sep 22, 2018 2:36 pm

wmayer fixed issue #3598 and issue #3599 two days ago in git commit 14b8579a. :D

This is how the Pipe parameters now look like in v0.18.14784.

FC018_Pipe_parameters_issue_3599_fix.png
FC018_Pipe_parameters_issue_3599_fix.png (63.92 KiB) Viewed 21 times

It also fixes something that was bringing confusion: the "Profile" header was on top of the sweep path selection. Now "Profile" is for the first sweep section, and the sweep path has its own header "Path to sweep along", this is much clearer now.

Thank you Werner!

OS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14784 (Git)
Build type: Release
Branch: master
Hash: ac21bcc35c56b360e03c646f5cfdcf15e5769717
Python version: 2.7.15rc1
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/Canada (fr_CA)
chrisb
Posts: 10412
Joined: Tue Mar 17, 2015 9:14 am

Re: Sweep not following sweep path

Postby chrisb » Sat Sep 22, 2018 2:48 pm

Thanks from here too. It turns out that Werner's vacation are really wonderful - for us FreeCAD users.