Installing Qt5 Designer on Linux Mint 19

A forum for research and development of the user interface of FreeCAD

Moderator: agryson

User avatar
regis
Posts: 655
Joined: Sun Jul 12, 2015 8:17 am
Contact:

Installing Qt5 Designer on Linux Mint 19

Postby regis » Sun Feb 10, 2019 2:27 am

Since i've had alot of trouble getting qt5 on my system I thought it would be good to leave a permanent trace of what I did to trouble shoot the problem for anyone who might run into the same situation.

Here is the link that finally provided me with the solution
https://forums.linuxmint.com/viewtopic.php?t=278552
And here is the code to install

Code: Select all

sudo apt install qt5-default qttools5-dev-tools qttools5-dev
I appears you can install it from software center aswell but each of the individual qt's are not compiled into one.
qt5-default
qttools5-dev-tools
qttools5-dev

OS: Linux Mint 19.1 Tessa
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15470 (Git) AppImage
Build type: Release
Branch: master
Hash: ab916fefe74d289ff4439924a83508cad54a8c09
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Canada (en_CA)
Screenshot from 2019-02-09 21-26-04.png
Screenshot from 2019-02-09 21-26-04.png (79.52 KiB) Viewed 572 times