Ich habe eine Installationsproblem mit Freecad

In diesem Forum Fragen und Diskussionen in Deutsch
Forum rules
Foren-Regeln und hilfreiche Informationen

WICHTIG: Bitte zuerst lesen, bevor Sie posten
svenair
Posts: 65
Joined: Sat Nov 29, 2014 2:55 pm

Ich habe eine Installationsproblem mit Freecad

Postby svenair » Sat Feb 15, 2020 11:38 am

Hallo!
Ich habe gerade ein Installationsproblem mit Freecad.
Ursprünglich hatte ich die 0.18.4
Und die Daily Build 0.19
installiert.
Und zwar auf einem Kubuntu 19.04
Irgendwann fiel mir auf, das es gar keine Updates mir für den Daily Build kamen.
Dann hatte ich Freecad über den Paketmanager deinstalliert.
Um es wieder neu zu installiere.
Mittlerweile hab ich nur noch eine OS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 (Git)
Build type: Unknown
Branch: master
Hash: 690774c0effe4fd7b8d2b5e2fb2b8c8d145e21ce
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.0.0
Locale: English/UnitedStates (en_US)

Im Paketmanager finde ich Freecad nicht mehr..

Irgendwas ist da scheinbar kaputtgegangen..

Hat jemand eine Idee, wie man das reparieren kann?

Die Softwarequellen sind richtig eingetragen.
freecad-heini-1
Posts: 6393
Joined: Tue Jan 07, 2014 11:10 am
Contact:

Re: Ich habe eine Installationsproblem mit Freecad

Postby freecad-heini-1 » Sat Feb 15, 2020 1:35 pm

Einfach nochmal drüber bügeln kann nicht schaden.
Daily:

Code: Select all

sudo add-apt-repository ppa:freecad-maintainers/freecad-daily
sudo apt-get update
sudo apt-get install freecad-daily
Stable:

Code: Select all

sudo add-apt-repository ppa:freecad-maintainers/freecad-stable
sudo apt update
sudo apt install freecad freecad-doc
svenair
Posts: 65
Joined: Sat Nov 29, 2014 2:55 pm

Re: Ich habe eine Installationsproblem mit Freecad

Postby svenair » Sat Feb 15, 2020 1:57 pm

Hab ich schon ein paarmal gemacht...

Im Startmenü ist auch kein Freecad Eintrag.

Aber es ist eine alte Version auf dem Rechner..

Kommen denn momentan Daily Builds?

Das war ja der Grund warum ich stutzig wurde..

Habs mal durchlaufen lassen..

sven@sven-P8612:~$ sudo add-apt-repository ppa:freecad-maintainers/freecad-daily
[sudo] Passwort für sven:
Ubuntu daily builds of FreeCAD. These packages are generated by Launchpad's automatic system, and are untested.

Note: the ccx package brings CalculiX support to the FEM workbench, and needs to be installed separately.
More info: https://launchpad.net/~freecad-maintain ... ecad-daily
Press [ENTER] to continue or Ctrl-c to cancel adding it.

OK:1 http://de.archive.ubuntu.com/ubuntu disco InRelease
OK:2 http://ppa.launchpad.net/freecad-mainta ... ily/ubuntu disco InRelease
OK:3 http://de.archive.ubuntu.com/ubuntu disco-updates InRelease
OK:4 http://de.archive.ubuntu.com/ubuntu disco-backports InRelease
OK:5 http://ppa.launchpad.net/freecad-mainta ... ble/ubuntu disco InRelease
OK:6 http://de.archive.ubuntu.com/ubuntu disco-proposed InRelease
OK:7 http://security.ubuntu.com/ubuntu disco-security InRelease
Paketlisten werden gelesen... Fertig
sven@sven-P8612:~$ sudo apt update
OK:1 http://ppa.launchpad.net/freecad-mainta ... ily/ubuntu disco InRelease
OK:2 http://de.archive.ubuntu.com/ubuntu disco InRelease
OK:3 http://security.ubuntu.com/ubuntu disco-security InRelease
OK:4 http://de.archive.ubuntu.com/ubuntu disco-updates InRelease
OK:5 http://ppa.launchpad.net/freecad-mainta ... ble/ubuntu disco InRelease
OK:6 http://de.archive.ubuntu.com/ubuntu disco-backports InRelease
OK:7 http://de.archive.ubuntu.com/ubuntu disco-proposed InRelease
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
sven@sven-P8612:~$ sudo apt install freecad freecad-doc
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paket freecad ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »freecad« existiert kein Installationskandidat.
E: Paket freecad-doc kann nicht gefunden werden.
sven@sven-P8612:~$
Last edited by svenair on Sat Feb 15, 2020 2:34 pm, edited 1 time in total.
freecad-heini-1
Posts: 6393
Joined: Tue Jan 07, 2014 11:10 am
Contact:

Re: Ich habe eine Installationsproblem mit Freecad

Postby freecad-heini-1 » Sat Feb 15, 2020 2:08 pm

svenair wrote:
Sat Feb 15, 2020 1:57 pm
Kommen denn momentan Daily Builds?
Ja, zuletzt gestern um 15:18:16 Uhr, Zeitstempel.

In der Konsole ausführen:

Code: Select all

sudo apt update && sudo apt upgrade && sudo apt dist-upgrade -y
Nix neues.

Was sagt denn der Start aus der Konsole?

Code: Select all

freecad
FreeCAD 0.18.4, Libs: 0.18.4R

Code: Select all

freecad-daily
FreeCAD 0.19, Libs: 0.19R
Viele Grüße
Wilfried
svenair
Posts: 65
Joined: Sat Nov 29, 2014 2:55 pm

Re: Ich habe eine Installationsproblem mit Freecad

Postby svenair » Sat Feb 15, 2020 2:46 pm

freecad-heini-1 wrote:
Sat Feb 15, 2020 2:08 pm
svenair wrote:
Sat Feb 15, 2020 1:57 pm
Kommen denn momentan Daily Builds?
Ja, zuletzt gestern um 15:18:16 Uhr, Zeitstempel.

In der Konsole ausführen:

Code: Select all

sudo apt update && sudo apt upgrade && sudo apt dist-upgrade -y
Nix neues.

E: Für Paket »freecad« existiert kein Installationskandidat.
E: Paket freecad-doc kann nicht gefunden werden.
sven@sven-P8612:~$ sudo apt update && sudo apt upgrade && sudo apt dist-upgrade -y
[sudo] Passwort für sven:
OK:1 http://security.ubuntu.com/ubuntu disco-security InRelease
OK:2 http://de.archive.ubuntu.com/ubuntu disco InRelease
OK:3 http://ppa.launchpad.net/freecad-mainta ... ily/ubuntu disco InRelease
OK:4 http://de.archive.ubuntu.com/ubuntu disco-updates InRelease
OK:5 http://de.archive.ubuntu.com/ubuntu disco-backports InRelease
OK:6 http://ppa.launchpad.net/freecad-mainta ... ble/ubuntu disco InRelease
OK:7 http://de.archive.ubuntu.com/ubuntu disco-proposed InRelease
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
calculix-ccx ibverbs-providers libboost-program-options1.67.0
libboost-regex1.67.0 libcaf-openmpi-3 libclang1-8 libcoarrays-openmpi-dev
libcoin80c libevent-core-2.1-6 libevent-pthreads-2.1-6 libfabric1
libfreeimage3 libgl2ps1.4 libglew2.1 libhdf5-openmpi-103 libhwloc-dev
libhwloc-plugins libhwloc5 libibverbs-dev libibverbs1 libjs-jquery-ui
libjsoncpp1 libjxr0 libmedc11 libnetcdf-c++4 libnl-3-dev
libnl-route-3-200 libnl-route-3-dev libnuma-dev libocct-data-exchange-7.3
libocct-foundation-7.3 libocct-modeling-algorithms-7.3
libocct-modeling-data-7.3 libocct-ocaf-7.3 libocct-visualization-7.3
libopengl0 libopenmpi-dev libopenmpi3 libpmix2 libpsm-infinipath1
libpsm2-2 libpyside2-py3-5.11 librdmacm1 libshiboken2-py3-5.11 libsoqt520
libspnav0 libspooles2.2 libvtk7.1 libzipios++0v5 openmpi-bin
openmpi-common python-matplotlib-data python3-cycler python3-dateutil
python3-kiwisolver python3-matplotlib python3-numpy python3-pivy
python3-pyparsing python3-pyside2.qtcore python3-pyside2.qtgui
python3-pyside2.qtopengl python3-pyside2.qtsvg python3-pyside2.qtuitools
python3-pyside2.qtwidgets python3-pyside2.qtxml python3-pyside2uic
shiboken2
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
calculix-ccx ibverbs-providers libboost-program-options1.67.0
libboost-regex1.67.0 libcaf-openmpi-3 libclang1-8 libcoarrays-openmpi-dev
libcoin80c libevent-core-2.1-6 libevent-pthreads-2.1-6 libfabric1
libfreeimage3 libgl2ps1.4 libglew2.1 libhdf5-openmpi-103 libhwloc-dev
libhwloc-plugins libhwloc5 libibverbs-dev libibverbs1 libjs-jquery-ui
libjsoncpp1 libjxr0 libmedc11 libnetcdf-c++4 libnl-3-dev
libnl-route-3-200 libnl-route-3-dev libnuma-dev libocct-data-exchange-7.3
libocct-foundation-7.3 libocct-modeling-algorithms-7.3
libocct-modeling-data-7.3 libocct-ocaf-7.3 libocct-visualization-7.3
libopengl0 libopenmpi-dev libopenmpi3 libpmix2 libpsm-infinipath1
libpsm2-2 libpyside2-py3-5.11 librdmacm1 libshiboken2-py3-5.11 libsoqt520
libspnav0 libspooles2.2 libvtk7.1 libzipios++0v5 openmpi-bin
openmpi-common python-matplotlib-data python3-cycler python3-dateutil
python3-kiwisolver python3-matplotlib python3-numpy python3-pivy
python3-pyparsing python3-pyside2.qtcore python3-pyside2.qtgui
python3-pyside2.qtopengl python3-pyside2.qtsvg python3-pyside2.qtuitools
python3-pyside2.qtwidgets python3-pyside2.qtxml python3-pyside2uic
shiboken2
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
sven@sven-P8612:
Was sagt denn der Start aus der Konsole?

Code: Select all

freecad
FreeCAD 0.18.4, Libs: 0.18.4R
sven@sven-P8612:~$ sven@sven-P8612:freecad
sven@sven-P8612:freecad: Befehl nicht gefunden.
sven@sven-P8612:~$ FreeCAD 0.18.4, Libs: 0.18.4R
FreeCAD: Befehl nicht gefunden.
sven@sven-P8612:~$

Code: Select all

freecad-daily
FreeCAD 0.19, Libs: 0.19R
sven@sven-P8612:~$ freecad-daily
freecad-daily: Befehl nicht gefunden.
sven@sven-P8612:~$ FreeCAD 0.19, Libs: 0.19R


Viele Grüße
Wilfried
Ich hab den Eindruck ich sollte mit Auto Remove alte Pakete entfernen...?


Viele Grüße Sven
jeno
Posts: 666
Joined: Sun Jun 29, 2014 10:41 am

Re: Ich habe eine Installationsproblem mit Freecad

Postby jeno » Sat Feb 15, 2020 6:50 pm

svenair wrote:
Sat Feb 15, 2020 11:38 am
Hallo!
Ich habe gerade ein Installationsproblem mit Freecad.
Ursprünglich hatte ich die 0.18.4
Und die Daily Build 0.19
installiert.
Und zwar auf einem Kubuntu 19.04
...
Im Paketmanager finde ich Freecad nicht mehr..
Irgendwas ist da scheinbar kaputtgegangen..
Hat jemand eine Idee, wie man das reparieren kann?
Die Softwarequellen sind richtig eingetragen.
Hallo,
es ist insofern nichts kaputt, da 19.04 seit ungefähr drei Wochen das Supportende erreicht hat. Ausserdem ist Freecad vermutlich entfernt worden wegen der Umstellung auf Pyhton 3.
Da wirst du um ein Upgrade auf 19.10 nicht herumkommen. Oder du gehst das Risiko ein und wartest auf 20.04. Aber vermutlich gibt es für deine Version nicht mal mehr Security-Fixes :roll:

Mit freundlichen
svenair
Posts: 65
Joined: Sat Nov 29, 2014 2:55 pm

Re: Ich habe eine Installationsproblem mit Freecad

Postby svenair » Sun Feb 16, 2020 11:44 am

Guter Punkt!
Ich glaube das probiere ich.
Müsste mir nicht normalerweise das Update auf 19.10
vom Paketmanager angeboten werden?


Viele Grüße Sven
jeno
Posts: 666
Joined: Sun Jun 29, 2014 10:41 am

Re: Ich habe eine Installationsproblem mit Freecad

Postby jeno » Sun Feb 16, 2020 12:42 pm

svenair wrote:
Sun Feb 16, 2020 11:44 am
Guter Punkt!
Ich glaube das probiere ich.
Müsste mir nicht normalerweise das Update auf 19.10
vom Paketmanager angeboten werden?
Viele Grüße Sven
Sorry kein (K)Ubnuntu, aber ich glaube default werden nur LTS automatisch angeboten. Der Paketmanager sollte dir da weiter helfen.

Mit freundlichen
freecad-heini-1
Posts: 6393
Joined: Tue Jan 07, 2014 11:10 am
Contact:

Re: Ich habe eine Installationsproblem mit Freecad

Postby freecad-heini-1 » Sun Feb 16, 2020 1:04 pm

jeno wrote:
Sun Feb 16, 2020 12:42 pm
Sorry kein (K)Ubnuntu, aber ich glaube default werden nur LTS automatisch angeboten. Der Paketmanager sollte dir da weiter helfen.

Mit freundlichen
Unter Anwendungen & Aktualisieren ist wahrscheinlich bei "Über neue Ubuntu-Versionen benachrichtigen" "Für Langzeitunterstützungen" voreingestellt. Ändern auf "Für jede neue Version".

https://wiki.ubuntuusers.de/Aktualisierungen/
Image